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INTRODUCTION 
Welcome 

We know training is a vital component of retaining the value of your Microsoft® 
Business Solutions investment. Our quality training from industry experts keeps 
you up-to-date on your solution and helps you develop the skills necessary for 
fully maximizing the value of your solution. Whether you choose Online 
Training, Classroom Training, or Training Materials, there’s a type of training to 
meet everyone’s needs. Choose the training type that best suits you so you can 
stay ahead of the competition. 

Online Training 
Online Training delivers convenient, in-depth training to you in the comfort of 
your own home or office. Online training provides immediate access to training 
24 hours a day. It’s perfect for the customer who doesn’t have the time or budget 
to travel. Our newest online training option, eCourses, combine the efficiency of 
online training with the in-depth product coverage of classroom training, with at 
least two weeks to complete each course. 

Classroom Training 
Classroom Training provides serious, in-depth learning through hands-on 
interaction. From demonstrations to presentations to classroom activities, you’ll 
receive hands-on experience with instruction from our certified staff of experts. 
Regularly scheduled throughout North America, you can be sure you’ll find a 
class convenient for you. 

Training Materials 
Training Materials enable you to learn at your own pace, on your own time with 
information-packed training manuals. Our wide variety of training manuals 
feature an abundance of tips, tricks, and insights you can refer to again and again: 
 
Microsoft Business Solutions Courseware: The Microsoft Business Solutions 
Courseware are very detailed training manuals, designed from a training 
perspective. These manuals include advanced topics as well as training 
objectives, exercises, interactions, and quizzes. 
 
Look for a complete list of manuals available for purchase on the Microsoft 
Business Solutions website: www.microsoft.com/BusinessSolutions. 
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Microsoft Business Solutions Courseware Contents 
Test Your Skills 
Within the Microsoft Business Solutions Training Courseware you will find a 
variety of different exercises.  These exercises are offered in three levels to 
accommodate the variety of knowledge and expertise of each student. 

Challenge Yourself! (Level 3) 
Challenge yourself! (Level 3) exercises are the most challenging. These exercises 
are designed for the experienced student who requires little instruction to 
complete the required task. 

Need a Little Help? (Level 2) 
Need a little help? (Level 2) exercises are designed to challenge students, while 
providing some assistance.  These exercises do not provide step-by-step 
instructions, however, do provide the user with helpful hints and more 
information to complete the exercise. 

Step-by-Step (Level 1) 
Step by step (Level 1) exercises are geared towards brand new users who require 
detailed instructions and explanations to complete the exercise.  Step by step 
(Level 1) exercises will guide the user through the task, step-by-step, including 
navigation. 

Quick Interaction: Lessons Learned 
At the end of each chapter within the Microsoft Business Solutions Training 
Courseware, you will find a Quick Interaction: Lessons Learned page.  This 
interaction is designed to provide the student with a moment to reflect on the 
material they have learned. By outlining three key points from the chapter, the 
student is maximizing knowledge retention, and providing themselves with an 
excellent resource for reviewing key points after class. 
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Student Objectives 
What do you hope to learn by participating in this course? 
 
List three main objectives below. 
 
1. 

 

 

 

 
 
2. 

 

 

 

 
 
3. 
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CHAPTER 1: GETTING STARTED 
 

• Overview 
• Background 
• The Application Window 
• The Microsoft® Business Solutions−Navision® Navigation Pane and 

Menu Items 
• Microsoft Navision Windows 
• Changing How Your Window Looks 
• Command Buttons and Menu Buttons  
• Entering Information 
• Editing Information 
• Menu Bar Overview 
• Finding, Viewing, and Searching for Information 
• Online Help 
• Dimensions 
• Shortcut Keys 

 

Overview 
In this chapter, you obtain an overview of basic Microsoft Navision functionality, 
including customizing the look of Microsoft Navision windows, basic Microsoft 
Navision navigation functionality, editing, viewing, deleting, and adding 
information. 
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Background 
Microsoft Navision is a fully integrated, relational, financial database. It allows 
you to enter and maintain your general ledger, inventory, sales and receivables, 
purchases and payables, resources, and job and campaign tracking activity all in 
one place, one time, allowing you to have one software package instead of 
several. 
 
Microsoft Navision is a graphically based system for enterprise business solution. 
Because Microsoft Navision is graphically based, all work on the screen is done 
in windows, many windows can be open at the same time, and you can use a 
mouse to choose, select and execute various functions when working. Microsoft 
Navision contains the standard functions expected of a computer program in 
regards to functionality and structure. Additionally, Microsoft Navision fulfills 
the requirements of an enterprise business solution by supplying tools for 
entering and managing information. 
 
This material is intended to familiarize you with the features available throughout 
Microsoft Navision. Learning these features will help you with your daily 
routines and will be most helpful with locating information quickly and 
managing your business information. 

Setup 
Keep in mind, every setup you do is a customization for you and your users. 
Setup is a one time investment, allowing you to tailor Microsoft Navision to your 
company, and use your terms. For example, you might maintain inventory in four 
warehouses: North, East, South, and West. Another company may call their 
warehouses #1, #2, and #75. Microsoft Navision setup allows you to define your 
warehouses as North, East, etc., and your neighbor to name them #1, #2, and #75.  

Getting Help 
The various manuals have multiple purposes. The first is to familiarize the novice 
Microsoft Navision user with the software. The second is to give specific 
instructions for Setup and initial usage. And the third is to serve as a reference 
when you cannot quite figure out how to do what you want to do in Microsoft 
Navision. This chapter will cover basic usage and keystrokes. 
 
Online Help, when licensed, is accessible by clicking f1, selecting Help from the 
toolbar, or by clicking the What's This? icon in the upper right corner of your 
screen. Online help is context sensitive, and as such, provides specific 
information rather that the broad overviews provided in the various User 
Manuals. 
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A Few More Words Before You Start 
Microsoft Navision works within Microsoft® Windows® 2000, Windows® XP or 
SQL Server. All Windows functionality is present in Microsoft Navision, and 
you can expect Windows characteristics from Microsoft Navision. 
 
Passwords are case sensitive in Microsoft Navision, User IDs are not. In the case 
that you forget your User ID or Password, consult your System Administrator. 
 
Application areas are the submenus you find on your Navigation Pane: Financial 
Management, Sales & Marketing, Purchase, Warehouse, Manufacturing, etc. The 
individual application areas consist of even smaller units called ″granules.″ The 
granules available to you depend on your license agreement, and your access 
rights.  
 
Screens are granule-specific and granule-dependent. Be aware of where you are 
when you begin input, or when you question output. 
 
The application areas and granules are constructed of small independent units 
called objects. This structure makes it possible to change an individual object 
without affecting the other objects. 

The Application Window 
The Application Window appears as follows: 
 

 
 
It includes the following parts: 
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Title Bar 
The Title Bar is located at the top of the screen; displays the company you are 
currently working in, the name of program (Microsoft Navision), a minimize 
button, a maximize/restore button and a close button. 
 

 
 

Menu Bar 
The Menu Bar is located just below the Title Bar; this standard Windows feature 
contains menus to select functions such as creating new companies, design tools, 
and help. Functions which cannot be used appear dimmed (gray). 
 

 
 

Toolbar 
The Toolbar is located just below the Menu Bar; contains a row of iconic buttons 
to give quick access to frequently used functions such as editing, filtering and 
locating data. The menu bar description on the following pages will describe the 
use of these buttons. At the end of the Toolbar, there are icons for a List feature, 
to activate the Navigation Pane, and to access context-sensitive Help. 
 

 
 

Status Bar  
The Status Bar is located at bottom of screen; shows name and contents of active 
field, work date, user ID, and whether a filter (FILTER) is set and if you are in 
insert (INS) and /or overwrite (OVR) mode. 
 

 
 

Login Window  
After User IDs and Passwords have been created, the Login window always 
appears when you access the database. 
 

 
 
Remember that the application distinguishes between uppercase and lowercase 
letters in Passwords. The User ID does not have this restriction.  
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After receiving your initial password from your system manager, you may 
change it to a password known only to you under TOOLS→SECURITY→PASSWORD 
on the menu bar. Your password is not visible in the system, so be sure to 
remember it! 
 
Microsoft Navision supports both the single sign-on system offered by Windows 
XP and the unified login system offered by Windows NT. If you are using either 
of these operating systems, your system manager can grant you direct access to 
Microsoft Navision. Therefore, your system may be set up so that no password is 
needed to open the database on a server. 

The Microsoft Navision Navigation Pane and Menu Items 
When you open Microsoft Navision, the Navigation Pane appears. The 
Navigation Pane lists options that allow you to choose the application area, such 
as Financial Management and Sales & Marketing. 
 

 
 
If your database contains multiple companies, go to FILE→COMPANY→OPEN to 
select the appropriate company. If the Navigation Pane does not appear, click the 
Main Menu button or press F12 to open the Navigation Pane. If the Navigation 
Pane does not appear still, click VIEW→NAVIGATION PANE (ALT + F1).  
 
If you cannot open a company, it is most likely because a database must be 
selected (FILE→DATABASE→OPEN) and a company may need to be set up.  
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Menu Items in the Navigation Pane 
Some of the options have special symbols indicating their functionality. Plusses 
preceding a menu selection indicate that the item opens a set of options within 
itself. Cards before the item indicate that the item is linked to a list of data or a 
card that gathers its information from a list. Booklets before an item indicate that 
the menu item starts a batch job. 
 

 
 
As you can see, the menus in Microsoft Navision guide you through the system 
to give you easy access to all the functions you need. You can quickly exit any 
current window by pressing the ESC key, clicking the close button at the top of 
every window, or choosing FILE→CLOSE on the Menu bar. 
 
You can open as many windows as you wish in Microsoft Navision. The window 
on top is called the active window. You can enter information in this window, 
and the window is affected by the functions you execute. You can always 
recognize the active window because its title bar is a different color than that of 
the other open windows. You can make a window active by clicking on it.  
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Microsoft Navision Windows 
It is important to understand the two types of windows used in Microsoft 
Navision. There are Card windows and Tabular windows. 

Card Windows 
Card windows show only one record per window, and you can scroll through the 
cards with the PAGE UP and PAGE DOWN keys, or by clicking the recorder icons: 
 

 
 
Card windows usually have labeled tabs at the top to help organize the 
information. You may change tabs using CTRL + PAGE DOWN CTRL + PAGE DOWN 
or click on any of the tabs; when you do, you will see even more fields specific to 
that record. Typically, there are several fields, many of which are available for 
data entry. Also, many card windows have menu buttons and command buttons 
at the bottom, which will give you even more related information and easy access 
to useful functions. 
 
On the Financial Management menu, click RECEIVABLES→CUSTOMERS. The card 
window that appears belongs to the first customer from the Customer Table. The 
Customer card has seven tabs labeled General, Communication, Invoicing, 
Payments, Shipping, Foreign Trade and Commerce Portal.  
 

 
 
When you click on one of these tabs, you see information related to that tab 
name. At the bottom of the card, there are two menu buttons called Customer 
and Sales. If you access either of these buttons by pressing ALT and the 
underlined letter, you can choose from several options on a menu. There is also a 
command button to quickly access the Help feature. 
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Some card windows are informational only. These windows show related 
information that cannot be edited. An example of this would be a Statistics 
window. On the Customer card, click on the Customer button, and click 
Statistics. The Statistics window can also be accessed with the F9 key.  
 

 
 
On the Statistics window, there are two tabs: General and Sales. These tabs 
display information about that specific customer such as outstanding balance, 
orders and sales history. 
 
The fields on the Statistics card are dimmed, which means that you cannot 
change or add information as you could on the main Customer card. However, in 
many cases, if you click on the field itself, a down arrow appears at the right of 
the field. This feature is called a Drill-down. Click on the Balance field and then 
click on the Drill-down. The Customer Ledger Entries window appears with 
more information related to that field. Press ESC to return to the Customer Card. 
 
On many card windows, there is a pencil icon near the top. This is a Comments 
feature. If you click on the icon, a comments window appears. You may also use 
the keystroke combination ALT + C to access the Customer menu button, then 
press M to open the comments window. In the Comments window you can enter 
any special remarks you would like to make for that specific record. After 
comments have been made, the icon changes, with lines added. That way, it is 
apparent when a record has any comments attached to it. More comments can be 
added to this window at any time. If you delete all of the comments from a 
comment window, the icon will return to its original appearance.  
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Tabular Windows 
Tabular windows show multiple records per window, these windows have rows 
and columns. While on the Customer card, press F5 or click the List icon. You 
will see a tabular window appear that lists all the customers in the Customer 
Table.  
 

 
 
If the tabular window has more fields than can display in the list view, you can 
use the scroll bar at the bottom of the window to move left and right to view 
them all. You can browse up and down in the lines by clicking up or down arrow 
head to move one line (record) at a time, or by using the scroll bar to browse 
through the records. 
 
On the left there is a vertical panel called the ″line selector.″ The record indicator 
points to the line you have selected. You can use the line selector to select a line 
by clicking the cell next to the line. The line will then be highlighted. You can 
select one line or several (by clicking and dragging), or all of the lines at once 
(by clicking in the empty square in the top left corner of the window, next to the 
headings). 
 
This list window has the same menu and command buttons as the Customer card, 
as well as two extra command buttons called OK and Cancel. Clicking Cancel 
closes the window and put you back into your Customer card. Clicking OK 
returns you to the Customer card and display the information from the record the 
record indicator was on when you clicked OK. 
 
Bring your customer list up again, and scroll up or down this list. You can 
highlight any customer on the list and click the OK button. When the Customer 
card reappears, it will now show the information for the customer you selected 
from the list. 
 



 

 

Microsoft Navision Introduction 

Page 14 

As with card windows, some tabular windows are for data entry and some are 
informational only. For example, journals are all tabular windows used for 
making journal entries. However, when you used the drill-down feature earlier 
from your Customer Statistics window, you saw the tabular window called 
Customer Ledger Entries. This window is for viewing information only, and the 
information cannot be edited.  
 
Some tabular windows can be used to show trends or changes over different 
periods of time. On the Financial Management menu, click GENERAL 
LEDGER→BUDGETS. On this window, you will see a row of number buttons near 
the bottom. This is called a TrendScape, and each number represents a time 
period, such as by day, week, month, quarter or year. The last button is for any 
specific Accounting Period that you set up for your company. 

Changing How Your Window Looks 
When you first start Microsoft Navision, the screen you see after logging in and 
selecting the company in which you would like to work is called the MenuSuite. 
The basic design of this screen is very similar to Microsoft® Outlook®. This was 
designed to make it easier for end users to have quick access to all the functional 
areas of Microsoft Navision in which they would be working. Therefore, this 
screen can be customized according to what specific areas you will be working 
in. These customizations will be discussed in later courses. 
 
Within Microsoft Navision, there is standard Microsoft Windows functionality 
available that enables you to change how tabular windows display. This changed 
view is associated with your User ID and saved within the ZUP file on your 
computer. Therefore, when you change how a window displays other users in 
your company will not be affected. 
 
Changes you make will be overwritten if you receive an object to replace the one 
which you modified. For example, if you change the location of columns in a 
journal and subsequently get a modified journal from a Microsoft Business 
Solution Center, the column changes you made will be lost. 

Changing Column Width 
To change the width of a column, place the cursor on the vertical line separating 
the columns in the column header. The cursor will display as a vertical line with 
an arrow through it. Hold the mouse button and drag the column separator to the 
desired width. Release the mouse button when you are satisfied with the width. 

Changing Row Height 
You can change the height of all rows or the heading row. To change the height 
of the heading row, place the cursor in the line selector column on the line below 
the heading row. The cursor will become a horizontal line with an arrow through 
it. Hold the mouse button and drag the row separator to the desired height. 
Release the mouse button when you are satisfied with the height. 
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To change the height of all of the rows, other than the column heading, place the 
cursor on the line selector column on the line below the row to be changed. The 
cursor will become a horizontal line with an arrow through it. Hold the mouse 
button and drag the row separator to the desired height. Release the mouse button 
when you are satisfied with the height. 

Moving Columns 
To move a column, first place the cursor in the heading area of the column you 
would like to move. Hold the mouse button down so that the cursor becomes a 
hand and drag the column to the spot where you want to place it. Release the 
mouse button. 

Showing and Hiding Columns 
In addition to changing column height, row height and moving columns around 
you are also able to select what fields (columns) will display. You can either 
right click on the heading section of the tabular window or select VIEW→SHOW 
COLUMN from the menu bar to see a list of available columns. To display a field in 
your window, place a check in front of the field name. To remove a column, 
remove the check.  
 

  
 
In the window displayed above, Code and Name will display while Budgeted 
Amount will not. 



 

 

Microsoft Navision Introduction 

Page 16 

Command Buttons and Menu Buttons 
At the bottom of many windows in Microsoft Navision, you see buttons that can 
be used to access different useful functions related to the information in that 
window. The buttons with a small downward triangle are Menu buttons and the 
others are Command buttons. 
 

 
 
Menu buttons display a menu with related functions. Some examples are the 
Account and Posting menu buttons found on the Cash Receipt Journal window.  
 
Command buttons execute a command for you. Some examples are Print (prints 
from Quotes or Orders), or Help (brings up the help screen). Menu and 
Command buttons can be accessed by pressing ALT and the underlined letter on 
the button or by clicking on the button. 

Entering Information 
When entering information into fields, Microsoft Navision provides the format 
for the type of information you are entering. For example, a date field can only 
accept date parameters, a number field only accepts numbers, and a text field 
accepts everything. 

Entering a Date 
Microsoft Navision is very flexible in how you enter dates. The following are 
valid entries in a date field: 
 

User Input Result 
w The work date you entered under Tools 
t Today's system date 
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User Input Result 
c Closing date 
# Number of the day in the current work month 
Month-day-year 122502, 12 25 02, 12-25-02, 12/25/02  
Weekday-weeknumber-year Fr5202, fr 52 02, fr-52-02, fr/52/02 

 
You may also enter abbreviations for the weekday and Microsoft Navision enters 
the date for that weekday based on your Work Date: 
 

User Input Result 
m Monday 
tu Tuesday 
we Wednesday 
th Thursday 
f Friday 
sa Saturday 
su Sunday 

 
Keep in mind that the Microsoft Navision week starts on Monday. 
 
Enter as few numbers as possible when entering dates since Microsoft Navision 
is set to accept dates through the next millennium, we must be very careful with 
the years we enter. 
 
Microsoft Navision uses the year of your Work Date if you just enter the day 
and month. So, if your Work Date is 12/25/02 and you enter 1225, the date is set 
to 12/25/02. 
 
Microsoft Navision uses the month and year of your Work Date if you just enter 
the day. So, when your Work Date is 12/05/02 if you enter a day of 25, the date 
is set to 12/25/02.  
 
Microsoft Navision supports the default Windows date range of 1930 to 2029. 
Therefore, when you enter the year portion of a date with two digits, it will be 
interpreted as 19XX if the number is between 30 and 99 and 20XX if the number 
is between 00 and 29. 

Check Boxes and Option Buttons 
Press your space bar or click on these boxes and you will see a check mark or a 
black dot to select that field. 
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Entering a Number or Amount 
If a field accepts only numbers, enter the numbers without commas but with 
decimals. Numbers will always be right justified on the screen and on printed 
material. Use a period as a decimal sign. All decimal number fields have a built-
in mathematical function; you can enter calculations such as 13.50 * 2 − 12. The 
four basic mathematic operators are + (plus), − (minus), * (multiply), and / 
(divide). 

Entering Codes 
A code is used to identify a record such as a Vendor No. or Customer No. Codes 
are also values that are used for the sorting of information on the screen and in 
reports. You can use numbers and letters for identification codes. If you use pure 
numbers as the Codes for a table, all Codes in the table should be pure numbers. 
If you use alphanumeric fields you can also use pure alpha codes in the same 
table. By using this format, filtering will be easier.  
 
If you are entering information and need to find a code, go to the code field and 
click on Lookup (F6). This will give you a list of available codes. It is best not to 
use special characters, such as the ″&″ sign, in codes because sometimes these 
characters are used in filtering Microsoft Navision information. You may use a 
dash (-) but avoid all other non-alphanumeric characters.  
 
When entering Codes from a related table containing alphanumeric or pure alpha 
codes, you only need to enter the characters that make this Code unique in the 
table. For example: If you wanted to enter a Salesperson on a Customer Card and 
the table contained the following: 
 

• SAM Sam Jones 
• SUSAN Susan Smith 

 
You would just need to enter SA for SAM or SU for Susan. When entering into 
Code Type fields, Microsoft Navision changes all lowercase characters to 
uppercase. 
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Editing Information 
Editing Fields 
To edit information in a field, press the F2 key. This works like a word processor 
in that the left and right arrow keys move through the text without changing it. 
Pressing F2 again will position cursor at the end of contents in field. 

Inserting and Deleting  
To insert a line or a record in Microsoft Navision, use F3 or press the Insert icon. 
To delete a line or a record, use F4 or click the delete icon. Both of these 
functions can also be accessed by choosing EDIT→INSERT NEW OR DELETE. 

Posted Entries 
You cannot change important information in posted entries. Only information 
such as due date, payment discount date, possible payment discount, applies-to 
ID and whether the entry is pending approval can be changed. In order to make a 
change to these fields, you must click the field twice or press F2 to begin the edit. 
This protective editing function that only applies to these fields is called ″inline 
editing.″ 

Copy and Paste 
You can copy entire lines using the Copy and Paste functions, using the 
following procedure: 
 

1 From the Financial Management menu, click GENERAL 
LEDGER→GENERAL JOURNALS. Select the DEFAULT batch journal. 

2. Select a line, by clicking the button on the line selector to the left of 
the line or placing the cursor on the line and then on the Menu bar, 
clicking EDIT→SELECT. 

3. Click EDIT→COPY on the Menu bar or use the icon on the toolbar. 

4. Move to the spot on the empty line or card where you want to insert 
the copied line. 

5. Click EDIT→PASTE on the Menu bar or click the icon on the toolbar to 
paste. 

 
NOTE: You can only copy and paste from certain fields and tables. For instance, this 
functionality is not available on Sales and Purchasing documents. 

 
You can use this process to copy data from within Microsoft Navision to a 
spreadsheet program such as Microsoft® Excel. For security reasons, you cannot 
copy from Excel into Microsoft Navision. 
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You may also use this process to create new cards in Microsoft Navision from 
existing cards. Microsoft Navision will prompt you to change the Code field to 
be unique before you leave the card. 

Menu Bar Overview 
The Menu Bar includes the following menus: 
 

• File 
• Edit 
• View 
• Tools 
• Window 
• Help 

 
Each menu can be accessed by clicking with the mouse or by pressing the ALT 
key simultaneously with the first letter that is underlined. For example, ALT + F 
will access the File menu. Just pressing the underlined letter can then access the 
items listed on the menus. Many of the items in the menus can also be accessed 
by using Shortcut keys. Shortcut keys and their uses will be detailed later. 
 
Some of the options listed on the menus will change or become inactive 
(dimmed) depending on what Microsoft Navision functional area you are 
currently working in.  
 
The following is the initial list of menu options. 

File Menu 
The File Menu contains functions related to starting, closing and maintaining the 
databases and companies used in Microsoft Navision. 
 
Close (ESC) − To close the active window. 
 
Save as HTML − When a report is previewed to the screen, it may be saved as 
an HTML file. This file may then be opened in Excel and ″What If″ analysis can 
be run on it.  
 
NOTE: The file is imported as values; any formulas will therefore have to be input into 
Excel. 

 
Database (ALT + F, B) − Create a New database, Open an existing database, Test 
a database (this must be done at least monthly), Expand a database size, Delete a 
database, Close a database, and Information about database size, connections and 
active sessions as well as a tables list that shows size and optimization. The 
functions in this program such as creating and deleting should only be done by 
the system administrator. 
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The Database Used should never exceed 85% of the Database Size, and the 
Database Size should never (on a normal basis) exceed 85% of the Licensed Size. 
Microsoft Navision needs the last 15% of opened space in order to process 
activity and perform large tasks like Backup and Restore. 
 
If you are using the SQL Server Option for Microsoft Navision, you will have 
available Altering databases. You may use this function to change the database 
properties whenever you think that it is necessary. 
 
Company (CTRL + O) − Start a New company, Open an existing company, 
Rename a company, Delete a company, and Close a company. The functions in 
this program other than open and close should only be done by the system 
administrator. 
 
Page Setup, Print Preview, and Print − Functions relating to printing 
documents and reports (Print and Preview are toolbar icons). These options 
become active when a document or report has been selected for printing and the 
Request Form is displayed. 
 
Page Setup (ALT + F, G) − You may reset the margins on a report here, if 
desired. Generally, the margins are reset as a property of the report. We normally 
set all the margins on your checks and other documents where needed to 0. 
 
Print Setup (ALT + F, U) − This is used to have a report print to a different 
printer than your default printer. Like Page Setup this must be changed when the 
request form of the report appears and then the report / document must actually 
be printed or previewed after setting the printer. From then on the report always 
defaults to that printer from your workstation until changes are made. 
 
Send − The Report by Email option enables you to send e-mail messages out of 
Microsoft Navision. For example, you may create a Purchase Order, then Print 
Preview it. With the document displayed on the screen, go to 
FILE→SEND→REPORT BY EMAIL and a window will open up from which you may 
select the appropriate address to e-mail the document to. This function depends 
on having MAPI compliant e-mail. The file is sent in HTML format and may be 
viewed with a browser, and then printed. 
 
Link by Email − To use this option, first open the form or report you want to 
send a link for. With the document displayed on the screen, go to 
FILE→SEND→LINK BY EMAIL. Your email will open a new message; a link will be 
pasted to the Attach field from which the recipient can then access by double-
clicking the link.  
 
Shortcut to Desktop − Shortcut to Desktop enables you to create a Shortcut on 
your desktop to a form or report in Microsoft Navision.  
 
1, 2, 3 − List of recently opened companies; type the number or click on the list 
to re-open a company. 
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Exit (ALT + F, X) − This command exits the Microsoft Navision program. 

Edit Menu 
The Edit Menu includes several editing features for data entry into and between 
different Microsoft Navision windows. 
 
Undo (CTRL + Z) − To "undo" an editing error, such as deleting the contents of a 
field, but will undo preceding action only. This function is of limited use in 
Microsoft Navision because once we have left a field, we have written to the 
database. 
 
Cut (CTRL + X), Copy (CTRL + C), and Paste (CTRL + V) − Standard Windows 
editing options for moving and removing information. These functions can be 
used within Microsoft Navision or between Microsoft Navision and Microsoft 
Office products. 
 
Clear (DEL) − This function removes only what is selected in the active window. 
This could be part of a field, an entire field, multiple fields, multiple lines or all 
lines.  
 
Copy Link − This allows you to create a link to a form or a report. The form 
must be the active form in Microsoft Navision. Click EDIT→COPY LINK. Microsoft 
Navision places the link on the clipboard which you then paste the link using 
EDIT→PASTE. 
 
Copy Previous (F8) − This copies into a field the exact contents of the field 
directly above. 
 
Insert New (F3) and Delete (F4) − To insert or delete records and fields. 
 
Select (ALT + E, S) − Used to select a single record in a table. This highlights the 
line you are on in blue and is the same function as clicking the mouse in the left-
hand margin. You can also select multiple consecutive lines by holding down the 
SHIFT key and using the DOWN ARROW key simultaneously.  
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In addition, you can select nonconsecutive lines. Click the first line, then press 
the CTRL key and click the line selector of the additional lines you want to select. 
Your window will appear as follows: 
 

 
 
Select All (CTRL + A) − Used to select all the visible records in a table / list. This 
respects all filters set on the table. Clicking in the upper left hand corner of a 
tabular window can perform the same operation. 
 
Select Object − Used in Object Designer. 
 
Toggle Mark (CTRL + F1) − Selectively mark records in a list / journal. This 
places or removes a diamond mark in the left-hand margin. This is then used with 
View Marked Only (ALT + V, M) to show and perform functions on only those 
lines that are marked. 
 
Find (CTRL + F) and Replace (CTRL + H) − To locate and/or replace specific 
contents of fields. The window displays as shown below. 
 

 
 
The Title Bar displays the field you are searching in. The Find What field is 
where you enter the information you are searching for. You may use Match to 
select what part of the field the value you enter should be compared to; the 
choices for Beginning or Any Part are only appropriate when searching in fields 
that display text or codes.  
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Microsoft Navision distinguishes between upper and lower case if you place a 
check in the Match Case field. If Use the Best Key is selected, Microsoft 
Navision resorts the table in the order that will result in the fastest search; this is 
especially useful in large tables. When Find As You Type is selected, Microsoft 
Navision will begin searching for the text as you type in the value. 
 
Microsoft Navision stops and displays what it has found when it finds a value 
that fits the search string. If the record displayed is not the one you are looking 
for, you may use the Find First, Find Next and Find Previous buttons to locate 
the appropriate record. If you want to replace the value, use the Replace button 
to indicate the value to substitute. 

View Menu 
The View Menu includes functions that affect what is visible in the active 
window. 
 
Go To − Go to First (CTRL + HOME), Previous (PAGE UP), Next (PAGE DOWN) or 
Last (CTRL + END) records.  
 
Field Filter (F7), Table Filter (CTRL + F7) and Flow Filter (SHIFT + F7) − 
Microsoft Navision functions to filter records in a window based on certain 
criteria. These functions will be covered in more detail later. 
 
Marked Only (ALT + V, M) − To show only those records marked by the Toggle 
Mark (CTRL + F1) function in a window. 
 
Show All (SHIFT + CTRL + F7) − To release filters you have set and to show all 
records again. 
 
Sort (SHIFT + F8) − To change the order data displays change the sort order of 
the table, such as customer number or entry number. Sorting works as follows: 
numbers only without blank spaces or special characters then letters only or 
numbers and letters combined. When numbers and letters are combined, the field 
contents are checked character by character from left to right. The sorting priority 
is as follows: blank spaces come before something, letters come before numbers 
and numbers come before special characters. 
 
These rules will result in the following sorted list. 
 

Order Reason 
1 
11 
12 
111 

Numbers without blank spaces or special character come 
before letters or combinations of numbers and letters, and 
Microsoft Navision counts in ascending order. 

A 1 This is a combination of letters and numbers. It comes 
before other such combinations because the blank space 
between A and 1 comes before anything else. 
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Order Reason 
ABC Letters come after blank spaces (so ABC comes after A 1 

above) 
AB1 But before numbers in letter/number combinations. So 

ABC comes before AB1. 

A1 Numbers are sorted after letters, so A1 comes after AB. 
D S B D comes after A, blank spaces come before something. 
D1 Numbers are sorted after letters, so D1 comes after D S B. 
D.S.B. Special characters come after numbers. 
1A A number at the start of a combination of letters comes 

next to last in the sorting order. 
+A1 Special characters come last in a sorting. 

 
It is important to be familiar with sorting rules so that filters can be entered 
correctly. For example, the filter A100..110 will not result in any data being 
found since the interval cannot exist. The result of an incorrectly used filter can 
be incorrect or even no information.  
 
To ensure that numbers are sorted correctly, you must use the following 
principles: always use a numerical series of a fixed length (100 to 999), never use 
a numerical series such as 1 to 999 in code or text fields, and never use a 
numerical series such as 001 to 999 in code or text fields. 
 
The SQL Server Option for Microsoft Navision sorts numbers as if they were 
text as illustrated in the following table: 
 

Numerical Sorting Text Sorting 
1 1 
2 10 
3 100 
4 2 
10 3 
100 4 

 
To avoid this problem, you should use a numerical series that has a fixed length 
by either specifying a numerical series that has a predefined number of digits and 
starts with a number other that zero or manually follow the numbering principles 
and use a fixed number of digits. 
 
Toolbar − Choose whether the toolbar will be displayed and in what manner. 
Some options are color, size, and "ToolTips" (cues). 
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Hide Column (ALT + V, H) and Show Column (ALT + V, U) − For use with 
windows with rows and columns (tabular windows) to choose which columns 
will be visible. This same functionality can be achieved by right clicking on the 
heading portion of the tabular window. 
 
Refresh − This option is available if you are using the SQL Server Option for 
Microsoft Navision. You use this function to refresh the data that the active 
window contains. Microsoft Navision will then ensure that the newest data 
appears in the window. 

Tools Menu 
The Tools Menu contains the major programming functions and setup options. 
 
Work Date − Allows each user to enter a date that the system will use when 
entering transactions that is different from the system or actual date. For 
example, you may have several transactions to enter that were dated 3/20/02. 
However, today's date is 3/31/02. By changing the work date to 3/20/02, you will 
not have to manually enter a date. You can override the work date when entering 
transactions by typing "t" for today's date or entering a different date.  
 
The Work Date is also used to determine the default year and month Microsoft 
Navision will use when you enter either just the day of the month or the month 
and day. For more information, see the "Entering Information" section. 
 
Language − Displays a table of the application languages.  
 
Object Designer (SHIFT + F12) and Designer (CTRL + F12) − Allows the use of 
the Microsoft Navision C/SIDE application development system to modify the 
application and customize forms or reports. Special permission is required to use 
these functions. 
 
Navigation Pane Designer (ALT + F12) − Allows access to customizing the 
Navigation Pane. Special permission is required to use this function. 
 
Debugger − Used by programmers when they customize Microsoft Navision. 
 
Client Monitor − Used by programmers to monitor the communication between 
server and clients in a network to ensure efficient communication. 
 
Zoom (CTRL + F8) − Allows users with Superuser permissions, to see the 
contents of every field in the current record. This gives you the ability to see 
every field available in a table even when they are not displayed in the window. 
 
Backup and Restore − Allows backup of one company, all companies, 
application objects, or entire database. Backups can be performed at any time due 
to the unique feature within Microsoft Navision called Version Management. 
Before a backup, the system takes a picture of the version at the time of the 
request and then backs it up. This allows other users to continue processing in the 
program and means that backups do not have to be done after hours.  
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If you need to restore a backup, use the Restore procedure to restore a backup 
made using the Microsoft Navision Backup program. Microsoft Navision will not 
overwrite existing data therefore companies must be renamed or deleted prior to 
running the Restore function. 
 
Security − Used to enter users into the system with options of Roles, Database  
Logins, Window Logins and Passwords. Each user on the system should be 
given rights to access menus, windows, tables and functions in Microsoft 
Navision. Each user's name and password (if needed) is entered in this window to 
have access to the Companies set up in Microsoft Navision. The Password 
option allows you to change your password.  
 
If you are using the SQL Server Option for Microsoft Navision, you will also see 
the Synchronize function under TOOLS→SECURITY. The synchronization process 
is the heart of the security system for SQL Server Option for Microsoft Navision. 
 
License Information − Shows contents of the license file under which you are 
working including the license number, who owns it and, if there is a time limit, 
when the license expires. Your license file is named fin.flf. 
 
If you want to see all the functions in Microsoft Navision, including those for 
which you have not purchased permission, you can use the license file cronus.flf. 
To change the license, select TOOLS→LICENSE INFORMATION. On the License 
Information window, click the Change button and browse to locate the license.  
 
Custom Controls − This menu item provides a list of OCX controls registered in 
Windows.  
 
Options − Contains the program setup options which include DBMS Cache 
(KB), Commit Cache, Object Cache (KB), Status Bar, Close Forms on ESC, 
Marquee Full Selection, Quick Find. The System Administrator is responsible for 
monitoring these options. 

Window Menu 
The Window Menu contains information related to windows that are currently 
open. 
 
Close All (ALT + W, A) − Closes all open windows. 
 
Arrange Icons − To arrange the icons shown on lower border of the application 
window that appear when you minimize a window (double-click the icon to 
maximize again). 
 
1, 2, 3 − List of currently open windows; type the number or click on list to re-
focus a window. 
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Help Menu 
The Help Menu (F1) contains many Help options that will be discussed in more 
detail later. 
 
Microsoft Business Solutions-Navision Help − Shows a table of contents 
available in Help system. 
 
C/SIDE Reference Guide − Reference tool for programming. 
 
What's That? (SHIFT + F1) − Transforms the cursor to a Help cursor that can 
retrieve Help for everything on the screen. 
 
Overview of F Keys (CTRL + ALT + F1) − Displays an overview of the function 
keys in the program. The functions displayed are context sensitive. A complete 
listing is in the section entitled ″Shortcut Keys.″ 
 
About Microsoft Business Solutions-Navision − Displays product information, 
including the version number of the program. 

Finding, Viewing, and Searching for Information 
Microsoft Navision offers a variety of ways to view information, so you can view 
and work with only the information that is relevant to the task you are trying to 
accomplish. For example, if you want to see transactions for a particular time 
period, you can select only those transactions. You may wish to filter information 
to view or work with by a range of dates, or by a dimension: department, project, 
and so on. 
 
Finding, viewing, and searching for information is where your Shortcut keys will 
come in handy. We will review terms and Shortcut keys as well as show you how 
to use the keyboard or the mouse. 
 
Navigate − This feature is an option available from most application area menus. 
Navigate lets you track entries associated with a particular transaction. Choosing 
Navigate will show you every posting entry made for the transaction.  
 
Navigation searches by the Document No. and the Posting Date. Therefore, 
when you enter corrections to entries you should always use the same Document 
No. and Posting Date as the original transaction whenever possible.  
 
You will find a Navigate button on all posted transaction forms that can be 
accessed by ALT + N. If you think there may be other transactions with the same 
Document No. but a different Posting Date, clear the Posting Date field on the 
Navigate card and press ALT + N or click the Find button. 
 
You can also search for Customer and Vendor transactions based on the External 
Document No. (Vendor's Invoice No.) by accessing the External tab. 
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List (F5) −Brings up the list associated with that window. You can activate the 
List feature with your cursor on any position in the window, but you will always 
get the general list for the whole window. 
 
Ledger Entries (CTRL + F5) − Pressing CTRL + F5 (or choosing Ledger Entries 
from a menu button) provides a list of all related ledger entries for that window. 
 
Lookup (F6) − Pressing F6 (or clicking on the Lookup button) in a field provides 
you with the list associated with that field. For example, pressing F6 while in the 
Customer No. field brings up a full customer list. Unlike the List feature, it is 
field specific. The upward arrow indicates a relationship to another table. 
 
Drill-down (F6) − Pressing F6 (or clicking the Drill-down button) in a field 
provides you with background information related to that field. For example, 
pressing F6 in a Balance field shows all transaction entries that make up a field. 
The downward arrow indicates the number was calculated from another table. 
 
Options (F6) − Pressing F6 (or clicking the Options button) in a field gives you a 
list of options for that field. For example, go to the Payments tab of a Customer 
Card and click the Options button or press F6 while in the Application Method 
field. You will be given the options Manual or Apply to Oldest to select for that 
field. Once you learn the available options, you can just type the first letter of the 
option to select that option (or enough characters to be unique). 
 
No. Series (F6) − Pressing the F6 command or clicking the Numbering Series 
command takes you to a table displaying numbering options. For example, go to 
WAREHOUSE→PLANNING & EXECUTION→ITEMS and press F6 while in the No. field. 
 
Zoom (CTRL + F8) − Pressing CTRL + F8 (or choosing TOOLS→ZOOM) while in a 
record brings up a window that lists all available fields for that record and the 
values for each of the fields for the given record. This function is limited to 
Superusers when permissions are in place. 
 
Find (CTRL + F) − This feature allows you to search for something in a particular 
field in one window at a time. You can also replace the text you find with 
something else. To access this feature, put your cursor on the field in question, 
then press CTRL + F, or click the Find icon (or choose EDIT→FIND). 
 
When you access Find, a window appears in which you can enter the string of 
characters (words or numbers, for example) you want to search for.  
 
Microsoft Navision will consider case only if you place a check mark in the 
Match Case field. You may also choose whether to match part, all, or the 
beginning of a field. Depending on what type of field you start with, Microsoft 
Navision will set the default match. 
 
When you are in a List view, type the first few characters that you are looking for 
and Microsoft Navision will automatically start finding the record.  
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Sort (SHIFT + F8) − This feature allows you to view information in a different 
order from the default order. For instance you can change the view of Customers 
to the Search Name to scroll through them in alphabetical order. If you change 
the sort on the Card Microsoft Navision remembers that sort order each time you 
open the Customer Card. That sort order is also used when accessing the List 
form the Card. 
 
Toggle Mark (CTRL + F1) − Use this feature when you want to post only 
portions of your journal entries and filter out other journal entries on the screen. 
Pressing CTRL + F1 can access this feature, or choose EDIT→TOGGLE MARK. You 
can select multiple entries to mark by holding the CTRL button and clicking the 
square to the left of your entries, then access Toggle Mark.  
 
Once you have marked one or more entries, you can filter to see only these by 
choosing VIEW→MARKED ONLY. If you choose this function, the journal entry 
screen will only show those entries that are marked. Click , press SHIFT + CTRL 
+ F7, or choose VIEW→SHOW ALL to show all entries again. 
 
Page Up and Page Down − Using the PAGE UP and PAGE DOWN keys takes you 
through the cards in the database. If you are searching through the Vendor Cards, 
PAGE DOWN takes you to the next card and PAGE UP takes you to the previous 
card. 
 
CTRL + HOME and CTRL + END − Takes you to the first or last record in a table. 
 
CTRL + PAGE DOWN and CTRL + PAGE UP − Move you through tabs on a Card 
or Report Request form. 
 
CTRL + UP ARROW and CTRL + DOWN ARROW − Move you from sections of a 
form, from Line sections to Header sections, and from a list form to menu and 
command buttons. 
 
Recorder Buttons − Click on icon on the tool bar or these can also be accessed 
on the menu bar: VIEW→GO TO and choosing First, Previous, Next or Last. These 
functions let you quickly browse through records (cards or lines). 

Filtering 
Filters are used to limit the scope of the information that appears on a screen or 
report. They give you the ability to see only the information you want. You may 
select between Field, Table and Flow filters. 
 
When you set any of the three filter types, FILTER is shown at the bottom of the 
application window in the Status Bar. FILTER also displays when the system has 
set a filter internally. For example, when you view the Ledger Entries of a 
Customer, the system sets a Field Filter on the Customer No. field in the 
Customer Ledger Entry table. 
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If you are not completely sure which filter you need to use to see the desired 
information in a window, you can have the filter window opened simultaneously 
with the data window, then switch filters until the desired contents of the data 
window appear. For this purpose you can click the Apply button instead of OK 
in the filter window. If you click Apply you can test one filter after another and 
then click OK after finding the filter you want to use. 
 
Field Filter (F7) − Field Filters apply to one field at a time in a table. Field 
Filters do not affect calculated fields, but they do limit the amount of information 
displayed. When you select a field and press F7 or click the icon (or select 
VIEW→FIELD FILTER), the program displays a Field Filter window. You can then 
enter the filtering information.  
 
Table Filter (CTRL + F7) − Table Filters enable you to combine multiple Field 
Filters. By accessing Table Filter you can filter by more than one field in a table 
at a time or view the filters you have set using Field Filter. For example, you can 
filter on multiple fields at once such as zip code and payment terms. Or, you 
could use Table Filter to view Vendors from a specific zip code and with 
balances above a certain amount.  
 
Most request forms offer several Table Filters to use while printing reports or 
batch jobs. Table Filter is different from Flow Filter in that it can be used to limit 
data on multiple fields in the system. If you are using multiple filters in the 
window you can use CTRL + F7 or click the icon to see a list of each filter and edit 
them from this screen. 
 
Both Field Filters and Table Filters are released by the Show All function which 
is accessed by the icon (or VIEW→SHOW ALL). 
 
Flow Filters (SHIFT + F7) − Flow Filters limit the contents of the fields that 
display amounts or quantities that Microsoft Navision calculates from entries in 
other tables. It does this by making a selection of the entries included in the 
calculations. The filter should be entered in the table where the calculated field 
appears and not in the table where the figures come from. Filters can be set in 
field whose names end with the word Filter, such as Date Filter or Budget Filter. 
For example, if you want to see transactions for a particular department, you 
would use the Flow Filter feature to limit the function to the department. If you 
want to make entries to the budget for a particular department, you would use the 
Flow Filter feature. If you want to see how a promotion went, you would use the 
Flow Filter for a range of dates. 
  
Flow Filters may be used for a range of dates, departments, projects, budgets, and 
business units. Flow Filters are not released by the Show All function. You must 
access the Flow Filter on the same screen where you set the filter, blank the Filter 
column, and click OK. 
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Filtering on Reports 
In addition to allowing you to analyze data online, filters are also useful in 
selecting data to print on reports. When you select a report to print, a request 
form will display as shown below. 
 

 
 
The Sort button in the lower right portion of the window can be used to select 
how you would like the data displayed on the report. If you wish to change the 
sort order, be sure to do so before setting any filters. 
 
Each tab represents a table that is used to provide information for the report. On 
each tab, you can use the assist button in the Field column to select fields that are 
not displayed. On the same line as the selected fields, you can indicate filters to 
apply. This report has tabs for the Customer table and Value Entry table. 
 
The Options tab is used to make general decisions about how to print the report. 
Some examples of this would be the option to print in detail or summary and 
whether company information (address, etc.) should print on the report. 

SQL and Filtering Reports 
It is important to understand how consistency of data may affect reports 
generated in Microsoft Navision on SQL. The SQL Server Option allows many 
users to interact with Microsoft Navision simultaneously. This means that a wide 
variety of transactions can be carried out at any time. Although the data displayed 
by Microsoft Navision is up-to-date, it is not necessarily completely consistent. 
For example, an incomplete transaction may cause inconsistencies to occur 
between the debit and credit in an account. 
 
The only way to ensure the consistency of the data on which you base your 
reports would be to design the reports so that they lock the relevant tables or 
records. This prevents other users from inserting, deleting or modifying these 
records or tables while the report is being generated. However, this is not the 
default setting, and it is not a suitable method for designing reports. 
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Therefore, two procedures may be followed to ensure the consistency of the data 
used when generating reports with the SQL Server Option for Microsoft 
Navision: 
 
Create batch jobs that generate your reports at night or at another time when the 
system is not being updated. 
Set a filter in the report that places a date limit on the data used in the report so 
that it does not incorporate the day's transactions. You could also limit the report 
to a department or branch that is not currently updating the system. 
 
Various ways to enter filters are outlined on the following pages. 

Filter Expressions 
 

Meaning Sample 
Expression 

Record Content Displayed 

Equal to 377 377 
1100..2100 1100 through 2100. 
..2500 Up to and including 2500. 

Interval 

P8.. Information for accounting Period 8 
and thereafter. 

Either/or 1200|1300 Those with 1200 or 1300. If there is a 
record with each number, both will be 
displayed. 

And <2000&>1000 Numbers that are less than 2000 and 
greater than 1000. (The "&" sign 
cannot be used by itself with numbers 
because records cannot contain two 
numbers.) 

Different from 
(not equal to) 

<>0 
<>1000&<>2000 

All numbers except 0. 
All numbers that are not 1000 and not 
2000 

Greater than  >1200 Numbers greater than 1200. 
Greater than or 
equal to 

>=1200 Numbers greater than or equal to 
1200. 

Less than <1200 Numbers less than 1200. 
Less than or 
equal to 

<=1200 Numbers less than or equal to 1200. 
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Meaning Sample 

Expression 
Record Content Displayed 

*Co* Textual matter than contains *co* 
such as uncooperative, company, etc. 

Co* Textual matter than begins with co* 
such as coordinate, company, etc. 

An unspecified 
number of 
unknown 
characters (may 
be none) 

*co Textual matter than ends with *co 
such as Debtco. 

One unknown 
character 

Hans?n Textual matter than contains the 
specified letters, and one unspecified, 
such as Hanson or Hansen. 

Calculate first 30|(>=10&<=20) Those records with number 30, or 
with a number between 10 and 20 (the 
result of the calculation within 
parentheses). 

Ignore case @department Textual matter containing Department 
or department. 

 
Expressions can also be combined, as in the examples below: 
 
Combination Meaning 
5999|8100..8490 Include any records with the number 5999 or a number 

from the interval 8100 through 8490. 
..1299|1400.. Include records with a number less than or equal to 1299 

or a number equal to 1400 or greater, that is, all numbers 
except 1300 through 1399. 

>50&<100 Include records with numbers that are greater than 50 and 
less than 100, that is, numbers 51 through 99. 

*C*&*D*  Texts containing both C and D. 
@*co?* Texts containing co., CO., Co., cot, cope, incorporated.... 

(CO, cO, co or Co must be present, followed by at least 
one character, but there can be an indefinite number of 
characters before and after these, and case is unimportant). 

 

Quick View of Icons and F Keys 
Here is a quick view of some of the functions we have covered, showing both 
Shortcut keys and icons where applicable: 
 
Function Keyboard Shortcut 
Search for information from a list of 
contents 

F5 (List ) 

View a list of general ledger entries CTRL + F5 (Ledger Entries) 
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Function Keyboard Shortcut 
Search for information from a list of 
valid entries 

F6 (Lookup  ) 

Search for related background 
information 

F6 (Drill-down  ) 

Look up available options for a field F6 (Options  ) 
All fields in a card CTRL + F8 (Zoom in) 
Find contents of a field CTRL + F (Find ) 
Limit window to certain contents in 
field 

F7(Field Filter ) 

Limit window to certain contents in 
multiple fields at one time 

CTRL + F7 (Table Filter ) 
 

Work with lines/accounts in the same 
dept., date, project, budget, business 
unit, or any combination 

SHIFT + F8 (FlowFilter ) 
 

Search for the next or previous card in 
the database 

PAGE DOWN or PAGE UP  

 

On-Line Help 
Help is available throughout the system and there are many ways to access this 
feature. 
 
F1 Shortcut Key − Brings up a Help screen related to area your cursor is in. 
 
What's This? − By clicking on the icon at the right end of the toolbar, your 
cursor becomes a Help cursor that will retrieve Help for whatever you click on. 
 
Help button − Displays in the lower right hand corner of all windows. 
 
Menu Bar − The Help menu can be accessed by pressing ALT + H, or clicking on 
the Help Menu bar option. The Microsoft Navision Help option has tabs for 
Contents, Index, Search and Favorites. 
 
The Contents option bring up a Table of Contents for the Help System which 
includes subfolders for every application area and Welcome to Navision Help. 
Within each application area there is help available to assist you with procedures 
and provide information on tables and reports. 
 
Other selections under Help on the menu bar include C/SIDE Reference Guide, 
What's This?, Overview of F Keys, and About Microsoft Business Solutions-
Navision. 



 

 

Microsoft Navision Introduction 

Page 36 

Dimensions 
If you have responsibility for making setup decisions in your company, you 
should begin thinking about how you will use dimensions. Dimensions are a 
feature within Microsoft Navision that enables you to set parameters by which 
you will slice and dice your information. You can use Dimensions to link 
information to an entry when you post it; this will enable you to retrieve the 
information either online or in reports based on Dimensions.  
 
You might, for example, set up Dimensions of Salesperson, Campaign and 
Region. You could then view results for Sales by Region by Campaign by 
Salesperson (Northwest Region, Fall Kickoff, John Smith). Alternatively, you 
could also print reports that provide results for total sales for the Fall Kickoff 
without specifying the Region or Salesperson. 
 
Each dimension can have an unlimited series of dimension values for that 
dimension. For example, the dimension Region may have dimension values 
assigned of Northwest, Southeast, Midwest and Pacific Coast. Dimensions and 
dimension values are user-defined and unlimited (with the Advanced Dimension 
granule), which means you can create dimensions tailored to your company's 
needs and business processes. 
 
By using dimensions, you can analyze trends and compare various characteristics 
across a range of entries. The Analysis by Dimensions functionality is 
particularly effective for this purpose when you utilize multiple dimensions. 
However, even if you have only two global dimensions, you can also use filters, 
account schedules and reports to create informative dimension analysis.  
 
Microsoft Navision gives functionality to enable you to limit how dimensions are 
combined, acceptable values and how dimensions can be posted. Default 
dimensions can be assigned to the chart of accounts, customers, items etc. and 
you may specify how contradicting default values should be prioritized. This 
functionality allows you to setup Microsoft Navision to adhere to your business 
rules, increasing the consistency of data entry and making data output more 
reliable. 

Dimension Types 
Three types of dimensions are set up in Microsoft Navision: global, shortcut and 
budget. You may specify two dimensions that you have defined to be global. 
Global dimensions will be available throughout Microsoft Navision. This means 
that global dimensions can be used as filters for journal entries, reports, account 
schedules and batch jobs.  
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Global dimensions are made available for use on entry lines and document 
headers as Shortcut dimensions. Because Microsoft Navision makes global 
dimensions readily accessible throughout the program, they are usually a firm's 
most used and important dimensions. If necessary, you can change the 
dimensions that are defined as global in a batch job that updates all records. This 
process, however, will take some time to perform. 
 
Shortcut dimensions can be added to lines in journals and on sales and purchase 
documents using the VIEW→SHOW COLUMN feature of Microsoft Navision. Up to 
eight Shortcut dimensions can be specified in Microsoft Navision; the first two 
are the same dimensions used as global dimensions. The remaining six can be 
changed to suit your company's needs. To enter information for dimensions not 
selected as Shortcuts, you must use a separate Dimensions window. 
 
Budgets may have up to four dimensions assigned to them in addition to the two 
global dimensions. You select the budget dimensions for each budget from the 
dimensions you have created. Budget dimensions can be used to set filters on a 
budget and to add dimension information to budget entries. 

Shortcut Keys 
Although menus are provided throughout the system, using Shortcut keys makes 
using Microsoft Navision faster and easier. 
 
Below are the most commonly used Shortcut keys: 
 

Function Keyboard Shortcut  
Find CTRL + F 
Card to List F5 
List to Card SHIFT + F5 
Ledger Entries CTRL + F5 
Statistics F9 
Look Up F6 
Drill Down F6 
Option List F6 
Sort SHIFT + F8 
Post F11 
Post & Print SHIFT + F11 
Next Window CTRL + F6 
Navigation Pane F12 
Toggle Mark CTRL + F1 
Show Marked Only ALT+V, M 
Next Record PAGE DOWN 
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Function Keyboard Shortcut  
Previous Record PAGE UP 
Open Company Record CTRL + O 
Edit F2 
Insert F3 
Delete F4 
Copy CTRL + C 
Paste CTRL + V 
Copy from above F8 
Field Filter F7 
Table Filter CTRL + F7 
Flow Filter SHIFT + F7 
Show All SHIFT + CTRL + F7 
Return to Previous Value ESC 
Close ESC 
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Test Your Knowledge − Getting Started 
1. How many Salesperson/Purchasers are in Microsoft Navision?  

 

2. Who is the contact at Customer 49525252 − Beef House?  

 

3. What is the current balance on Customer 49525252 − Beef House?  

 

4. How many open invoices does Customer 49525252 − Beef House 
have?  

 

5. How many Bank Accounts are set up in Cronus International, Ltd.? 
(Hint: On the Financial Management menu, click CASH 
MANAGEMENT→BANK ACCOUNTS)  

 

6. What is the quantity on hand of Item No. 70000? (Hint: On the 
Warehouse menu, click PLANNING & EXECUTION→ITEMS)  

 

7. What is the Unit Price of Item No. 70040?  

 

8. What is the Last Direct Cost of Item No. 70040?  

 

9. Name three ways to insert a Customer:  

 

10. When you type the letter ″t″ in a date field, what happens?  

 

11. What Shortcut key do you press to delete a new Customer?  

 

12. When you type the letter ″w″ in a date field, what happens?  
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13. What are the three types of Dimensions available in Microsoft 
Navision?  

 

14. What would the following filter expression display: 1200|1300? 

 

15. What would the following filter expression display: 1100..2100? 

 

16. What Shortcut key do you press to Lookup, Drill-down and display 
the Options menu?  

 

17. What are the three filter types available in Microsoft Navision?  
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Quick Interaction: Lessons Learned 
Take a moment to write down three Key Points you have learned from this 
chapter: 
 
1. 

 

 

 

 

 
 
2. 

 

 

 

 

 
 
3. 

 

 

 

 

 



 

 

Microsoft Navision Introduction 

Page 42 

 



 

 

Chapter 2: Technology  

Page 43 

CHAPTER 2: TECHNOLOGY 
 

• Overview 
• C/SIDE Development Environment 
• Server Options 
• Navision Application Server  
• Multilanguage Functionality  

 

Overview 
This chapter covers the more technical aspects of using Microsoft® Business 
Solutions−Navision® These aspects, the Development Environment; Server 
Options; Application Server; and Multilanguage functionality; are covered in 
more depth in the Navision Installation and Configuration manual. 
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C/SIDE Development Environment 
The development environment in Microsoft Navision is called C/SIDE 
(Client/Server Integrated Development Environment). The major benefits of 
C/SIDE are: 
 

• All application areas for Microsoft Navision are developed in 
C/SIDE. 

• It contains all the tools to build on and customize the application. 
• It includes the executables in the program subdirectory on the hard 

disk. 
• It contains the code needed to interpret the application objects, 

development system tools (editors, debugger, and so on), the 
database management system (DBMS) and the operating system 
interface.  

 
C/SIDE consists of three central systems: 
 

• Fourth-generation language (4GL) development system 
• Database management system 
• Special database functions 

 

Object Designer 
The Object Designer enables you to develop applications in C/SIDE. From the 
Object Designer, you can run an application object or start an application object 
designer, for example, the Form Designer. You use the application object 
designers to modify the design of an existing application object or to create a new 
application object. Note that special permission is required to use this tool. 
 
There are seven types of application objects: 
 

• Tables 
• Forms 
• Reports 
• Dataports  
• XMLports 
• Codeunits  
• MenuSuite 
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To open the Object Designer, click TOOLS→OBJECT DESIGNER. The Object 
Designer window appears: 
 

 
 

Application Objects 
C/SIDE uses object-oriented programming technology. An object is a self-
contained module of data and its associated processing. 
 
All objects in C/SIDE are assigned a number for identification purposes.  
 

• Objects 0-9,999 have been developed by Microsoft Navision.  
• Objects 10,000-49,999 have been developed by Microsoft Navision 

Territory Representatives (NTRs).  
• Objects 50,000-99,999 are available for Microsoft Navision Solution 

Centers (NSCs). 
• Objects 1,000,000- 98,999,999 are available for add-on products. 

 

Tables 
All information in the database is stored in tables. Each table contains one kind 
of information, such as journal lines, posted entries and basic information.  
 
There are four different kinds of tables: 
 

• Normal tables display information that the user can work with. The 
Customer table is an example of a normal table. 

• System tables are tables that the system creates automatically. The 
DBMS uses the system tables to manage, among other things, system 
security and permissions. The User table is an example of a system 
table. 
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• Temporary tables act as buffers for table data in your C/AL 
programs. You can do almost anything with a temporary table that 
you can do with a normal database table. A temporary table is not 
stored in the database but is held in memory on your workstation 
until you close the table. 

• Virtual tables contain information that the system provides. You 
cannot change the information that these tables contain. The system 
computes virtual tables at runtime. The Date and Session tables are 
examples of such virtual tables. 

 

Forms  
Forms are used to enter and display data. For example, you can use a form to 
enter information about new customers or to update and review information 
about existing customers. 

Reports 
Reports are used to print information from a database. They can be used to 
structure and summarize information, and they can be used to print documents, 
such as invoices. They can also be used to process data without printing 
anything. 
 
You can use the Report Designer to customize and modify existing reports. To 
create a new report, you must open the New Report window from the Object 
Designer. To do so, click REPORT→NEW. The New Report window appears: 
 

 
 
The report wizard guides you through the design of the report. 

Dataports 
A dataport is an object type that is used to import data from and export data to 
external text files, for example, comma-separated files. 
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XMLports 
The XMLport object is conceptually related to a dataport; you also use 
XMLports to import and export data, but in XML format. XMLports make the 
process of exchanging data in XML between systems more simple and 
streamlined. 

Codeunits 
A codeunit is an object type that contains functions written in C/AL code.  

MenuSuite 
The MenuSuite object contains the menus that are displayed in the Navigation 
Pane and in the Navigation Pane Designer. Each menu contains content for a 
specific departmental area, for example, Finance or Manufacturing.  
 
For more information about the Object Designer, see the manual Application 
Designer's Guide.  

C/AL − The Programming Language 
C/AL is a fourth-generation programming language (4GL) that: 
 

• Is used to create functions. 
• Controls how individual database objects interact. 
• Includes standard functions for reading, writing and modifying table 

data. 
 
When you program in C/AL, you use statements. There are the following 
different types of statements: compound statements, conditional statements, 
repetitive statements, EXIT statements and WITH statements. 
 
For more information about C/AL, see the manual C/AL Programming Guide or 
the Microsoft Navision Programming training material. 

The Graphical User Interface (GUI) 
The user interface is designed so that it is easy to use if you are already familiar 
with Microsoft products. The user interface has many benefits including the facts 
that many windows can be open at the same time and that the GUI follows the 
same design principles throughout Microsoft Navision. 

Special Facilities in Microsoft Navision 
Microsoft Navision fulfills the requirements of a business management solution 
by supplying tools for entering and managing information and always satisfying 
the current accounting laws. Microsoft Navision also contains some very special 
facilities, which are listed below. Becoming familiar with these facilities will 
help you to fully utilize the program in your daily work. 
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Microsoft Navision provides: 
 

• Direct access from one table to another 
• Easy data entry 
• Information in multiple dimensions 
• Automatic calculation of amounts and quantities 
• Information on what is included in a calculated amount 
• Filtering of information 
• Sorting with one or more keys 
• Pictures of items or a company logo on the screen together with the 

associated information 
• Connections to mail merge, spreadsheet applications and 

presentation graphics programs 
 

Server Options 
Microsoft Navision has two database options: 
 

• Navision Database Server (scalable up to 128 GB) 
• The Microsoft® SQL Server® Option for Navision based on 

Microsoft SQL Server (scalable beyond 128 GB) 
 

Database Features 
Here are some of the features of the two database server options for Microsoft 
Navision: 
 
Navision Database 
Server 

Microsoft SQL Server Option 

Relational Relational 
Version Management Version Management 
Commit Rollback Commit Rollback 
SIFT Technology SIFT Technology 
Client Server Client Server 
Optimistic Concurrency  
 Transaction Logs 
Database Level Security  
 Record Level Security 
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Some of these features are described briefly below.  
 
For more information about the database features, see the manual Application 
Designer's Guide.  

Sum-Indexed Flow Technology − SIFT 
SIFT is the basis of FlowFields. It is a feature in the database that allows you to 
have sums calculated very quickly by maintaining SumIndexes. There are 
columns in which the figures in SumIndexFields are constantly being summed. 
When you want a sum calculated, the program does not have to calculate the sum 
by going through a large number of entries in the database. The sum is calculated 
quickly when the program subtracts one figure in a SumIndex from another. The 
updated sum can be seen in a FlowField every time you open a window that 
contains a FlowField, or when you set a filter on a Balance field. 

Version Management 
Version management builds on a principle that ensures that a user always starts a 
task with the latest updated complete version of the data. The user can work with 
this version of the data, change it, and add new data. After this, the new data will 
become part of a new version of the database. 

Optimistic Concurrency 
Microsoft Navision uses a technique called optimistic concurrency. With 
optimistic concurrency, you always have access to the record you want to work 
with. Thus, if two or more users try to access the same data in the database at the 
same time, they will all be allowed to do so. 

Database Level Security 
This means the access that the users have to the data in the database can be 
defined in terms of the tables that they have access to. 

Record Level Security 
This means the access that the users have to the data in the database can be 
defined in terms of the records that they have access to. 

The Logical Structures in Your Database 
The database is organized in units of fields, records, tables and companies. This 
section describes the basic principles of these structures. 

Fields 
A field is the smallest logical structure used in the C/SIDE database. A field is 
used to hold a single piece of information, such as a name like John or an amount 
like 2,352.00. Any particular field can only contain information of one specific 
data type. The C/SIDE database system distinguishes between 17 different types 
of data. 
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Fields are assembled into a structure called a record. On its own, a field is not 
very useful, as it can hold only a limited amount of information. By assembling 
these small pieces of information into records, we get a much more flexible 
"information-holder" that is better organized, keeping fields together that belong 
together. 

Records  
A record is a logical structure assembled from an arbitrary number of fields. It is 
used to store a single entry in the database. The fields in a record are used to store 
information about important properties of the entry. Records are organized in 
tables. An example of a record is a number of fields with information about a 
single customer. 

Tables  
A table can be thought of as an N by M matrix. Each of the N rows describes a 
record and each of the M columns describes a field in the record. An example of 
a table is the Customer table, which contains a record for each customer. Each 
company in a database contains a number of tables. 

Companies  
A company is the largest logical structure used in a C/SIDE database. A company 
may be considered to be a subdatabase; its primary use is to separate and group 
large portions of data in a database. A company can contain private tables as well 
as tables shared with other companies. 

Navision Application Server 
Navision Application Server is a middle-tier server, which executes business 
logic without user intervention. With Navision Application Server, it is possible 
to communicate with external services. Navision Application Server acts as a 
client towards a database server and can act as a server for other services. When 
you start Navision Application Server, it opens a predefined database and 
executes C/AL code in a predefined codeunit. 
 
To understand more about how Navision Application Server communicates with 
external services, see the online Help project "Development Guide for 
Communication Components." 

No User Interface 
Navision Application Server runs without displaying anything on a screen and 
therefore requires no user interaction. This means that error messages cannot be 
displayed to the user. Instead, error messages are logged in the NT event log. The 
user can, however, interact with Navision Application Server through the 
Navision Application Server Manager.  
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Navision Application Server Manager 
You can install Navision Application Server as a service and manage it through 
the Navision Application Server Manager, which is a Microsoft Management 
Console snap-in. With the Navision Application Server Manager, you can see 
which Navision Application Server properties you have set. You can also add 
and reconfigure Navision Application Server. 

Navision Application Server Versus Navision Server 
It is important to distinguish between Navision Application Server and Navision 
Server, the latter being a database server. For more information about Navision 
Server, see the "Navision Installation and Configuration" manual. 

Running More Than One Application Server 
It is possible to run more than one Navision Application Server with the same 
database or with different databases, but Windows Installer can only install one 
Navision Application Server on each computer. This is because Windows 
Installer checks for existing Navision Application Server installations. 
 
To install more than one Navision Application Server, you must copy all files 
that belong to the previously installed Navision Application Server to another 
target folder. Which files to copy depends on whether you are using Navision 
Database Server or Microsoft SQL Server. 
 
For more information about Navision Application Server, see the "Navision 
Installation and Configuration" manual. 

Multilanguage Functionality 
The multilanguage functionality in Microsoft Navision helps your employees 
work more efficiently. You can switch to virtually any language on the fly. Every 
employee can work in the language of his or her choice, allowing your 
organization to respond quickly and efficiently to international business 
opportunities. 

Speak Your Employees' Language 
Microsoft Navision helps employees become more efficient by eliminating 
language barriers among your multilingual workforce.  
 
Users of Microsoft Navision can work in the language of their choice. For 
example, a Swiss user can run their version of Microsoft Navision in German, 
French or Italian. The local functionality is, however, still Swiss. If the user 
prefers French, but wants to send a report to an Italian colleague, he can do so in 
Italian. This means that, for example, French and Italian colleagues can work 
side by side on the same database or even share a workstation. 
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You can also change languages on the fly; you do not have to close down the 
application and log on again just to switch languages. The real-time functionality 
saves you time. It gives you fast access to the information you need to work more 
efficiently − in your own language. 

Speak Your Customer's Language 
With Microsoft Navision, your customer service improves because you can do 
business in the language preferred by your customer. For example, if a Polish 
customer wants invoices in his native language, you can easily print the invoices 
in Polish from your Microsoft Navision application. You can therefore 
communicate more efficiently with both existing and potential customers and 
partners around the globe.  

Adding a Language Layer 
In order to let the user select a certain language from the Tools menu, that 
language must be present as a granule in the license file. The application must 
also be translated to that language, so that you can import it into the database 
either as a text file or as a language module. Either you can export all text strings 
and translate them in a translation tool, such as the Microsoft Navision 
Localization Workbench, or you can enter the translation of the text strings 
directly in the Multilanguage Editor. 

Multilanguage Editor 
You access the Multilanguage Editor window by selecting an object from the 
Object Designer, clicking on Design and then clicking VIEW→PROPERTIES to open 
the Properties window and clicking the AssistButton in the CaptionML property. 
In the Multilanguage Editor window, you can click the AssistButton in the 
Language field and select your language from the list that appears, or you may 
simply enter the three-letter abbreviation and move the cursor to the Value field. 
The system then replaces the abbreviation with the full language description. In 
the Value field, enter the correct term for this object in this language. To save 
your entry, you must click OK before exiting the window. 

Developing Multilanguage-Enabled Applications 
When you develop in a multilanguage-enabled environment, it is important to 
remember the following three rules of thumb: 
 

• Everything has a Name property in (United States) English 
• Text constants replace text strings, such as error messages 
• Everything that the user will see must have a Caption property 
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Before you start working in a multilanguage-enabled database, you should set the 
application language to (United States) English. You do this by clicking 
TOOLS→LANGUAGE and selecting English (United States): 
 

 
 
In Microsoft Navision, the code base is English (United States). This means that 
the Name property of, for example, an object must always be English (United 
States). 
 
The code base in English (United States) includes, among other things, the 
following: 
 

• Object names 
• Field names 
• Function and variable names 
• Comments 
• Option strings 
• Control names 

 
For more information about how to develop multilanguage-enabled applications, 
see the "Application Designer's Guide" manual. 
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Test Your Knowledge − Technology  
1. Name the seven types of objects in C/SIDE. 

 

2. Name the four types of tables in C/SIDE. 

 

3. What is a codeunit? 

 

4. Explain C/AL. 

 

5. What are the special facilities in Microsoft Navision? 

 

6. Microsoft Navision can be installed on which database servers? 

 

7. Explain SIFT. 

 

8. Define/describe the following and the relationship between them: a 
record, a field, a table, a company. 

 

9. Describe the features of Navision Application Server. 

 

10. Describe the multilanguage features in Microsoft Navision. 
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Quick Interaction: Lessons Learned 
Take a moment to write down three Key Points you have learned from this 
chapter: 
 
1. 

 

 

 

 

 
 
2. 

 

 

 

 

 
 
3. 
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CHAPTER 3: ORDER PROCESSING − PURCHASES, 
PAYABLES, AND GENERAL LEDGER  

 
• Overview 
• Processing Overview 
• Purchase Order Processing 
• Payables Processing  
• General Ledger Adjustments 

Overview 
This chapter covers the order processing functionality of Microsoft® Business 
Solutions−Navision®. In this chapter you learn more about the various steps of 
purchase order processing in Microsoft Navision. Through exercises you become 
more familiar with how this functionality is integrated into the program.  
 
In the first section, Processing Overview, you learn about setting up Vendors and 
Items. You also learn about various costing methods within Microsoft Navision, 
such as FIFO and Last Direct Cost. 
 
In the second section, Purchase Order Processing, you learn about: 
 

• Creating a Purchase Order 
• Creating a Purchase Invoice 
• Using History to view Posted Documents 

 
This section not only allows you to learn first hand the method of entering 
purchase documents in Microsoft Navision, but also lets you use the Microsoft 
Navision History functionality to view the results of your work. 
 
The third section, Payables Processing, we will take a look at the Accounts 
Payable report as well as the methods of performing payables transactions within 
Microsoft Navision. You get to use the various ways of paying an invoice within 
Microsoft Navision, as well as learn to print and post checks. 
 
The final section, General Ledger Adjustments, leads you through the process of 
making correcting entries into a journal in Microsoft Navision. Afterwards, you 
will be taking a look at the results of your work using the Register.  
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Processing Overview 
Integration 
Before starting with processing, we need to discuss integration in Microsoft 
Navision. 
 

 
 
The above diagram is meant to portray some of the integration in Microsoft 
Navision. If you plan to use Inventory, many of the transactions that you post 
will ″flow through″ Inventory. The Purchase of Items results in an increase in the 
balance in Inventory, and updates General Ledger with the balance due to the 
Vendor and the increase in Inventory. 
 
Processing a Sales Order similarly affects Inventory and General Ledger as will 
producing Inventory Items. 
 
The General Ledger works as the data collection point for the entire system. Very 
little data flows back the other way. There are of course other interactions 
between the non-General Ledger modules, but for the time being if you can 
understand the above diagram it will go a long way to improving your 
understanding of the fundamental way Microsoft Navision operates.  
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Purchase, Payables, and General Ledger Processing 
The following diagram is a visual representation of the process steps we perform 
in Purchases and Payables, and the impact that the processing has on other 
application areas. 
 

 
 
Begin by creating a Vendor and Item. Then create a Purchase Order using the 
new Vendor and Item. After the Purchase Order is created, post a Receipt. This 
updates the Quantity on Hand (Inventory) in inventory for the Item. Next, Post an 
Invoice from the Order. This updates the Vendor card for the liability and update 
the Chart of Accounts as well.  
 
The exact accounts updated in the Chart of Accounts depends upon the posting 
options selected in a company; any explanation beyond that is covered in later 
classes.  
 
Finally, issue payment to the Vendor utilizing functionality in Microsoft 
Navision. Issuing Payment updates the Vendor's balance and the balance in the 
Chart of Accounts. 
 
Now go to Microsoft Navision and create the Vendor, Item and then begin 
processing. 
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New Vendor and Item Setup 
Scenario 1: As the Accounting Clerk at Cronus International, you are 
responsible for setting up new Items, Vendors and Customers. A new customer 
has asked for a special paint that you currently do not sell. In fact, you need to 
locate a vendor from whom you can purchase this particular color: Sunflower 
Yellow. 
 
In this section you will create the new vendor and item and associate the item to 
the vendor. We will not be defining every field on the Vendor or Item cards, only 
those that are necessary for processing and posting Purchase, Payable and 
General Ledger entries. The new Customer will be setup in Chapter 4. 
 

NOTE: You can always find more information about fields by using the f1 help or 
clicking the What's This? button and then clicking the field in question. 

Change the Work Date 
In this database, all postings must happen between November − February. 
 

1. Click TOOLS→WORK DATE. The Work Date window appears.  

2. Type 01/01/04. 

3. Press ENTER or click OK. 

Vendor Setup 
On the Purchase menu, click ORDER PROCESSING→VENDORS. The Vendor Card 
window appears: 
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1. Press F3, or click the Insert button on the Toolbar, to insert a new 
Vendor Card. 

2. In the No. field, press F6 or click the AssistButton. The No. Series 
window appears. No. Series are setup when new companies are 
created and used to allow for automatic or manual numbering. 
Multiple or single No. Series can be setup for each card. In the Item 
card setup, you will see a multiple No. Series setup. 

 In the No. Series window, notice that there is a Starting and Ending 
number. If you scroll to the right, you will see that both the Default 
Nos. and Manual Nos. check boxes are selected. This means that a 
user can either have a number created automatically (by pressing the 
ENTER key after inserting a new record) or manually (by typing it) in 
the No. field.  

 The number identifies the vendor and is used when you post from a 
journal or set up quotes, orders, invoices and credit memos. 

 You cannot fill in the other fields in the Vendor table until you have 
entered a number in the No. field. This is true of all cards (G/L 
Accounts, Customers, Items, Jobs, Orders, Invoices, Shipments, 
Contracts, etc.).  

3. Press ESC to return to the Vendor Card and press the ENTER key to 
assign a number from the No. Series.  

 If using Manual Nos. you could enter an alphanumeric value. 

 
NOTE: You do not need to open the No. Series window each time you create a new 
record. We only opened this window to explain the No. Series. 
 

4. In the Name field, type AR Day Property Management XYZ. 

5. In the Address field, type 200 Bay Drive. 

6. In the Post Code field, type GB-L18 6SA. 

7. Notice that the City field is now populated with Liverpool. A Post 
Code and City combination has been setup which allows users to 
type in (or lookup and choose) either a Post Code or City which 
then will automatically populate the other respective field. If the Post 
Code and City table has not been setup, users will need to type in 
both the Post Code and City manually. 

8. In the Country field, type in GB. 

9. In the Contact field, enter Laura Owen.  

10. Click on the Invoicing tab. 
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11. In the Gen. Bus. Posting Group field, lookup to the Gen. Business 
Posting Group window. Click on the record indicator on the line for 
NATIONAL and click OK and press ENTER. 

12. The VAT Bus. Posting Group field should populate with 
NATIONAL. Do not change this as it has defaulted in from the Gen. 
Business Posting Group setup. 

13. In the Vendor Posting Group field, press F6 and since DOMESTIC 
is selected in the list, press ENTER. Be sure to press ENTER again or 
tab off the field as leaving the field commits the data to the field. 

 
NOTE: Always tab off a field or press ENTER after entering data into a field. This is how 
data is committed (saved) into the field. 

 
14. Click on the Payments tab. 

15. In the Application Method field, leave the default of Manual. Here 
you can choose how the program will apply entries for this vendor. 
Manual means that the program will apply payments only if you 
specify a document. The other option, Apply to Oldest, means that if 
you do not specify a document for the payment to be applied to, the 
program will apply the payment to the oldest of the vendor's open 
entries. 

16. In the Payment Terms Code field, lookup (F6 or click the 
AssistButton) and use the ARROW DOWN key to select 7 DAYS and 
press ENTER. The Payment Terms Code, combined with the 
Document Date, determines when the Vendor expects payment. 
When a Purchase Order or Invoice is created, this code, 7 DAYS, 
will default in and will calculate the Due Date seven days from the 
Document Date of the Order or Invoice. 

The Receiving and Foreign Trade tab would be filled out if you have default 
Location, Shipping Method needs, or if this Vendor has a different currency or 
language than your company.  
 

17. Close the Vendor Card window. 

 
The Vendor card setup is complete for this scenario. Now create the Item card. 
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Item Setup 
On the Purchase menu, click INVENTORY & COSTING→ITEMS. The Item Card 
window appears: 
 

 
 

1. Press F3, or click the Insert button, to insert a new Item Card. 

2. In the No. field, lookup to the No. Series window. Multiple No. 
Series have been setup for Item numbers. Since there are various 
types of Items that Cronus sells, they have chosen to set up multiple 
No. Series so that the same type of Items will be grouped together. 
Click on the second line, ITEM2, which is the "Paint" No. Series, 
and then click OK. 

 The No. field should now be populated with 70105, since that is the 
next number available in the "Paint" No. Series.  

3. Press ENTER or TAB to go to the Description field. Type Paint, 
sunflower yellow. 

4. In the Base Unit of Measure field, press F6 or click the 
AssistButton. The Item Units of Measure window appears. 

 We are now selecting the Base Unit of Measure for this item. If we 
wanted to sell this item at another unit of measure, for instance, by 
the case rather than the can, we could setup other units of measure in 
this window. 

5. In the Code field, either press F6 or click the AssistButton. The 
Units of Measure window appears. 

6. Click on the record indicator for CAN and then click OK. 

7. The Qty. per Unit of Measure field populates with 1.  

8. Click on the record indicator for CAN and then click OK. 
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9. The Base Unit of Measure field will now be populated with CAN. 

10. In the Shelf No. field type B6. Here you can specify where to find 
the inventory item in the warehouse. 

11. Click the Invoicing tab. 

12. In the Costing Method field, leave FIFO. FIFO means First-in-First-
out. With this method, the items that were purchased first are always 
sold first. The FIFO costing method values the inventory decrease by 
using the value of the first inventory increases on inventory.  

 Since the Costing Method determines how costs are calculated and 
how inventory is valued, please see the F1 help to find out more 
about the other options. 

13. In the Unit Cost field, type 1.40. This field contains the most recent 
direct unit cost that was paid for the items. 

14. In the Last Direct Cost field, type 1.40. This field contains the most 
recent direct unit cost that was paid for the items. 

15. In the Unit Price field, type 2.70. This is the unit price of the item, in 
local currency (LCY). 

16. Notice that the Profit % field is now populated. This field is 
automatically calculated based on the selection made in the 
Price/Profit Calculation field. The current selection Profit=Price-
Cost calculates the Profit % based on the Unit Price − the Unit Cost.  

17. In the Gen. Prod. Posting Group field, lookup (F6 or the 
AssistButton) to the Gen. Product Posting Group window and click 
on the record indicator for RETAIL. Click OK and press ENTER. 

18. In the VAT Prod. Posting Group field should populate with 
VAT25. Do not change this as it has defaulted in from the Gen. 
Product Posting Group setup. 

19. In the Inventory Posting Group field, press F6, click on the record 
indicator for RESALE, and click OK. Be sure to press ENTER again 
or tab off the field as leaving the field commits the data to the field. 

20. Click on the Replenishment tab. 

21. In the Replenishment System field, leave Purchase. Since we are 
purchasing this item and not producing (Prod. Order) it, we will 
leave it as Purchase. 

22. In the Vendor No. field, press F6 to open the Vendor List and select 
the Vendor you created in the above section: AR Day Property 
Management XYZ. Press ENTER twice. 

23. The other tabs are not necessary to fill out at this time. Close the 
Item Card window.  

 
The Item card setup is complete for this scenario. 
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Test Your Skills − Creating an Item and Vendor 
Scenario: As the Purchasing agent for Cronus International, Ltd. you are 
responsible for setting up new items as well as new vendors. A customer has 
requested two items of which one is not currently stocked by your company. You 
need to create a new item as well as a new vendor that will supply this new item.  
 
Use the following to create the new item and vendor:  
 
Item No. 80301 
Description USB Mouse 
Unit of Measure PCS 
Costing Method FIFO 
Unit Cost 11.50 
Last Direct Cost 11.50 
Price/Profit Calculation Profit=Price-Cost 
Unit Price 14.375 
General Product Posting Group RETAIL 
VAT Product Posting Group VAT25 
Inventory Posting Group RESALE 
Replenishment System PURCHASE 

 
Vendor No. 40101 
Vendor Name Lewis Home Furniture XYZ, LTD. 
Address 89 Radcroft Road 
Postal Code GB-IB7 7VN 
City Gainsborough 
Phone No. 23159799 
Contact Katie Jordan 
General Business Posting Group NATIONAL 
VAT Business Posting Group NATIONAL 
Vendor Posting Group DOMESTIC 
Application Method MANUAL 
Payment Terms Code 1M(8D) 
Payment Method Code CHECK 
Location Code BLUE 
Shipment Method Code CIF (Cost, Insurance and Freight) 
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All Skill Levels 
Your tasks are as follows: 
 

1. Create an item and vendor using the information provided above. 

2. View the newly created item and vendor cards. 

Need a Little Help? 
 

• Go to PURCHASE→INVENTORY & COSTING→ITEMS.  
• Create a new item card. 
• Use the above data to complete the item card. 
• Go to PURCHASE→ORDER PROCESSING→VENDORS. 
• Create a new vendor card. 
• Use the above data to complete the vendor card. 
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Purchase Order Processing 
Scenario 2: As the Accounting Clerk at Cronus International, you are also 
responsible for purchasing. The Customer has requested the Sunflower Yellow 
paint and you have received a phone call from the sales department asking if you 
could place the order for 100 cans of the paint. They also suggested you order 
200 cans to keep in stock as this will be a return customer. There will be a 
backorder so a partial receipt will be necessary. 
 
In this section you will create the purchase order for the Sunflower Yellow paint 
for Vendor AR Day Property Management XYZ. We will not be defining every 
field on the Purchase Order, only those that are necessary for processing and 
posting the Purchase Order. 

Create a Purchase Order 
On the Purchase menu, click ORDER PROCESSING→ORDERS. The Purchase Order 
window appears: 
 

 
 
The Purchase Order contains a header section (top) and a line section (bottom).  
 

1. With the cursor in the header, press F3 to insert a new Purchase 
Order. 

2. Press ENTER to automatically assign a No. 
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3. In the Buy-from Vendor No. field, lookup (press F6 or click the 
AssistButton) to the Vendor List. Locate the Vendor you created in 
the previous section: No. V00010, AR Day Property Management 
XYZ and press ENTER twice.  

 Notice that some of the fields on the header are now populated with 
the information that you entered on the Vendor Card. The data in 
these fields can be changed here, such as changing the Buy-from 
Contact name if the person you spoke to when ordering this product 
was different than the contact on the Vendor Card. Making changes 
here do not affect the Vendor Card; these changes will remain with 
this particular order. 

4. Make note of the Document Date. Click on the Invoicing tab and 
note the date in the Due Date field. Remember, the Document Date 
and the Payment Terms Code determine the Due Date. Since we 
setup this Vendor with seven day terms, the Due Date will be seven 
days after the Document Date. In this case, 01/08/04. Go back to the 
General tab. 

5. Click in the lines section. 

 
REMEMBER: If you prefer to use the keyboard you can use the ARROW DOWN key to get 
down to the lines section of the Purchase Order. To get back to the header press CTRL + 
ARROW UP. 

 
6. The first field is the Type field. Press F6 to view the options list. 

Since we are purchasing an item, select Item from the list. 

7. Tab or press ENTER to go to the No. field. Since Item was selected in 
the Type field, this field represents the Item No. Press F6 to lookup 
to the Item list. Locate the Item you created in the previous section: 
Paint, sunflower yellow. Press ENTER twice.  

8. Notice that the Description field is now populated with Paint, 
sunflower yellow, which is the description from the Item card. The 
Description field can be modified. 

9. In the Location Code field, press F6 to open the Location List 
window. Click on the line for BLUE and click OK. Press ENTER. 
The Location Code field contains the code for the location where 
the items on the line will be located. 

10. In the Quantity field, type 200. This is the number of items you are 
ordering from this vendor. 

11. Notice that the Direct Unit Cost Excl. VAT field has been 
populated with the Unit Cost amount from the Item card. Also notice 
that the Line Amount Excl. VAT field automatically calculated the 
Quantity * Direct Unit Cost Excl. VAT (200 * 1.40).  
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 If you were to change the values in either the Quantity or Direct 
Unit Cost Excl. VAT fields, the Line Amount Excl. VAT field 
would recalculate automatically. If you were to change the Line 
Amount Excl. VAT field, the Line Discount % field would 
calculate a percentage based on this change. 

12. Click ORDER→STATISTICS (F9). The Purchase Order Statistics window 
appears. You can use this window to get a quick overview of a 
purchase order. The window shows detailed information about the 
specific order and the quantities that will be invoiced and received. 

 The General tab displays information regarding the entire purchase 
order. The Invoicing tab displays information about the quantity of 
items to be invoiced. The Shipping tab displays information about 
the quantity of items to be received. The Vendor tab displays the 
Vendors current balance. Notice that right now all the tabs, other 
than the Vendor tab, display the same information. We will come 
back to this window shortly. Press ESC to go back to the order. 

13. Go to the Qty. to Receive field in the lines. The field has been 
updated with the Quantity value. Change this value to 75. Note that 
the Qty. to Invoice field is updated to 75 as well. Clear the Qty. to 
Invoice field. We are going to do a partial receipt first. 

 The Qty. to Receive and Qty. to Invoice fields are used in the 
receiving and invoicing process. If part of your paint order was 
backordered but you received the available shipment, you could 
enter the amount received in the Qty. to Receive field and then post 
the receipt to adjust inventory.  

 The Qty. to Invoice field is used to determine how much of the line 
should be invoiced. This field is used only when you post orders. 
Each time the Quantity field is updated and you post an order, the 
program will automatically suggest invoicing the quantity that has 
not yet been invoiced. Generally, an order is invoiced when you 
receive the invoice from the Vendor. At that time, the amount to 
invoice would be entered into the Qty. to Invoice field and then 
posted. Once the order is posted, a Posted Purchase Invoice is 
created, which also creates a payable in the general ledger. 

 
NOTE: It is never possible to invoice more than you have received. 

 
 These two processes can be done simultaneously by entering the 

received amount in both the Qty. to Receive and Qty. to Invoice 
fields.  
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14. Click F9 to open the Purchase Order Statistics window. The General 
tab still displays the total amounts of the order. Now click on the 
Invoicing tab and note that there are no values displayed. This is 
because you cleared the Qty. to Invoice field on the order. Click on 
the Shipping tab and note that the partial receipt amounts are 
displayed. Press ESC to go back to the order. 

15. Click POSTING→POST (F11). The following window appears:  

 

 
 

16. The default is Receive and Invoice but since we are only receiving 
this, click Receive and then click OK. 

The Qty. to Receive field is now populated with 125, the Qty. Received field is 
populated with 75, and the Qty. to Invoice field is populated with 200. Since we 
posted a partial receipt of 75, the Qty. Received field displays the amount of the 
posted receipt: the quantity received into inventory. We still have 125 more to 
receive so the Qty. to Receive field displays that amount: the quantity still to 
receive. And we have not invoiced this product yet so the Qty. to Invoice 
displays the total quantity of the order that has not been invoiced, which is 200.  
 
At this point, if you wanted to post an invoice for the partial receipt, you could 
clear the Qty. to Receive field and change the Qty. to Invoice to 75 and then 
post the invoice.  
 
Scenario 3: Some time has passed and the backordered items have been shipped 
to your BLUE location. You now need to receive these items and invoice the 
entire purchase order. 
 

1. But first, click F9 to open the Purchase Order Statistics window. The 
General tab still displays the total amounts of the order. Now click 
on the Invoicing tab and note that the values match the General tab 
since you are invoicing the entire order. Click on the Shipping tab 
and note that the partial receipt values are displayed. Press ESC to go 
back to the order. 

2. In the header, go to the Posting Date field and change the date to 
01/05/04. Since you are receiving and invoicing on a different date, 
you need to make the Posting Date be the date we receive and 
invoice the items.  
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 You may notice that the Document Date also changed. Remember 
that the Document Date partially determines the due date. Generally 
the Document Date should be the same as the date on the vendors 
invoice. Do not change the date for this scenario, but note that the 
Due Date is now 01/12/04. 

3. In the Vendor Invoice No. field, type 9467725. This is the vendors 
invoice number, typically found on the invoice they send you. A 
Purchase Order cannot be posted without a Vendor Invoice No. 

4. Click POSTING→POST (F11). The Posting window appears. Receive 
and Invoice is the default. Click OK. 

 
The order is fully received and invoiced. You may notice that the Order 
disappeared and you are now looking at a different order. This happens because 
when you have completely received and invoiced an order in Microsoft Navision, 
it becomes a posted document. The posted invoices can be located on the 
Purchase menu by clicking HISTORY→POSTED INVOICES.  
 
When the Posted Purchase Invoice window is opened, press F5, or click the List 
button, to display all the Posted Invoices. Generally, the last invoice posted is at 
the bottom of the list, unless multiple number series are used for invoices. In this 
case, scroll to the bottom of the list (CTRL + PAGE DOWN). When you locate the 
invoice, click on the line and press ENTER or click OK.  
 
Posted Documents are not editable, but you can print them numerous times.  
 
Close the Posted Purchase Invoice and Purchase Order windows. 
 

Vendor Ledger Entries 
Go to the Vendor card to view the entries made. 
 

1. Click ORDER PROCESSING→VENDORS. The Vendor Card window 
appears. 

2. Press F5 or click the List button to display the Vendor List. Locate 
Vendor V00010 AR Day Property Management XYZ and click the 
line and press ENTER or click OK. 
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3. Click VENDOR→LEDGER ENTRIES. The Vendor Ledger Entries window 
appears:  

 

 
 
Notice that the External Document No. field is populated with the Vendor 
Invoice No. you entered on the Purchase Order. The entire amount of the Invoice 
appears in the Original Amount, Amount and Remaining Amount fields. Once 
a full payment has been posted and applied, the Remaining Amount will be 0.  
 
Scroll to the right and click in the Due Date field. At first it appears that this field 
is non-editable but if you press F2, you see that you can edit this field. Microsoft 
Navision allows Due Dates, Discount Dates and Discount Amounts to be edited. 
Do not change the Due Date, leave it as 01/08/04. Close the Vendor Ledger 
Entries and the Vendor Card windows. 

Item Card and Item Ledger Entries 
Now we will look at the Item Card and the Item Ledger Entries.  
 

1. From the Purchase menu, CLICK INVENTORY & COSTING→ITEMS. The 
Item Card window appears. 

2. Press F5 or click the List button to display the Item List. Locate Item 
Paint, sunflower yellow and click on the line and press ENTER or 
click OK. 

3. Click the Invoicing tab. 

4. The Average Cost (LCY) field is now populated with a value. This 
field was automatically populated when you posted the purchase 
order. This field will get updated each time this item has activity 
posted. 
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5. Click ITEM→ENTRIES→LEDGER ENTRIES. The Item Ledger Entries 
window appears: 

 

 
 

 There are two Item Ledger Entries; one for each Receipt that was 
posted. 

6. Click on the first line and click ENTRIES→VALUE ENTRIES. The Value 
Entries window appears: 

 

 
 

 There are two Value Entry lines: one for the Receipt and one for the 
Invoice. The two lines can be distinguished by looking at the Item 
Ledger Entry Quantity and Invoiced Quantity fields. The Receipt 
line will have a value in the Item Ledger Entry Quantity field but 
not in the Invoiced Quantity field. The Invoice line will be the 
opposite; the Invoiced Quantity field will have a quantity while the 
Item Ledger Entry Quantity field will be 0. In addition, the lines 
will have different document numbers. 
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Value entries are important because they capture all of the activity 
that constitutes the dollar amounts displayed in the Item Ledger 
Entry lines. This level of detail makes it very easy to audit the costs 
assigned to Items in Microsoft Navision. 

7. Escape back to the Item Ledger Entries window. 

8. Click on the second line and click ENTRIES→VALUE ENTRIES. The 
Value Entries window appears. 

 This Value Entry only displays a single line, with quantities in both 
the Item Ledger Entry Quantity and Invoiced Quantity fields. 
These fields are both populated because you posted the Receipt and 
Invoice simultaneously (using the Receive and Invoice posting 
option) during the final posting of the Purchase Order. You will learn 
more about Item Ledger Entries and Value Entries in later courses. 

9. Close the Value Entries, Item Ledger Entries, and Item Card 
windows. 
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Test Your Skills − Creating a Purchase Order 
Scenario: As the Purchasing agent for Cronus International, Ltd., you need to 
create a purchase order to purchase two items.  
 
Use the following data to create the purchase order:  
 
Purchase Order Number System Assigned 
Vendor Number 40101 
Item Numbers 80216 and 80301 
Item Name Ethernet Cable & USB Mouse 
Location Code BLUE 
Quantity for Item No. 80216 6 
Quantity for Item No. 80301 12 
Unit of Measure PCS 

 

All Skill Levels 
Your tasks are as follows: 
 

1. Using the information provided above, create a purchase order. 

2. Verify that the Direct Unit Price for both Items. 

Need a Little Help? 
 

• Go to PURCHASE→ORDER PROCESSING→ORDERS. 
• Create a new purchase order. 
• Use the above data to fill the purchase order window. 
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Test Your Skills − Receiving and Invoicing a Purchase Order 
Scenario: As the Purchasing agent for Cronus International, Ltd., you are 
responsible for purchasing items. You have created, printed and emailed a 
purchase order to the supplying vendor. Now, the items that are related to the 
purchase order have arrived on the warehouse dock. You can fully Receive and 
Invoice this order. 
 
Use the following data to receive and invoice the items:  
 
Purchase Order Number Previously System Assigned 

Number 
Vendor Number 40101 
Item Numbers 80216 and 80301 
Item Name Ethernet Cable & USB Mouse 
Location Code BLUE 
Quantity for Item No. 80216 6 
Quantity for Item No. 80301 12 
Vendor Invoice Number LHF-10021 

 

All Skill Levels 
Your tasks are as follows: 
 

1. Using the information provided above, receive and invoice the 
related purchase order. 

2. Verify that the quantity(s) to receive is(are) correct. 

3. Verify that the quantity(s) to invoice is(are) correct. 

4. Receive and Invoice the Order. 

Need a Little Help? 
 

• Go to PURCHASE→ORDER PROCESSING→ORDERS. 
• Fill in the Vendor Invoice No. field. 
• Click on the Posting button and Receive and Invoice the Order. 
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Create a Purchase Invoice 
Purchase Orders, as well as Sales Orders, are generally used for transactions 
involving inventory. While you can post an Item on a Purchase Invoice, you lose 
the receiving functionality. Purchase Invoices are mostly used for transactions 
involving general ledger activity. Purchase Invoices are also used most often for 
utility bills and other bills that you receive from vendors that do not affect 
inventory. 
 
Scenario 4: As the Accounting Clerk for Cronus International, you are also 
responsible for posting utility bills. The postage bill has arrived and you need to 
post it into Microsoft Navision. The Vendor is No. 10000, London Postmaster; 
the date of the invoice is 01/01/04; the Invoice No. is 88574; the amount is 
365.32 (LCY); and it needs to be posted to the Postage G/L Account.  
 
But first, change the work date to better show functionality. 
 

1. Click TOOLS→WORK DATE. The Work Date window appears.  

2. Type 01/15/04 and press ENTER or click OK. 

3. On the Purchase menu, click ORDER PROCESSING→INVOICES. The 
Purchase Invoice window appears: 

 

 
 

4. Press F3 to insert a new Purchase Invoice. 

5. Press ENTER to automatically assign a No. 
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6. In the Buy-from Vendor No. field, type 10000 and press ENTER. 
The header will be populated with the London Postmaster data. 

7. Leave the Posting Date as 01/15/04 but in the Document Date field, 
change the date to the Invoice date: 01/01/04. The Due Date will 
now be based on the Invoice date, not your Posting Date. 

8. In the Vendor Invoice No. field, type 88574. Similar to the Order, a 
Purchase Invoice cannot be posted without a Vendor Invoice No. 
Press ENTER and you should be taken into the lines section. If not, 
click in the lines. 

9. In the Type field, press F6 to display the options. Since we are 
posting to a General Ledger Account, click G/L Account and then 
press ENTER. 

10. In the No. field, press F6 to lookup to the G/L Account List. Locate 
the ″Postage″ G/L Account: 8240 and press ENTER twice.  

 Since G/L Account was selected in the Type field, this field 
represents the G/L Account No.  

11. In the Quantity field, type 1. Since you are entering a full amount, 
there is no reason to break out the quantities. 

12. In the Direct Unit Cost Excl. VAT field, type 365.32.  

13. Scroll to the right and notice that the Qty. to Receive and Qty. to 
Invoice fields do not exist. Again, this is because this is not a 
receiving document. 

14. Click POSTING→POST (F11). The message will appear asking if you 
want to post the Invoice. Click Yes. 

Now that this Invoice is posted, you may notice that it has disappeared from the 
Purchase Invoice window. Just like the Purchase Order, when the Purchase 
Invoice is posted, it becomes a posted invoice. The posted invoices can be 
located on the Purchase menu by clicking HISTORY→POSTED INVOICES. 
 
As stated previously, posted documents are not editable, but you can print them 
numerous times.  
 
Close the Posted Purchase Invoice and the Purchase Invoice windows. 
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Test Your Skills − Record Automobile Maintenance Expense 
Scenario: In Cronus International, Ltd. you are the accounts payable clerk, 
responsible for posting and paying expenses. You have received a bill from 
Mortimor Car Company for routine automobile maintenance services. You need 
to record this expense for payment. 
 
Use the following data to enter the expense:  
 
Purchase Order Number System Assigned Number 
Vendor Number 44127914 
Vendor Name Mortimer Car Company 
Posting Date 01/14/04 
Vendor Invoice Number LP-45002 
Item Type G/L Account 
G/L Account Number 8530 
Description Repairs and Maintenance 
Amount 132.94 

 

All Skill Levels 
Your tasks are as follows: 
 

1. Using the information provided above, record this expense for 
payment. 

2. Post the invoice. 

Need a Little Help? 
 

• Go to PURCHASE→ORDER PROCESSING→INVOICES. 
• Fill in the Vendor Invoice number field.  
• Change the Posting Date. 
• Go to the Posting button. 
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Payables Processing 
In this section you will run the A/P Aging report and then print and post checks. 
We will not be defining every field on the report request form or the Suggest 
Vendor Payments form. For more information about the other fields, please use 
the F1 help. 
 
Scenario 5: As the Accounting Clerk for Cronus International, you are also 
responsible for running the A/P Aging report prior to printing Vendor checks. 
Run the report for all vendors, aged as of 01/31/04, aged by the due date, with a 
period length of one month and print details. 

Running the A/P Aging Report 
On the Financial Management menu, click PAYABLES→REPORTS→AGED 
ACCOUNTS PAYABLE. The Aged Accounts Payable window appears.  
 

1. The Vendor tab allows you to filter the report using the fields on the 
Vendor table. The No. field on this tab represents the Vendor No. 
Since you are running the report for all vendors, do not enter 
anything into the No. field. 

 
NOTE: Did you notice that the tab is called Vendor? If this was a Customer report this 
tab would be called Customer. The table a report is running from will usually be the 
name of the first tab. 

 
2. Click on the Options tab. 

 

 
 

3. In the Aged As Of field, type 01/31/04. This date determines how 
the aging will be calculated.  
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4. In the Aging by field, keep Due Date selected. In this area you select 
whether the aging will be calculated from the invoice due date, 
posting date or document date. 

5. In the Period Length field, type 1M. This determines the length of 
the aging, in this case, one month. 

6. Select the Print Details check box. Selecting this adds lines for open 
invoices for each vendor to the report. If this field is not checked, the 
invoice amounts will be summarized onto one line for each vendor.  

7. Click Preview.  

8. Take a look at the report. Notice the invoice you posted to London 
Postmaster appears as due this month. Go to the next page and look 
at the AR Day Property Management XYZ vendor. This invoice is 
due this month as well. 

9. Close the Print Preview window. 

Pay the Vendor  
Scenario 6: It is the end of the month − as the Accounting Clerk for Cronus 
International, it is time to print Vendor checks. You will pay the Purchase 
Invoice for the paint to Vendor V00010 − AR Day Property Management XYZ. 
 
But first, change the work date to better show functionality. 
 

1. Click TOOLS→WORK DATE. The Work Date window appears.  

2. Type 01/28/04 and press ENTER or click OK. 

3. On the Financial Management menu, click PAYABLES→PAYMENT 
JOURNALS. The Payment Journal window appears: 
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4. In the Batch Name field, keep BANK selected.  

5. Click PAYMENTS→SUGGEST VENDOR PAYMENTS. The Suggest Vendor 
Payments window appears. As you saw in the reporting section, the 
first tab of the request form is used for filtering on fields on that 
table. Here again you see it is the Vendor table. Since you want to 
look at the entries for AR Day Property Management XYZ you will 
filter the list by Vendor No. 

6. In the No. field, type V00010. 

7. Click the Options tab. 

 

 
 

8. In the Last Payment Date field, type 01/31/04. 

9. In the Posting Date field, leave the work date of 01/28/04. 

10. In the Bal. Account Type field, click the AssistButton and click 
Bank Account. 

11. In the Bal. Account No. field, click the AssistButton, click WWB-
OPERATING and click OK. 

12. In the Bank Payment Type field, click the AssistButton and click 
Computer Check. Selecting Computer Check directs Microsoft 
Navision to create a computer check for printing, otherwise if you 
just need to post a handwritten check in the system, you should select 
Manual Check. 

13. Click OK. 
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14. The Payment Journal should display one line and a message should 
appear stating that you have created suggested vendor payment lines 
for all currencies. Click OK. 

 
NOTE: Quite often several lines will come into the Payment Journal when you run the 
Suggest Vendor Payment batch job. You can delete the lines you do not want to pay by 
selecting those lines and pressing F4. They are ONLY removed from this particular 
payment journal and can be suggested again. 

 
15. Press ARROW-UP to go to the first line Notice that the Posting 

Date is the work date and that the Amount field is populated with 
the amount of the Purchase Invoice: 350.00. 

16. Scroll over to the Applies-to Doc. No. field. Press F6 to open the 
Apply Vendor Entries window.  

17. In the lines, click on the first line and click Navigate. In the Navigate 
window, with Posted Purchase Invoice selected, click Show. From 
the Posted Purchase Invoice window, click on the first line and then 
click INVOICE→CARD. The Posted Purchase Invoice you created for 
the paint appears. 

18. Press ESC four times to get back to the Payment Journal. 

19. Click PAYMENTS→PRINT CHECK. The Check request form window 
appears. 

20. Do not change the filters set on the Gen. Journal Line tab. 

21.  Click the Options tab. 

 

 
 

22. In the Bank Account field, press F6, click on the WWB-
OPERATING line and press ENTER or click OK. Press ENTER 
again. 

23. The Last Check No. field will automatically be populated from the 
Last Check No. field on the Bank Account card. 



 

 

Microsoft Navision Introduction 

Page 84 

24. Select the One Check per Vendor per Document No. check box. 
By checking this box, you get one check per vendor for each check 
number. 

25. Click Print. 

26. In the Check − Print dialog window, verify that Microsoft Navision 
is pointing to the correct printer, and click OK.  

 
NOTE: If you do not want to print an actual check for this exercise select the Print to 
file check box on the Check − Print dialog window and click OK. The Print to File 
window will appear. Type a file name and click OK. 

 
27.  A second line now appears in the Payment Journal. This is the bank 

balancing line. 

28. Notice that the Document No. field on both lines is populated with 
the check number that was automatically populated on the Options 
tab of the Check window. 

29. Click on the second line and notice that the Balance and Total 
Balance fields in the lower right corner both display "0". This 
indicates that this journal is in balance and can be posted − you 
cannot post journals that do not balance. 

30. Click POSTING→POST (F11). A message appears asking if you want to 
post the journal lines. Click Yes. 

31. The Payment Journal runs through the posting process and then 
when completed, a message appears indicating that the lines were 
successfully posted. Click OK. 

32. Do not close the Payment Journal window. 

Manually Entering a Payment Journal Line 
Instead of running the Suggest Vendor Payments batch job, you are able to 
manually enter payment lines. 
 
Scenario 7: The postage bill for London Postmaster (Vendor No. 10000) is due 
for payment. You decide to manually enter the line rather than using the Suggest 
Vendor Payments batch job.  
 

1. Using the same batch BANK, click on the empty line in the payment 
journal. 

2. Leave the Posting Date as 01/28/04. 
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3. In the Document Type field, leave Payment. 

4. Clear the Document No. field. 

5. In the Account Type field, press F6 and click Vendor. 

6. In the Account No. field, type 10000. 

7. In the Applies-to Doc. No. field, press F6 to open the Apply Vendor 
Entries window. 

8. Notice that there are several line entries. All of the open entries for 
this Vendor appear in the detail lines. The last line entry is the 
postage invoice which you need to pay. Click on that line and press 
ENTER or click OK. 

9. Notice that the Applied-to Doc. Type field is Invoice and the 
Applied-to Doc. No. field is the same as the Document No. from the 
Posted Purchase Invoice. The Amount field has also been 
automatically populated with the amount of the Posted Purchase 
Invoice. 

10. In the Bank Payment Type field, type C and press ARROW DOWN. 
Notice that the field now displays Computer Check. In option fields, 
you can type in the selection rather than using the drill-down 
function.  

 
REMEMBER: Some option lists may contain words that begin with the same letters 
so always verify your selection before moving on. 
Most fields in Microsoft Navision allow you to type data in rather than looking up to 
tables or drilling-down to menus. If you know the information, feel free to type it 
into the fields directly. If the data does not exist or is incorrect, an error will appear, 
giving you the chance to make another selection from the table or the list. 

 
11. Click PAYMENTS→PRINT CHECK. The Check window appears. 

12. Do not change the filters set on the Gen. Journal Line tab. 

13.  Click the Options tab. 

14. Note that the settings selected in the last print check scenario remain. 
Do not change the following: 

 
Bank Account WWB-OPERATING 
Last Check No. 200 (if other, still do not change) 
One Check per Vendor per 
Document No. 

Yes (checked) 
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15. Click Print. 

16. In the Check − Print dialog window, verify that Microsoft Navision 
is pointing to the correct printer, and click OK.  

 
NOTE: If you do not want to print an actual check for this exercise select the Print to file 
check box on the Check − Print dialog window and click OK. The Print to File window 
will appear. Type a file name and click OK. 

 
17.  A second line now appears in the Payment Journal. This is the bank 

balancing line. 

18. Click POSTING→POST (F11). A message appears asking if you want to 
post the journal lines. Click Yes. 

19. The Payment Journal runs through the posting process and then 
when completed, a message appears indicating that the lines were 
successfully posted. Click OK. 

20. Close the Payment Journal window. 

 
NOTE: It is possible to post a payment to a vendor without applying the payment to an 
invoice. To accomplish this, you would setup the Payment Journal as shown above but 
leave the Applies to Doc. Type and Applies to Doc. No. fields blank. These types of entries 
may then be applied at a later time using functionality in the Vendor Ledger Entries 
window. 
 

Vendor Ledger Entries 
Go to the Vendor card to view the entries made in the last two scenarios. 
 

1. On the Purchase menu, click ORDER PROCESSING→VENDORS. The 
Vendor Card window appears. 

2. Locate Vendor V00010 (AR Day Property Management XYZ). 

3. On the General tab, note that the Balance field is 0. 

4. In the Balance field, press F6 to go to the Vendor Ledger Entries. 
The Vendor Ledger Entries window appears. 

5. There are two entries now: one for the Invoice and one for the 
Payment. The Document Type field displays the type of entry.  

6. Scroll to the right. Notice that the Remaining Amount field is 0 and 
the Open check box is empty for both lines. 

7. Escape back to the Vendor Card. 

8. Find Vendor 10000 (London Postmaster). 
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9. In the Balance field, click F6 to go to the Vendor Ledger Entries. 
The Vendor Ledger Entries window appears.  

10. Scroll to the bottom of the list to view the Invoice and Payment 
entries. 

11. As with vendor V00010, the Remaining Amount field is 0 and the 
Open check box is empty for both lines. 

12. With the record indicator on the Payment Line (Document Type = 
Payment), click ENTRY→APPLIED ENTRIES. The Applied Vendor 
Entries window appears.  

 This window indicates that the payment has been applied to the 
invoice. If the payment had been applied to other entries (invoices 
and/or credit memos) they would also be displayed in this window. 

13. Close the Applied Vendor Entries, Vendor Ledger Entries and 
Vendor Card windows. 
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Test Your Skills − Pay the Automobile Maintenance Expense 
Scenario: In Cronus International, Ltd. you are the accounts payable clerk, 
responsible for paying expenses. You have posted the invoice from Mortimor Car 
Company for routine automobile maintenance services and you now need to pay 
the invoice. You will print (to file) and post the check. 
 
Using Suggest Vendor Payments, use the following data to enter the payment:  
 
Batch Name BANK 
No. (Vendor tab) 44127914 

 
Options tab:  
Last Payment Date 01/31/04 
Posting Date 01/31/04 
Bal. Account Type Bank Account 
Bal. Account No. WWB-OPERATING 
Bank Payment Type Computer Check 

 

All Skill Levels 
Your tasks are as follows: 
 

1. Use the information provided above, and then use the Suggest 
Vendor Payments functionality. 

2. Print the check to a file. 

3. Post the Payment Journal. 

Need a Little Help? 
 

• Go to FINANCIAL MANAGEMENT→PAYABLES→PAYMENT JOURNAL. 
• Fill in the Suggest Vendor Payments using the information above. 
• Go to the Payments button.  

 
HINT: Remember to use the WWB OPERATING bank and print one check per 
vendor per document number. 

 
• Print check to file. 
• Go to the Posting button. 
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General Ledger Adjustments 
You use the General Journal window to post transactions to G/L, bank, customer, 
vendor, fixed assets, and IC (intercompany) partner accounts. In a general 
journal, you enter the relevant information for the transaction, such as the posting 
date, amount and the accounts you want to post to. The information you enter in 
a journal is temporary and can be changed as long as it is in the journal. 
 
After you post a journal, the journal will be empty and the transactions will be 
posted to individual accounts. You can view the results of posting a journal in the 
ledger entry windows and register windows. Posting with a general journal 
always creates entries on G/L accounts. 
 
We will not be defining every field on the General Journal window. For more 
information about the other fields, please use the F1 help. You also need to setup 
a new General Journal batch for this exercise. 

Create a General Journal Adjustment 
Scenario 8: During the closing process for January, you find out from the 
Accounting Manager that the London Postmaster bill was supposed to be 
allocated as follows: 
 

• Postage (8240) = 308.00 
• Office Supplies (8210) = 57.32 

 
You must make an adjustment to the General Ledger. 
 
But first, change the work date to better show functionality. 
 

1. Click TOOLS→WORK DATE. The Work Date window appears.  

2. Type 02/15/04 and press ENTER or click OK. 
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3. On the Financial Management menu, CLICK GENERAL 
LEDGER→GENERAL JOURNALS. The General Journal window appears: 

 

 
 

4. In the Batch Name field, press F6 to open General Journal Batches 
window.  

5. Press F3 to insert a new line. 

6. In the Name field, type GENERAL and then press ENTER. This line 
will move to the end of the list since it sorted alphabetically.  

7. In the Description field, type General Journal. 

8. In the No. Series field, leave GJNL-GEN as the selection. 

9. While on the GENERAL line, click OK and press ENTER. 

10. In the Posting Date field, type 01/31/04. This ensures that the 
adjustment is made in the same period as original entry.  

11. Leave the Document Type field empty. 

12. In the Document No. field, leave the number entered by the 
program. This number was retrieved by the program based on the 
GJNL-GEN No. Series entered for the GENERAL journal batch. 

13. In the Account Type field, press F6 and click G/L Account. 

14. In the Account No. field, press F6 and find the G/L account number 
for Postage: 8240. Click OK and press ENTER. 

15. Note that the Description field was automatically filled in with the 
account name Postage. This is done to help the end user confirm that 
the correct account was selected. You can now type over the 
description with whatever you like, such as a description for why the 
transaction is being made. 
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 In the Description field, type Correction to Document No. 108033. 

16. In the Amount field, type -57.32 to make a credit entry to the 
Postage account. 

 In the general journal, a positive amount represents a debit to the 
account in the Account No. field while a negative amount represents 
a credit to the account. 

17. In the Bal. Account Type field, leave G/L Account as the selection. 

18. In the Bal. Account No. field, press F6, select the Office Supplies 
account number, 8210, and then click OK. Press ENTER. 

19. Clear the Bal. Gen. Posting Type, Bal. Gen. Bus. Posting Group 
and Bal. Gen. Prod. Posting Group fields. These fields should only 
be populated when making a VAT entry. For our scenario, we do not 
need to post VAT entries.  

The journal lines displayed in the batch are balanced when the Total Balance 
field equals 0. You cannot post journals that do not balance. 
 
The journal entry is now complete, and you can post it. When you post a journal 
you can post or post and print a copy of the journal for you records. In this case, 
we will only post the journal. 
 

20. Click POSTING→POST (F11). A message appears asking if you want to 
post the journal lines. Click Yes. 

21. The Journal runs through the posting process and then when 
completed, a message will appear indicating that the lines were 
successfully posted. Click OK. 

22. Close the General Journal window. 

General Journal Registers 
Scenario 9: Now that you have adjusted the General Journal, you should view 
the entries. General Ledger entries are best viewed from the G/L Register. 
 
Each time an entry is posted in Microsoft Navision, a Register is created. For the 
General Journal you posted, a G/L Register is created. 
 
The G/L entries in a G/L register are the result of the following: posting of a 
journal in the General Ledger, Sales, Receivables, Purchases, or Payables 
application areas; posting of sales orders, invoices and credit memos; posting of 
purchase orders, invoices and credit memos; and other areas of Microsoft 
Navision. 
 
You can see the G/L registers for the General Ledger, Sales, Receivables, 
Purchases, and Payables application areas under the History menu item on the 
menu of each application area. 
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Following the Audit Trail 
1. On the Financial Management menu, click GENERAL 

LEDGER→HISTORY→REGISTERS. The G/L Registers window appears. 
Registers contain the information for the Audit Trail in Microsoft 
Navision. 

2. Go to the bottom of the G/L Registers window (CTRL + PAGE DOWN). 

 

 
 

 G/L Register No. 117 is the most recently posted activity, our journal 
entry. The Register No. is generated automatically by Microsoft 
Navision, as are the numbers in the From Entry No., To Entry No., 
From VAT Entry No., and To VAT Entry No.  

3. The Creation Date is not the Posting Date or the Work Date. You 
can see from our entry that the Creation Date is the date on your 
system, not the Work Date of 02/03/04 or the Posting Date of 
01/31/04.  

4. The User ID field would be shown if individual users have been set 
up for the database, which is not the case for this demo database. 

5. The Source Code field identifies the area of Microsoft Navision that 
created the entries. Note that the Source Code on this line is 
GENJNL. Next we will review how this Source Code is assigned. 

6. On the Financial Management menu, click SETUP→TRAIL 
CODES→SOURCE CODES. The Source Codes window appears. In this 
window you can see a listing of Source Codes for Microsoft 
Navision. These codes are provided as defaults in the database; you 
may create others.  
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7. On the Navigation Pane, click TRAIL CODES→SOURCE CODE SETUP. 
The Source Code Setup window appears. In this window, each 
Source Code is linked to a posting option in Microsoft Navision. For 
example, on the General tab, GENJNL is assigned to the General 
Journal and ADJAPPCORR is assigned to Adjust Add. Reporting 
Currency.  

 This is why GENJNL appears as the Source Code in the Register for 
our transaction.  

8. Close the Source Code Setup and Source Codes windows. 

9. On the G/L Register, click on the last line.  

10. The Journal Batch Name has been populated based on the batch we 
were using when we posted the General Journal.  

11. Make a note of the numbers in the From Entry No. and To Entry 
No. fields. We will be checking these against other windows in a 
moment. 

12. While still on line No. 117, click REGISTER→GENERAL LEDGER. The 
General Ledger Entries window appears. The lines that constitute the 
Register No. 117 are displayed in this window.  

13. Compare the Entry No. field on the far right to the number you 
noted in step 11 − they are the same. Microsoft Navision assigns a 
unique, sequential number to each line or entry posted. This allows 
for a complete audit trail.  

14. Close the General Ledger Entries and G/L Registers window. 

15. On the Navigation Pane, click GENERAL LEDGER→CHART OF 
ACCOUNTS. The Chart of Accounts window appears.  

16. Locate the Postage account: 8240 and click ACCOUNT→LEDGER 
ENTRIES. The General Ledger Entries window appears. 

17. Go to the bottom of the General Ledger Entries window (CTRL + 
PAGE DOWN).  

18. In this list, the Entry No. is the last field displayed. With the last line 
selected, click Navigate.  

19. On the G/L Entry line, the No. of Records field indicates that there 
were two G/L lines posted with the Register.  

20. Click on the G/L Entry line and click on Show. The General Ledger 
Entries window appears. The lines posted in the register are 
displayed here. The Entry Numbers can be used to determine to 
which Register an entry belongs.  
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21. Close the General Ledger Entries, Navigate, General Ledger Entries, 
and Chart of Accounts windows. 

22. On the Navigation Pane, under General Ledger click 
REPORTS→ENTRIES→G/L REGISTER. The G/L Register request form 
window appears. 

23. In the No. field, press F6 to open the G/L Registers window. Locate 
the Register No. for the General Journal you posted earlier. (117) 
Click on the line and click OK. 

24. Click Preview. The G/L Register report is displayed. 

 This report shows posted G/L entries sorted and divided by each 
register and can be used as documentation of the posted entries or for 
auditing. 

25. Close the Print Preview window. 
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Test Your Skills − Adjust the Automobile Maintenance 
Expense 

Scenario: In Cronus International, Ltd. you are the Accounting Manager who is 
responsible for G/L adjustments. The Mortimor Car Company bill had a gasoline 
charge on it and you need to reallocate as follows: 
 

• Repairs and Maintenance (8530) = 115.00 
• Gasoline and Motor Oil (8510) = 17.94 

 
Use the following data to enter the adjustment: 
 
Batch Name GENERAL 
Posting Date 01/31/04 
Account Type G/L Account 
Account No. 8530 
Description Correction to Document No. 108029 
Amount -17.94 
Bal. Account Type G/L Account 
Bal. Account No. 8510 
Bal. Gen. Posting Type <blank> 
Bal. Gen. Bus. Posting Group <blank> 
Bal. Gen. Prod. Posting Group <blank> 

 

All Skill Levels 
Your tasks are as follows: 
 

1. Enter the information provided above into the General Journal. 

2. Post the General Journal. 

Need a Little Help? 
 

• Go to FINANCIAL MANAGEMENT→GENERAL LEDGER→GENERAL 
JOURNALS. 

• Fill in the fields using the information above. 
• Go to the Posting button. 
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Quick Interaction: Lessons Learned 
Take a moment to write down three Key Points you have learned from this 
chapter: 
 
1. 

 

 

 

 

 
 
2. 

 

 

 

 

 
 
3. 
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CHAPTER 4: ORDER PROCESSING − SALES AND 
RECEIVABLES 

 
• Overview  
• Processing Overview  
• New Customer Setup  
• Creating a Sales Quote 
• Sales Order Processing 
• Receivables Processing 

 

Overview 
This chapter contains more information on the Order Processing functionality 
within Microsoft® Business Solutions−Navision®. In this chapter, you build upon 
the knowledge you gained in the previous chapter by using Sales Order 
Processing functionality in Microsoft Navision. 
 
This chapter is divided into two sections. In each section, you perform a series of 
scenarios aimed at not only making you more familiar with carrying out business 
processes and finding information, but also with allowing you to have a better 
overall idea of how information is processed within Microsoft Navision. 
 
In the first section, Sales Order Processing, you perform a series of scenarios 
aimed at making you more familiar with the information flow in Microsoft 
Navision. The processes are: 
 

• Creating a Customer 
• Creating a Sales Quote 
• Examining the Sales Order 
• Examining the Posted Sales Invoice History 
• Examining the Customer Card Ledger Entries 
• Examining the Item Ledger Entries 

 
In the second section, Receivables Processing, you review the Accounts 
Receivable Aging report and post a Cash Receipt. 
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Processing Overview 
The following diagram is a visual representation of the process steps performed 
in Sales and Receivables and the impact that the processing will have on other 
application areas. The steps mirror what we did in Chapter 3, with the addition of 
entering a Quote that is converted to an Order. 
 

 
 
Begin by creating a Customer. Next create a Sales Quote, then using 
functionality to convert the Quote to an Order. For the Quote, use the new 
customer and the Item created in Chapter 3 (Paint, sunflower yellow) to make it 
easier to review posted entries after processing.  
 
Next, post a Shipment − the equivalent of the Receipt on the Purchase side. Then, 
post the Invoice from the Order. This updates the Customer card for the 
receivable and update the Chart of Accounts as well. The exact accounts updated 
in the Chart of Accounts depends upon the posting options selected in a 
company; any explanation beyond that is covered in later classes.  
 
Finally, record the payment from the Customer utilizing the Cash Receipt 
functionality in Microsoft Navision. This process updates both the Customer's 
balance and the balance in the Chart of Accounts. 
 
Because this process mirrors the work we have done in Purchases and Payables, 
we will be able to move through the steps more quickly. We will now go to 
Microsoft Navision and create the Customer and then begin processing. 
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New Customer Setup 
Scenario 1: Your other responsibility as the Accounting Clerk for Cronus 
International is to set up new Customers. The customer referred to in the previous 
chapter would like to place an order for the Sunflower Yellow paint.  
 
In this section you create the new customer. You will not be defining every field 
on the Customer card, only those that are necessary for processing and posting 
Sales and Receivable transactions.  
 

NOTE: You can always find more information about fields by using the F1 help or 
clicking on the What's This? button and then clicking in the field in question. 

 

Change the Work Date 
In this database, all postings must happen between November − February. 
 

1. Click TOOLS→WORK DATE. The Work Date window appears. 

2. Type 01/10/04. 

3. Press ENTER or click OK. 

Customer Setup 
On the Sales & Marketing menu, click ORDER PROCESSING→CUSTOMERS. The 
Customer Card window appears: 
 

 
 

1. Press F3, or click the Insert button on the Toolbar, to insert a new 
Customer Card. 

2. In the No. field, press ENTER to automatically assign a number from 
the No. Series. 
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3. In the Name field, type Beef House Outlet. 

4. In the Address field, type 21 Bahnhofstrasse. 

5. In the Post Code field, type DE-27624. 

6. Notice that the City field did not automatically populate with the city 
name as it did in the last chapter. This is because the Post Code field 
will allow you to enter a Post Code that does not have an assigned 
city. In this case, you must manually enter the city name. 

 In the City field, enter Bederkesa. 

7. In the Country Code field, enter DE. 

8. In the Contact field, enter Martin Illum Lotz. 

9. Click on the Invoicing tab. 

10. In the Gen. Bus. Posting Group field, lookup to the Gen. Business 
Posting Groups window. Click on the record indicator on the line for 
EU and click OK and press ENTER. 

11. The VAT Bus. Posting Group field should populate with EU. Do 
not change this as it has defaulted in from the Gen. Business Posting 
Group setup. 

12. In the Customer Posting Group field, lookup to the Customer 
Posting Groups window. Click on the record indicator on the line for 
FOREIGN and click OK. 

13. Click the Payments tab. Here you can set default values for the 
Application Method, Payment Terms, Payment Method, Reminder 
Terms, and Finance Charge Terms. Leave the default Application 
Method of Manual. 

14. In the Payment Terms Code field, lookup to the Payment Terms 
window. Click on the record indicator on the line for 7 DAYS and 
click OK. 

15. Click on the Foreign Trade tab. 

16. In the Currency Code field, lookup to the Currencies window. Click 
on the record indicator on the line for EUR and click OK. 

17. Close the Customer Card window. 

The Customer card setup is complete for this scenario. Now we create a sales 
quote. 
 

HINT: It is not necessary to lookup to all of the windows that we have in this scenario 
to enter information. If it saves time you may enter the information directly into the 
fields. 
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Creating a Sales Quote 
Scenario 2: Now that the Customer has been created, you need to generate a 
Sales Quote for the new paint. Later in this section, a Sales Order will be created 
directly from the Quote. 
 
On the Sales & Marketing menu, click ORDER PROCESSING→QUOTES. The Sales 
Quote window appears: 
 

 
 
Similar to the Purchase Order you created in the previous chapter, the Sales 
Quote is divided into two sections; the header on top and the lines on the bottom. 
The Sales Quote, Order, and Invoice, however, have an additional side panel 
which provides the user with quick access to Customer Information. 
 

1. Press F3 to insert a new Sales Quote. 

2. Press ENTER to automatically assign a No. 

3. In the Sell-to Customer No. field, lookup to the Customer List 
window. Locate the customer you created in the last section: Beef 
House Outlet and press ENTER twice. 

4. Notice that some of the other fields in the header automatically 
populate with information from the Customer card you previously 
created. If changes need to be made for this specific quote, you may 
make them on this form without the changes being saved to the 
Customer card.  

5. Click in the lines section. 
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6. The first field is the Type field. Press F6 to view the options list. 
Since we are quoting an item, select Item from the list. 

7. Press TAB or ENTER to move to the next field. Press F6 to lookup to 
the Item list. Locate the item you created in the previous chapter: 
Paint, sunflower yellow. Press ENTER twice to select this item and 
commit the item number to the field. 

8. In the Location Code field, type Green. Notice in the pane on the 
right side of the quote, the Availability equals 0. This is because 
when the product was ordered, it was assigned to the BLUE 
Location Code. This location code does not need to be specified in 
the quote line unless it is important that the item be shipped from a 
certain location. For this scenario, we will fill in the Location Code 
field − type Blue. The Availability now equals 200. 

 The functionality of the Customer and Item Information areas of the 
Sales Quote, Order and Invoice will be defined in later courses. 

9. In the Quantity field enter 100. 

Now we are ready to convert this quote into an order. In Microsoft Navision, 
quotes can sit idle for a nearly indefinite period of time before being made into 
an order. This is useful when customers need time to review a quote that you sent 
to them. 
 

10. Click Make Order. 

11. A message appears asking if you want to convert the quote to an 
order. Click Yes. 

A notification window pops up telling you the order number that your quote has 
just become. Make note of this number. Press F5 and look for the quote that you 
just converted. You will find that it has gone away. Sales Quotes that are 
converted to orders do not remain in Microsoft Navision, since all the 
information is transferred to the order. Next we look at the order you just created. 
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Sales Order Processing 
Scenario 3: Now that we have turned the Sales Quote into a Sales Order, we will 
look at our order and prepare it for posting. To save shipping charges, the 
Customer has asked that you break the order into two shipments but only invoice 
for the entire order. 

Process the Sales Order 
On the Sales & Marketing menu, click ORDER PROCESSING→ORDERS. The Sales 
Order window appears: 
 

 
 

1. In the No. field, press F5 to lookup to the Sales Order List window 
and find the order you have just created. 

Notice how the header information has been transferred from the quote. This 
information can be edited for just this order here, without it being saved to the 
Customer card. 
 

2. Notice the Document Date field in the header. Combined with the 
Payment Terms that you defined earlier for this customer, the due 
date is determined. The due date and payment terms can be seen by 
clicking on the Payments tab. 

3. In the lines, scroll to the right to the Qty. to Ship and Qty. to 
Invoice fields. These fields have the same functionality as the Qty. 
to Receive and Qty. to Invoice fields on the Purchase Order, only 
for partial Shipments rather than Receipts. 

Now we will partially ship this order. We will send half the order, and not 
invoice for any of the product until the second half of the product is shipped. 
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4. Change the Qty. to Ship value to 50. 

5. Clear the Qty. to Invoice field. 

6. Click ORDER→STATISTICS. The Sales Order Statistics window 
appears.  

 
HINT: Order statistics can be seen at any time from the Order card by pressing F9. 

 
7. The General tab has numbers that correlate to the end result of the 

transaction, while the Invoicing and Shipping tabs only contain 
information pertaining to the numbers contained in the Qty. to 
Invoice and Qty. to Ship fields. 

8. Close the Sales Order Statistics window. 

9. Click POSTING→POST (F11). The Posting dialogue window appears.  

10. Since we have chosen not to invoice at this time, select Ship and 
click OK. 

11. Click ORDER→SHIPMENTS. The Posted Sales Shipment window 
appears. Here we can see the shipment that has been made for this 
order. More information can be obtained by clicking 
SHIPMENT→CARD.  

12. Close the Shipment Card and Posted Sales Shipments window. 

Now we will completely ship and invoice the Sales Order. Notice that the Qty. to 
Ship and Qty. to Invoice fields automatically populated with the values that 
remain after you posted the first shipment. This eliminates the data entry that we 
would have to do. 
 

13. Post the Sales Order by pressing F11. 

14. Select Ship and Invoice and click OK. 

Now that you have completely shipped and invoiced the order, you will notice 
that it has disappeared and you are looking at a different Sales Order. Again, 
when Orders and Invoices are posted in Microsoft Navision they become posted 
documents.  
 

15. Close the Sales Order window. 

On the Sales & Marketing menu click HISTORY→POSTED INVOICES. The Posted 
Sales Invoice window appears. 
 
Press F5 to view the Posted Sales Invoice list. Find the posted sales invoice that 
corresponds to the order you just posted. Notice that all the original information 
for the sales order is here for review. Next we look at some other places you can 
see the results of posting a sales order.  
 
Close the Posted Sales Invoice window. 
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Customer Ledger Entries 
When ledger entries are accessed from a customer card, Microsoft Navision 
automatically filters on the entries that pertain to that customer. This is a very 
convenient way of seeing all the entries that pertain to the customer. 
 

1. On the Sales & Marketing menu click ORDER 
PROCESSING→CUSTOMERS. The Customer Card window appears. 

2. Locate the Customer card for Beef House Outlet and click 
CUSTOMER→LEDGER ENTRIES. The Customer Ledger Entries window 
appears. 

Notice that the entire amount of the Invoice appears in the Original Amount, 
Amount and Remaining Amount fields. Once a full payment has been posted 
and applied, the Remaining Amount will be 0.  
 
Scroll to the right and click in the Due Date field. At first it appears that this field 
is non-editable but if you press F2, you will see that you can edit this field. 
Microsoft Navision allows Due Dates, Discount Dates and Discount Amounts to 
be edited. Do not change the Due Date.  
 

3. Close the Customer Ledger Entries and Customer Card windows. 

 
HINT: From any card in Microsoft Navision the associated ledger entries can also be 
seen by pressing CTRL + F5. 

 

Item Ledger Entries and Value Entries 
Another way that Microsoft Navision keeps track of the transaction that was 
made is in the Item Ledger entries. This information is seen according to what 
items were purchased, as opposed to which customer the purchase was made by. 
 

1. From the Sales & Marketing menu, click INVENTORY & 
PRICING→ITEMS. The Item Card window appears. 

2. Press F5 or click the List button to display the Item List. Locate Item 
Paint, sunflower yellow and click on the line and press ENTER or 
click on OK. 

3. Press CTRL + F5 to open the Item Ledger Entries window. 

 There are now four entries in this window: two purchase entries and 
two sales entries (see the Document Type field). Note that the 
Remaining Quantity field for the first three lines is 0 while the last 
line is 100. Because we shipped and invoiced 100, there are only 100 
left in inventory. You may also notice that the Sales Amount 
(Actual) fields are populated with the sales value for the Sales 
entries.  
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4. Click on the first Sales entry and click ENTRY→VALUE ENTRIES. The 
Value Entries window appears. 

 There are two Value Entry lines: one for the Shipment and one for 
the Invoice. The two lines can be distinguished by looking at the 
Item Ledger Entry Quantity and Invoiced Quantity fields. The 
Shipment line will have a value in the Item Ledger Entry Quantity 
field but not in the Invoiced Quantity field. The Invoice line will be 
the opposite; the Invoiced Quantity field will have a quantity while 
the Item Ledger Entry Quantity field will be 0. In addition, the 
lines will have different document numbers. 

5. Escape back to the Item Ledger Entries window. 

6. Click on the next Sales entry line and click ENTRY→VALUE ENTRIES.  

 This Value Entry only displays a single line, with quantities in both 
the Item Ledger Entry Quantity and Invoiced Quantity fields. 
These fields are both populated because you posted the Shipment 
and Invoice simultaneously (using the Ship and Invoice posting 
option) during the final posting of the Sales Order. You will learn 
more about Item Ledger Entries and Value Entries in later courses. 

7. Close the Value Entries, Item Ledger Entries, and Item Card 
windows. 



 

 

Chapter 4: Order Processing − Sales and Receivables 

Page 107 

Test Your Skills − Create a Sales Order 
Scenario: In Cronus International, Ltd. you are the clerk responsible for filling 
new orders. You have received another order from Beef House Outlet for 10 
bicycle tires and you now need to create the order. Post the order. 
 
Create a new sales order for Beef House Outlet, and use the following data:  
 
Posting Date 01/31/04 
Type Item 
No. 1160 
Quantity 10 
Unit Price 41 
Qty. to Ship 10 
Qty. to Invoice 10 

 

All Skill Levels 
Your tasks are as follows: 
 

1. Use the information provided above, and then post the sales order. 
Use the Ship and Invoice option to post. 

2. Find the results of your transaction in the Item Ledger Entries and 
the Customer Card Ledger Entries. 

Need a Little Help? 
 

• Go to SALES & MARKETING→ORDER PROCESSING→ORDERS. 
• Fill in the Sales Header by looking up and finding the Customer No. 

for Beef House Outlet. The rest of the information will come in 
accordingly. 

• Fill in the Sales Lines using the data above. 
• Find the Item Ledger Entries by clicking on INVENTORY & 

PRICING→ITEMS. Find the item named Tire and then from its item 
card press CTRL + F5 to see the ledger entries. 

• On the Customer Card for Beef House Outlet, press CTRL + F5 to see 
the ledger entries. 
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Receivables Processing 
In this section you will run the Aged Accounts Receivables report, post a cash 
receipt, and apply the cash receipt. We will not be defining every field on the 
report request form or the Cash Receipts window. For more information about 
the other fields, please use the F1 help. 

Running the Aged Accounts Receivables Report  
Scenario 4: As the Accounting Clerk for Cronus International, you are also 
responsible for running the Aged Accounts Receivable report to make collection 
calls on past due customer accounts. Run the report for the Beef House Outlet, 
aged as of 01/31/04. 
 

1. On the Financial Management menu, click 
RECEIVABLES→REPORTS→AGED ACCOUNTS RECEIVABLE. The Aged 
Accounts Receivable window appears. 

2. On the Customer tab, define various filters to sort the data you 
would like to view. For this scenario, we want to view only the 
information regarding the customer we have created. On the No. line, 
lookup to the Customer list and find the customer Beef House Outlet. 

3. Click the Options tab. Here you define various other parameters by 
which you would like to view the data.  

 

 

 
4. In the Aged As Of field, type w for the work date. 

5. In the Aging by field, leave the Due Date selection. 
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6. In the Period Length field, type 30D. This means that the report will 
be broken into 30 day periods. All other fields can be left with their 
default values. 

7. Click Preview. 

Take a few minutes to try different options within this report for the customer. 
 
As you have seen, the full integration of receivables functionality within 
Microsoft Navision makes it easy to access the data that was created as a result of 
our transactions. Next you will post the cash receipt for this order. 

Cash Receipt Posting 
Scenario 5: The Beef House Outlet has sent you a check for the paint. As the 
Accounting Clerk, your next assignment is to post the receipt of payment. The 
check number is 44695.  
 

1. For this scenario, the Work Date should be set to 02/15/04. 

2. On the Financial Management menu, click RECEIVABLES→CASH 
RECEIPT JOURNALS. The Cash Receipt Journal window appears: 

 

 
 

3. Make sure that the Batch Name field reads BANK. If it does not, 
lookup to the General Journal Batches window and select it. 

4. In the Posting Date field, type w for the Work Date (2/15/04). 

5. In the Document Type field, choose Payment. 

6. Click VIEW→SHOW COLUMN. Select the External Document No. 
field.  

7. In the Account Type field, choose Customer. 
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8. In the Account No. window, lookup to the Customer List and find 
the record for Beef House Outlet. Select the record and click OK. 

9. In the Applies-to Doc. Type field, choose Invoice. 

 
Now choose which Invoice to apply this payment.  
 

10. In the Applies-to Doc. No. field, lookup to the Apply Customer 
Entries window. 

Notice that the only invoices that appear are those that meet the criteria you 
already set in the Journal line. Microsoft Navision uses the information in the 
Account Type, Account No., and Applies-to Doc. Type fields to filter the 
information down to only records that are pertinent. 
 

11. Select the invoice with a Remaining Amount of 418.10 and click 
OK. 

Notice how the Amount field automatically populates with the full invoice 
amount. 
 

12. Press F11 to post the Journal Line. 

13. A message appears asking if you want to post the journal line. Click 
Yes. 

Customer Ledger Entries 
Go to the Customer card to view the entries made in the last scenario.  
 

NOTE: These results are based on the understanding that you created the Sales Order 
in the Test Your Skills activity. 

 
1. On the Sales & Marketing menu, click ORDER 

PROCESSING→CUSTOMERS. The Customer Card window appears. 

2. Locate the Beef House Outlet Customer. 

3. On the General tab, note that the Balance (LCY) field is 264.78. 
The Balance (LCY) field displays amounts in local currency. Since 
we have an open invoice, this is the balance in our local currency. 
You will see in a moment that the Open invoice is in the amount of 
410.00 (EUR). Cronus International's currency is (GBP). 

4. In the Balance field, press F6 to go to the Customer Ledger Entries. 
The Customer Ledger Entries window appears. 

5. There are three entries now: two Invoices and one for the Payment 
received. The Document Type field displays the type of entry.  
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6. Scroll to the right. Notice that the Remaining Amount field is 0 and 
the Open check box is empty for the lines applied in the last 
scenario.  

7. With the record indicator on the Payment Line (Document Type = 
Payment), click ENTRY→APPLIED ENTRIES. The Applied Customer 
Entries window appears.  

 This window indicates that the payment has been applied to the 
invoice. If the payment had been applied to other entries (invoices 
and/or credit memos) they would also be displayed in this window. 

8. Close the Applied Customer Entries, Customer Ledger Entries, and 
Customer Card windows. 
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Test Your Skills − Post a Cash Receipt  
Scenario: In Cronus International, Ltd. You are the clerk responsible for posting 
received payments. You have received another payment from Beef House Outlet 
for the remaining balance on an invoice and you now need to post the payment. 
 
Create a new cash receipt journal line for Beef House Outlet, and use the 
following data:  
 
Posting Date 2/25/04 
Document Type Payment 
External Document No. 44703 
Account Type Customer 
Customer  Beef House Outlet 
Amount 410.00 (EUR) 
Balance Account Type Bank Account 
Balance Account No. WWB-OPERATING 
Applies to Document Type Invoice 

 

All Skill Levels 
Your tasks are as follows: 
 

1. Use the information provided above, and then post the cash receipt. 
The payment is for the remaining balance of the sales order for 
yellow sunflower colored paint. 

2. Post the journal line. 

Need a Little Help? 
 

• Go to FINANCIAL MANAGEMENT→CASH RECEIPT JOURNALS. 
• Fill in the Journal Line by looking up and finding the Customer No. 

for Beef House Outlet. Then use the data above to fill in the rest of 
the information. 

• Post the Journal Line (Remember: F11). 
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Quick Interaction: Lessons Learned 
Take a moment to write down three Key Points you have learned from this 
chapter: 
 
1. 

 

 

 

 

 
 
2. 

 

 

 

 

 
 
3. 
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CHAPTER 5: FINANCE − REPORTING 
 

• Overview 
• Chart of Accounts 
• Standard Reports 
• Account Schedules 
• Analysis View 
• Analysis by Dimensions 
• Business Analytics 

 

Overview 
This chapter contains an overview of the Microsoft® Business 
Solutions−Navision® reporting functionality available. 
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 Reporting 
In this section, you obtain an overview of finance reports: chart of accounts, 
standard reports, account schedules, analyses by dimensions and business 
analytics. More detailed information on the financial reporting features in the 
program can be found in the Financial Series II training material. 
 
As entries are posted and amounts are accumulated in the General Ledger 
application area, the challenge is to examine and manage the information 
contained there. 
 
There are several ways to prepare analyses of G/L accounts (based on posted G/L 
entries): 
 

• You can do simple calculations in the Chart of Accounts by using 
Field Filters and/or FlowFilters.  

• You can use the standard reports in the program. 
• You can create more complex statements and calculations using 

Account Schedules to communicate the information. 
• You can also use Analyses by Dimensions based on an Analysis 

View. 
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Chart of Accounts 
You can filter the accounts and amounts displayed in the Chart of Accounts 
window using field filters, table filters and flow filters. Field and table filters on 
any field in the G/L Account table can be used to filter the accounts that are 
shown in the Chart of Accounts window.  
 
The amounts for each account are determined by summing the G/L Entries for 
the account. The calculated amounts are shown in the fields in the Chart of 
Accounts window.  
 
From the Financial Management menu, click GENERAL LEDGER→CHART OF 
ACCOUNTS. The Chart of Accounts window appears: 
 

 
 
By applying a flow filter, you can determine the ledger entries that are summed 
for the G/L accounts. 
 
To make the process of applying flow filters to the chart of accounts simpler, 
some standard analysis windows are available. All these analyses windows can 
be found on the Balance button in the Chart of Accounts window. The windows 
are: 
 
Name Description 
G/L Account Balance You use this window to view a scrollable 

summary of the debit and credit balances 
for different time periods, for the account 
you select in the chart of accounts. 

G/L Balance You use this window to view a scrollable 
summary of the debit and credit balances 
for all the accounts in the chart of accounts, 
for the time period you select. 
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Name Description 
G/L Balance by Dimension You use this window to view a scrollable 

summary of the balances for all the accounts 
in the chart of accounts. By using the Show as 
Line and Show as Column fields, you can 
define how the list of balances is presented in 
the matrix window. You can select from: 
Global Dimensions, Business Unit, Period or 
G/L Account. 

G/L Account Balance/Budget This window shows a summary of the debit 
and credit balances, and of the budgeted 
amounts for different time periods, for the 
account that you select in the chart of 
accounts. 

G/L Balance/Budget For each account in the chart of accounts, this 
window shows a scrollable summary of the 
debit and credit balances and of the budgeted 
amounts, for the time period that you select. 

Chart of Accounts Overview You use this window to display the Chart of 
Accounts with different levels of detail. You 
can click on a triangle in the Expand field (or 
select a line and press shift + ctrl + a) to 
expand or collapse a section of the chart of 
accounts. This allows you to choose whether 
you want to see only header and footer 
accounts, or all of the accounts in between as 
well. 

 

Standard Reports 
The program contains a number of standard printed reports. These can be found 
under the Reports menu item in each application area. Standard reports in the 
General Ledger application area include: 
 

• Trial Balance reports 
• Ledger reconciliation reports 
• Dimension reports 
• Consolidation reports 
• Account Schedules 
• Budgets 
• VAT reports 
• Intrastat reports 
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You can set filtering or options for each report using the request form for the 
report.  
 
Once you have selected a report from the reports menu, a request form will be 
displayed. The request form allows you to enter the parameters that you want the 
report to use when it runs. The report we will look at was selected because it 
contains all of the different parameters that you might encounter on a request 
form. Request forms are also used to set the parameters on imports and batch 
jobs.  
 
On the Financial Management menu, click GENERAL LEDGER→REPORTS→ 
FINANCIAL STATEMENT→BUDGET. The Budget report request form appears: 
 

 
 
In Microsoft Navision, reports can be run for many different ranges. Filters allow 
you to set the report specifications so that it only prionts the information you 
need. On the Budget report, you could select a particular G/L Account or for a 
range of Accounts, a range of entry dates or date periods, or dimension values. 
There is a different tab for filters that can be set for each table that is used during 
a report. Most reports in Microsoft Navision also contain an Options tab 
including additional options.  

Account Schedules 
Account schedules are intended for calculations that cannot be done directly in 
the chart of accounts. You can create as many Account Schedules as you like, 
each with a unique name. You can set up various report layouts and print the 
reports with the current figures whenever necessary. You use account schedules 
to analyze figures in G/L accounts or to compare G/L entries with G/L budget 
entries. For example, you can view the G/L entries as percentages of the budget 
entries.  
 
Account schedules can be used to make both simple and complex customized 
financial statements and management reports. By utilizing the analytical 
capabilities of the company dimensions features, you can analyze your G/L 
accounts in even greater detail.  



 

 

Microsoft Navision Introduction 

Page 120 

It is also possible to export your Account Schedules to Microsoft® Excel®. This 
allows other parties to use a copy of your data without requiring direct access to 
the program.  
 

NOTE: Microsoft Navision does not come with any financial statements and you must 
therefore create financial statements in account schedules. However, the demonstration 
company does come with some example account schedules, such as the ′acid test′ 
analysis. 

 
From the Financial Management menu, click GENERAL LEDGER→ANALYSIS & 
REPORTING→ACCOUNT SCHEDULES. The Account Schedule window appears: 
 

 
 
The Account Schedule window is used to create the report lines based on your 
G/L information. In addition to defining which G/L accounts to include in the 
report, you can also use formulas to perform calculations based on other rows in 
the account schedule. Click on FUNCTIONS→SET UP COLUMN LAYOUTS to display 
the Column Layout window. Here you can define criteria that relate to the 
amount that will be shown in each column. This can be the time period the 
amount relates to, whether you wish to see the balance or net change and whether 
the amount is an actual or budgeted amount. This means you can create reports 
such as: 
 

• Monthly and Year to Date comparisons of actual balances to 
budgeted balances for selected G/L accounts. 

• Comparisons of current year balances to prior year balances for 
selected G/L accounts. 

 
By separating the layout of rows and columns, you can easily create different 
reports by combining the same row layout with different column layouts. So if 
you have an Income Statement account schedule and two column layouts, one 
that shows department and another that shows months you can print the Income 
Statement and select if you want to show it per department or per month. Instead 
of having to create two complete reports, you only need to create one row layout 
and two different column layouts. 
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From the Account Schedule window, click in the Name field. The Account 
Schedule Names window appears. You use the Account Schedule Names 
window to set up a default column layout for a particular account schedule, as 
well as an Analysis View. An Analysis View allows you to filter your account 
schedule by specific dimensions. If an Analysis View is not chosen, the account 
schedule can be filtered by the Global Dimensions. Analysis View is discussed in 
more depth in the next section. 
 
If you wish to view the Account schedule without printing it, from the Account 
Schedule window, click ACC. SCHED.→OVERVIEW. The Acc. Schedule Overview 
window appears: 
 

 
 
The printed report has a limit of six visible columns, while you can view as many 
columns as you want in the Acc. Schedule Overview matrix. 

Analysis View 
As shown in the previous section, Account Schedule analysis capabilities are 
primarily based on the G/L Accounts and their structure in the Chart of Accounts.  
 
The analysis view is a means of viewing data from the general ledger for 
particular output needs based on criteria specified within your business. For an 
analysis view, G/L entries are grouped by criteria such as G/L accounts, Period, 
and up to four dimensions. In other words, if a G/L entry has been posted to a 
particular account with one of the four dimensions selected for an analysis view, 
this G/L entry information will be included in the analysis view as an analysis 
view entry. You can be highly specific about the dimension information you 
want to include in an analysis view by using the Analysis View Filter. 
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The data structure of the Analysis View is represented in the diagram below: 
 

 
 
You can also include G/L budget entries in an analysis view so that actual figures 
can be compared with expectations. 
 
The analysis view can be continually updated with new G/L entries in the 
following ways: 
 

• Using the Update button on a specific Analysis View Card. 
• Using the Update Analysis Views batch job under Periodic 

Activities. 
• Placing a checkmark in the Update on Posting field on the analysis 

view card. It should be noted that the automatic updating of an 
analysis view each time a G/L entry is posted might become a 
performance issue. 

 
Budget entries included in an analysis view can only be updated using the first 
two methods. 
 
The analysis view can be presented in the Analysis by Dimensions window. Note 
that you can filter on the amounts shown, manipulate the presentation of 
amounts, and compare actual amounts with budgeted amounts. 
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Analysis by Dimensions 
In the Analysis by Dimensions window, you analyze activities using dimensions 
information.  
 
By selecting dimensions on each axis in the matrix window, you can analyze 
entries from various perspectives. You can filter entries in the window to create a 
highly specific picture of your company's activities and you can drill-down to the 
exact G/L entries that have contributed to the view you are seeing. 
 
To view an example of dimension analysis, on the Financial Management menu, 
click GENERAL LEDGER→ANALYSIS & REPORTING→ANALYSIS BY DIMENSIONS. The 
Analysis by Dimensions window appears: 
 

 
 
You can easily create a library of views for the reports you use in your company, 
and manipulate and scrutinize analysis views to investigate possible trends that 
can affect the way that you do business. It is not possible to print an analysis 
view directly from the Analysis by Dimensions window. However, you can print 
dimensions information by combining analysis view entries with Account 
Schedule Column Layouts in the Dimensions − Total and Dimensions − Detail 
reports. 
 
Similar to account schedules, you can also export an analysis view to Excel. 
Excel's chart functions can also be used to display your analysis view 
graphically. 
 
Microsoft Navision exports the information to a text file, open the text file in 
Excel and create a pivot table based on the information in the text file. 
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The Excel Workbook 
The workbook in Excel contains three sheets: 
 

• Data Sheet − This sheet contains the data that the pivot table is 
based on. It includes all the Analysis View entries and Analysis 
View Budget entries that were used to create the Analysis by 
Dimensions you exported. It also includes G/L account numbers, 
dimension values and periods that have no posted entries. 

• General Information Sheet − This sheet contains information in the 
Analysis View Card and the Analysis by Dimensions windows at the 
time the export was performed. 

• Pivot Table Sheet − This sheet contains the pivot table that is 
created using the information in the data sheet. 

 

Business Analytics 
Business Analytics is a decision support and analysis tool that provides users 
with a range of visibility (detailed to aggregated) into different aspects of their 
business. It allows users to quickly get to the information they are looking for at 
the desired level of detail.  

Business Analytics & Microsoft Navision 
The base Microsoft Navision solution Business Analytics tool collects data from 
multiple domains within Microsoft Navision, arranges them in a hierarchical 
form, and lends itself to the users for analysis purposes through a client. The 
client chosen for the base solution is Excel, although it should be noted that a 
variety of other clients are available. Through the client, users can roll-up or 
drill-down at the desired level of detail for easy data analysis. For example, users 
can see the total sales across all products, and then drill-down to the sales at the 
product family level, or to a detailed product level. As most of the analysts use 
Excel today for data analysis purposes, Microsoft Navision uses it as the client 
for the base solution. It serves as a good 2-dimensional client to represent data, 
with capability to not only represent data, but to also allow users to manipulate it 
using their own formulas.  

The Business Analytics Configurator 
The configurator interface for Business Analytics allows you to specify the 
different data measures that you want to analyze, and the dimensional hierarchies 
across which you want to analyze the value of the measures. Using the 
configurator interface, you select the tables from where you want to get data for 
the dimensions and the measures. For each table, the program presents a list of 
fields from which you can select measures and dimension. At any time during the 
selection, you can save your work. Similarly, you can open an existing 
configuration definition and edit it. You save the definition of a configuration in 
an XML file.  
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Once you have defined a configuration, you can run the configurator to create 
cubes. The configuration utility invokes the configuration engine. The 
configuration engine performs several activities. It creates the schema for the 
staging database, the data mart, and the OLAP cubes. Additionally, it also 
configures DTS packages for transfer of measure and dimension data to the 
datamart. 

Business Analytics Cubes 
Cubes are the main objects in online analytic processing (OLAP), a technology 
that provides fast access to data in a data warehouse. A cube is a set of data that 
is usually constructed from a subset of a data warehouse and is organized and 
summarized into a multidimensional structure defined by a set of dimensions and 
measures. 
 
You use a client application (such as Microsoft Excel) to connect to an Analysis 
server and query the cubes on the server. An Analysis server can support many 
different cubes, such as a cube for sales, a cube for inventory, a cube for 
customers, and so on. 
 
Every cube has a schema, which is the set of joined tables in the data warehouse 
from which the cube draws its source data. The central table in the schema is the 
fact table, the source of the cube's measures. The other tables are dimension 
tables, the sources of the cube's dimensions.  
 
A cube is defined by the measures and dimensions that it contains. For example, 
a cube for sales analysis includes the measures Item Sale Price and Item Cost and 
the dimensions Store Location, Product Line, and Fiscal Year. This cube enables 
you to separate Item Sale Price and Item Cost into various categories by Store 
Location, Product Line, and Fiscal Year. 
 
Each cube dimension can contain a hierarchy of levels to specify the categorical 
breakdown available to you. For example, the Store Location dimension includes 
the level hierarchy: Continent, Country, Region, State/Province, City, Store 
Number. Each level in a dimension is of finer granularity than its parent. For 
example, continents contain countries, and states/provinces contain cities. 
Similarly, the hierarchy of the Fiscal Year dimension includes the levels Year, 
Quarter, Month, and Day. 
 
Dimension levels are a powerful data modeling tool because they allow you to 
ask questions at a high level and then expand a dimension hierarchy to reveal 
more detail. For example, you start by asking to see Item Cost values of products 
for the past three fiscal years. You may notice that 1998 Item Cost values are 
higher than those in other years. Expanding the Fiscal Year dimension to the 
Month level, you see that Item Cost values were especially high in the months 
January and August. You can drill down on the Store Location dimension to see 
if a particular region contributed significantly to the high Item Cost values, or 
you can expand into the Product Line dimension to see if Item Cost values were 
high for a particular product group or product.  
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Test Your Knowledge − Finance − Reporting 
1. What are the various ways to prepare analyses of G/L Accounts? 

 

2. Where are Standard Reports located in Microsoft Navision? 

 

3. What purpose do Account Schedules serve? 

 

4. How can dimension information be reproduced in Excel? 

 

5. What is Business Analytics? Why would a company want to use it? 
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Quick Interaction: Lessons Learned 
Take a moment to write down three Key Points you have learned from this 
chapter: 
 
1. 

 

 

 

 

 
 
2. 

 

 

 

 

 
 
3. 
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CHAPTER 6: MANUFACTURING 
 

• Overview 
• Items and the Item Card 
• Production Bill of Material 
• Routing 
• Standard Cost Roll Up 
• Planning 
• Production Order 
• Consumption and Output Journals 

 

Overview 
Manufacturing in Microsoft® Business Solutions−Navision® is a key element that 
is used by just about all of the organizations that would employ Microsoft 
Navision software. Manufacturing is how the company plans for and then 
executes the plan to produce or acquire product, or in some cases, resources that 
are the core of that company's business. Basically, a company will make or buy 
the things that they will sell, using Microsoft Navision to organize, plan, guide 
and track the activities. 
 
This involves the definition of a product found in item numbers, bills of material 
(the listing of all parts, purchased and produced, that are required to make an 
item) and routings (manufacturing process steps and instructions). A company 
will establish inventory or raw materials needed to produce the end items (what 
they sell). They have to assign costs to their inventory so that they can determine 
how to price their end products so that they will make a profit by their sale, and 
be able to monitor the value of their remaining inventories. 
 
Based on the demand for their products, a company will use the system to plan 
what inventory and how much will be needed to meet that demand. Then they 
release production orders to the manufacturing facility to produce the products 
for sale. 
 



 

 

Microsoft Navision Introduction 

Page 130 

In this chapter, we focus on the main elements of the following: 
 

• Creating Items and the Item Card.  
• Creating a Production Bill of Material 
• Creating a Routing. 
• Rolling up standard costs to the parent item number. 
• Planning worksheets and material requirements planning. 
• Creating a Released Production Order. 
• Pulling material and recording finished product with Consumption 

and Output Journals. 
• Reviewing the results of the Production Order activity. 

 
More detailed information can be found in the Microsoft Business Solutions 
Manufacturing manual.  
 
First we create an Item by completing the Item Card. We then create a 
Production Bill of Material and a Routing for the new Item. Next we roll up the 
costs to determine the cost of the parent item. 
 
Then we will walk through a scenario where a sales order triggers a demand for a 
product. We set up the appropriate planning and create a production order to 
make the product. Finally, we gather material and charge labor to the production 
order, and then finish the order so that the product is in inventory, ready for 
shipment. 
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Items and the Item Card 
The Item (or part number) Card is the basic building block of the system. We 
buy, make, stock and sell items. Item cards hold the master data required to buy, 
store, produce, account for, track, sell and ship items. 
 
On the Manufacturing menu, click PRODUCT DESIGN→ITEMS. The Item Card 
window appears: 
 

 
 
The Item Card has eight tabs used to describe various attributes of the item or 
part number. The tabs are labeled: General, Invoicing, Replenishment, Planning, 
Foreign Trade, Tracking, E-Commerce and Warehouse.  
 
In this section we create a new Item. We will not define or use all the fields on 
the Item Card, only those that are necessary for processing the scenarios and 
exercises in this chapter.  
 
NOTE: You can always find more information about fields by using the F1 help or 
clicking on the What's This? button and then clicking in the field in question. 
 

The General Tab 
1. Press F3 to insert a new Item card. 

2. In the No field, enter 100-500. 

3. In the Description field, enter Brand New Item. 

4. In the Base Unit of Measure field, click the AssistButton to access 
the Item Units of Measure window. In the Code field, click the 
AssistButton and select PCS. Click OK in both windows to return to 
the Item Card. 
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5. In the Item Category Code field, click the AssistButton and select 
MISC. You can specify a product group from which assigned default 
values will be created for the item, including posting groups (see 
Posting Group fields below).  

On the General tab, the only fields that need to be filled in are the item number, 
description and unit of measure. Using the Item Category Code will default 
values on later screens that make this process easier. 
 
Most of the fields on the right-hand side of the tab provide lookups to detailed 
information about the item's inventory level and its current supply and demand 
situation.  
 
Click the Invoicing tab. 

The Invoicing Tab 
1. In the Costing Method field, you must select the costing method 

that will determine how the program calculates the unit cost of the 
item and the cost of outbound items. Standard is typically used for 
manufacturing items. Standard was defaulted in by our selection of 
MISC as the Item Category Code on the previous tab. 

2. The Average Cost (LCY) field is filled by the program.  

3. Since we have chosen the Standard costing method, we must fill in 
the Standard Cost field with an appropriate value for the cost of one 
unit of the item. Enter 25.50 and press ENTER. A warning message 
will appear asking if you want to change the Standard Cost. Click on 
the Yes button.  

4. The Unit Cost field initializes order lines and journal lines as they 
are created. For items using Standard costing method, this field 
contains the standard cost.  

 For costing methods other than Standard, the Unit Cost field should 
be filled in with an appropriate value. When the Adjust Cost − Item 
Entries batch job is run, the program updates the field so it contains 
the most recent adjusted average unit cost.  

5. In the Unit Price field, enter 80.00. This is the sales price of one unit 
of the item.  

6. The program updates the Last Direct Cost field whenever a 
purchase is invoiced. 

7. The Posting Group fields must be filled in to be able to post 
transactions with the item. These three fields were defaulted in from 
our selection of the Item Category Code.  

 Please note that Posting Groups are a central element in the 
accounting process within Microsoft Navision.  

 
Click the Replenishment tab. 
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The Replenishment Tab 
1. In the Replenishment System field, click the AssistButton and 

select Prod. Order. Here indicate whether your standard way of 
supplying the item is by buying it (Purchase) or by producing it 
(Prod. Order).  

2. In the Manufacturing Policy field, leave Make-To-Stock. 

3. In the Routing No. field you can click the AssistButton and select a 
routing to govern the item's manufacturing process.  
 
A specific routing must be set up and certified before it can be used 
for an item card. For now, leave this field blank. 

4. In the Production BOM No. you can field click the AssistButton 
and select a production BOM to govern the product structure of the 
item. A specific production BOM must be set up and certified before 
it can be used for an item card. For now, leave this field blank. 

5. In the Flushing Method field, select Manual. Here indicate whether 
consumption of this item in production should be calculated and 
posted manually; Manual, or automatically with either of the 
following two methods: Forward, to have the program automatically 
calculate and post consumption when the production order is 
released, or Backward, to have the program automatically calculate 
and post consumption when the released production order is finished. 
To see all of the Flushing Methods available and there definitions, 
click on the Help Button, and then in the field, Flushing Method. 

Click the Planning tab. 

The Planning Tab 
1. In the Reordering Policy field, select Lot-for-Lot. This is the 

common approach in a material requirements planning (MRP) 
environment. The other options are more applicable with other 
inventory planning and management techniques. 

2. In the Include Inventory box, click in the check box. This tells the 
planning process to consider on hand inventory of this item during 
the planning process.  

The remaining four tabs on the Item Card are Foreign Trade, Item Tracking, E-
Commerce and Warehouse. Each tab further defines the item for those specific 
purposes. 
 
The Item Card setup is complete. We now have a new item number that can be 
used throughout the system.  
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Production Bill of Material 
The production process could be viewed as a recipe for manufacturing 
companies: the Production Bill of Material (BOM) is the list of ingredients, the 
Routing tells us what to do with the ingredients to get a finished product, and the 
finished product is stored and sold as Inventory. 
 
Elsewhere in the manual, we see that production orders keep a queue of what we 
plan to make and tell us what to work on next. The planning functions tell us 
what to make or buy and when we need to make or buy those items. 
 
The production bill of material (BOM) shows the items used to make the parent 
item. The end result of a production BOM could be a subassembly (used in 
another item) or a finished good (an item ready for sale). It is possible for an item 
to be both a subassembly and a finished good, for example, if a part is sometimes 
sold as a spare part of another item. The items listed on the production BOM are 
components.  
 
The production BOM is used when production orders are created and is used by 
the Planning Worksheet to show what needs to be made or purchased. 
 
The structure of the production BOM defines the number of levels, or how many 
levels deep the item is. A production BOM can consist of multiple levels − the 
maximum being 50 levels deep.  
 
Once the production order is certified, changes to the components are often made 
by creating a new version of the production BOM rather than changing the 
original production BOM.  
 
On the Manufacturing menu, click PRODUCT DESIGN→PRODUCTION BOM. The 
Production BOM window appears: 
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Production BOM Header 
1. In the header, press F3 to insert a new Production BOM. 

2. In the No. field, enter 100-500. This is the number of the production 
BOM (for example, the same as the parent item).  

3. In the Description field, enter Brand New Item. This is the name of 
the production BOM (for example, the same as the parent item).  

4. In the Unit of Measure Code field, click the AssistButton and 
select PCS, which is the parent item's unit of measure code  

5. The Status field must be New or Under Development to edit the 
BOM, and Certified to enable it. Leave it as New and click in the No. 
field in the lines.  

Production BOM Lines 
1. You can copy lines from an existing Production BOM by clicking 

FUNCTIONS→COPY BOM to select existing lines, or you can enter the 
lines manually, which we will do now. 

2. In the Type field, leave Item as the selection. Bill of material lines 
may be purchased items, manufactured items, or sub-assemblies. 

3. In the No. field, click the AssistButton and select any item number 
except 100-500. This item number should not be a parent of itself in 
a product structure. 

4. In the Quantity Per field, enter 1. This indicates how many units of 
the item go into the parent item (e.g. 4 wheels for 1 car).  

5. Press the ARROW DOWN key to go to the next item line. 

6. Select another item No. and enter a Quantity Per, for this line and 
repeat two or three additional times. You have created a bill of 
material for our item 100-500, made up of three to five component 
items even if they are nonsensical in this case. The component lines 
only require an item number and a quantity per. 

7. In the Status field of the header, select Certified.  

8. Close the Production BOM window. 

 
NOTE: Remember to go back to the Item Card for the parent part number and enter this 
production BOM number on the Replenishment tab, Production BOM No. field. You must 
do this in order to have the system utilize the correct BOM numbers for all bill explosions 
(The process of determining component identities, quantities per assembly and other 
parent/component relationship data for a parent item.). Do this after you have developed 
the Routing. 
You also need to recalculate the item's standard cost (all levels). You learn how to do this 
after you have developed the Routing. 
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Where-Used Feature  
The where-used feature shows where a production BOM or item is used 
throughout the product structure. (A similar feature is available for routings.) The 
single and multilevel features are helpful tools when performing maintenance or 
troubleshooting. When viewing multilevel, the indentation of the description 
field indicates the level within the BOM structure, similar to an indented BOM. 
The quantity needed includes scrap percentage from the production BOM line. 
 
As an example, from the Manufacturing menu, click PRODUCT DESIGN→ITEMS. 
The Item Card window appears. 
 

1. Use the List Button, or F5, to locate item 1120. 

2. In the List, with item 1120 selected, click 
ITEM→MANUFACTURING→WHERE-USED. The Prod. BOM Where-Used 
window appears.  

3. Make note of the results in the window. 

4. In the Levels field, select Multi and now review the results. Again, 
the Where-Used is showing the production bills of material on which 
this item is used as a component part.  

5. Close the Where-Used, List and Item Card windows. 

Routings 
A routing specifies the sequence of operations to manufacture a product. The 
operations can be performed at a work center or at a machine center. Work 
centers and machine centers are referred to as capacities or facilities. 
Manufacturing companies use routings to manage and show the production 
process. The routings are the basis for process scheduling, capacity scheduling, 
and manufacturing documents. 
 
The routings are then assigned to the item card in the same manner as production 
BOMs.  
 
Work Centers and Machine Centers are critical to establishing routings. They are 
the locations where work is performed, and they have their own set of set up 
factors that describe capacities, number of resources, shift lengths etc. This 
information is used in the back scheduling of production orders and in capacity 
planning. 
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Routing Header 
On the Manufacturing menu, click PRODUCT DESIGN→ROUTINGS. The Routing 
window appears: 
 

 
 
To create a routing, you need to define the routing header. This header 
information applies to the entire routing. In the routing detail lines, the data is 
entered for the specific machine center and work center that processes the 
product at that operation. You must define a number (code) and a type.  
 

1. In the header, press F3 to insert a new Routing. 

2. In the No. field, enter 100-500. This is the number of the routing (for 
example, according to the process or the parent item).  

3. In the Description field, enter Brand New Item. This is the name of 
the routing (for example. after the process or the parent item).  

4. In the Type field, select Serial. 

5. The Status field must be New or Under Development to edit the 
routing, and Certified to enable it. Leave New in this field.  

Routing Lines 
The routing lines allow you to list the user-defined required operations. In our 
recipe example, this is the area where we list the steps of the recipe. If a field is 
mentioned below that you do not see, remember to use TOOLS→SHOW COLUMN to 
add the field. 
 

1. In the Operation No. field, enter 10. This is the number of the first 
operation. By entering 10, each new operation number will be 
incremented by 10.  
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2. In the Type field, select Work Center. This determines which kind of 
resource is used. 

3. In the No. field, click the AssistButton and select any of the Work 
Centers listed. This indicates which work center will be used. 

4. In the Run Time and Setup Time fields, enter the process times 
needed to perform the operation. In our example, these are in 
minutes. Enter reasonable figures such as 10 minutes to Set Up and 5 
minutes per piece Run Time. Note that Setup time is calculated per 
production order, run time is calculated per produced item. 

5. Use the Down Arrow to move to the next open operation step and 
continue to fill in lines for all operations involved in producing the 
item in question. Enter the following additional lines: 

 
Field Line 2 Line 3 Line 4 
Operation No. 20 30 40 
Type Work Center Work Center Work Center 
Work Center 
No. 

Choose any Choose any Choose any 

Setup Time 5 minutes 10 minutes 7 minutes 
Run Time 4 minutes 5 minutes 6 minutes 

 
 Successive steps may take place in the same Work Center. This is 

not unusual.  

6. Certify the routing. Click in the Status field in the header and select 
Certified. 

 
A new routing has been created. Close the Routing window. 
 
Next you MUST tell the system that we have created a specific production bill of 
material and a specific routing number for Item 100-500. On the Manufacturing 
menu, click PRODUCT DESIGN→ITEMS.  

 

1. Locate item 100-500 and click on the Replenishment tab. 

2. In the Routing No. field, enter 100-500.  

3. In the Production BOM No. field, enter 100-500. 
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Calculate Standard Cost 
This is a good opportunity to have the system calculate the standard cost of the 
item number that we have just created. Remember that we must have the 
Production BOM No. and the Routing No. fields identified for this item on the 
Replenishment tab of the Item Card. 
 
On the Manufacturing menu, click PRODUCT DESIGN→ITEMS. The Item Card 
window appears. 
 

1. Locate item 100-500 and click on the Invoicing tab. 

2. Make note of the current values in the Standard and Unit Cost 
fields. 

3. Click on ITEM→MANUFACTURING→CALC. STANDARD COST.  

4. Select All Levels and the click OK.  

5. Notice the change in the Standard and Unit Cost fields. 

 
The process has taken the cost of the component items or materials found on the 
production bill of material for our item, plus the labor cost as defined in the 
operation steps of the routing that you created and established a cost standard for 
this item. If the item had had a number of bill levels and many routings to make 
and assemble lower level items, they all would have been calculated and summed 
to give the standard cost for the top item. 



 

 

Microsoft Navision Introduction 

Page 140 

Test Your Skills − Create New Items for Production 
Scenario: Your company manufactures wooden tables. Create some new Items 
using the following information:  
 
Field Item 1 Item 2 Item 3 
Item No. TYS001 TYS002 TYS003 
Description Table, Complete Table Top Table Leg 
Base Unit of Measure PCS PCS PCS 
Item Category Code MISC MISC MISC 
Costing Method Standard Standard Standard 
Standard Cost 400.00 200 50 
Unit Price 550.00 <blank> <blank> 
Replenishment System Prod. Order Purchase Purchase 
Reordering Price Lot-for-Lot Lot-for-Lot Lot-for-Lot 
Include Inventory Yes Yes Yes 

 

All Skill Levels 
Your tasks are as follows: 
 

• Create the Items using the Item Card. 
• Set up the items appropriately with Purchase or Production 

replenishments. 
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Planning and the Production Order 
To produce items in the organization, usually, a production order or work order is 
issued or released to the manufacturing or assembly facility. The production 
order specifies what item is to be produced, how many are to be made and a date 
by which all the pieces should be completed. The production order also specifies 
what component parts or raw materials are required to make the end item. This is 
the production bill of material. And finally, the production order includes the 
steps and instructions required to actually make or assemble the item. This is the 
routing. 
 
A good deal of planning is required to determine what items to make when, and 
even more complex is the planning to insure that all of the component parts or 
raw materials will be available when they are needed to be able to meet the 
schedule of end item manufacturing to fill sales orders or stock shelves etc. 
 
We will now go through a scenario where a sales order is the source of demand 
for end items from our plant. We will run the planning process to identify 
requirements, release a production order to satisfy the sales order demand and 
process that production order through to completion. This is a very simplified 
example, but keep in mind how this would work in an organization of thousands 
of component part numbers, hundreds of saleable end items and hundreds of 
suppliers and customers. 

Scenario − Initial Setup 
The Sales Order Demand and Component Inventory setup must be completed 
before we begin the next scenarios. We will be using some key forms in the 
system to accomplish these tasks, but for now, we will not go into any detail 
about their main purposes and functions. These forms and tasks are defined in 
more detail in the Manufacturing course. 

Sales Order Demand 
1. Click on TOOLS→WORK DATE. Set the Work Date to 01/01/01. Click 

OK. 

2. On the Manufacturing menu, click PLANNING→SALES ORDERS. Use 
the List button or F5, or use the Next button to locate sales order 
number 109001. 

3. In an empty Sales line, click in the No. field and enter item number 
1150, Front Hub. 

4. In the Quantity field and enter 200. Tab once again and a warning 
box will be displayed. Click Yes to bypass the warning. 

5. On the first line item, Item 1000, change the Location Code to 
Green and click Yes to the warning message. 
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6. Click FUNCTIONS→RELEASE, and close the Sales Order window. 

7. A demand has just been created in the system for 200 of our Front 
Hubs. This is the end item we will be working with for this exercise. 

Component Inventory 
1. On the Warehouse menu, click INVENTORY→ITEM JOURNALS. The Item 

Journals window appears. 

2. Create two lines using the following information: 

Field Line 1 Line 2 
Item No. 1151 1155 
Location Code Green Green 
Quantity 250 250 

 

3. Click the POSTING→POST. A message will appear asking if you want 
to post the journal lines, click Yes and then click OK. Close the Item 
Journal window. 

 
We have just added inventory of the component items that are needed to make 
the Front Hub to satisfy the sales order. Notice that we have used Location 
Green. The Location feature is found throughout Microsoft Navision and is the 
functionality that allows for multiple facilities, plants, offices etc all within the 
same organization. The formal planning process would have told us to procure 
the component parts that we just added. 

Scenario 1 − Planning 
On the Manufacturing menu, click PLANNING→PLANNING WORKSHEETS. The 
Planning Worksheet window appears. 
 
Now we are going to have the system perform its planning routines to identify 
what items we need to purchase and what items we need to make in order to 
fulfill commitments based on either or both open sales orders from customers and 
sales forecasts that we have developed. Remember our Front Hub, Item number 
1150, that we just added to a sales order. 

 

1. Click the FUNCTIONS→CALCULATE REGENERATIVE PLAN. (Regenerative 
means that we will re-do the entire plan, as opposed to a partial 
update.)  
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2. Fill out the request form as follows: 

 
Tab Field Value 
Item   
 Location Green 
Options   
 MPS Yes (checked) 
 MRP Yes (checked) 
 Order Date 01/01/01 
 Ending Date 01/31/04 
 Order Tracking Respect Item Card 

 
3. Click the OK button to start the process.  

 

 
 
We have just run Material Requirements Planning (MRP), for our location. That 
is, the form has gathered all sources of demand for product coming from sales 
orders and forecasts. It has exploded the bills of material for each demand item to 
determine what component parts are required to build the demand items. It has 
compared the required quantity of all of these component parts against the on 
hand inventory of those parts, and against the open purchase orders and work 
orders to supply those parts. Finally, it will tell us what items are outstanding and 
give us recommendations to procure (purchase or make) those items. And, it does 
all this keeping track of the requirement or need dates of each item based on that 
items lead time and position in the product structure or bill of material. The 
system is trying to insure that we will have the correct items on hand and in the 
correct quantity just when they are needed. 
 



 

 

Microsoft Navision Introduction 

Page 144 

The planning worksheet is giving us the results of our planning run. Scroll 
horizontally and vertically to get a feel for the type of information it is providing. 
Remember that in addition to our Front Hub, that sales order also had a line for 
25 bicycles in our Green plant. You are seeing the requirements for many of the 
other components of the bicycle. But we will focus on item 1150, the Front Hub. 

Scenario 2 − Production Order 
1. In the Planning Worksheet window, click in the No. field and locate 

item no. 1150. You should find two requirement lines for 1150, one 
from the order for the bicycle of which it is a component, and one for 
the order for itself. Click in either one. 

2. Click the Field Filter icon or use F7. Our item number 1150 will 
appear in the Field Filter window. Click OK. This filters out all 
requirements except those for our item number. The other 
requirements have not been deleted, just hidden, and in the real 
world the planner would return to handle those requirements also.  

3. Click the FUNCTIONS→CARRY OUT ACTION MESSAGES. On the Options 
tab, for Production Order, select Firm Planned. This is the only field 
we need to be concerned with because right now we are only dealing 
with production orders to make our item. We are not buying any 
items with purchase requisitions or purchase orders. 

4. Click OK, and notice that our two requirement lines have been 
deleted. This is because we have just converted the requirements 
from the planning process or MRP, into production orders. 

5. We just used the Planning Worksheet to calculate all of our 
requirements. We could have used the Order Planning form, also in 
the Planning folder, to determine order requirements just at the top 
level. This is a valuable tool in certain business environments. Close 
the Planning Worksheet and close the Planning Folder windows. 

6. On the Manufacturing menu, click EXECUTION→FIRM PLANNED PROD. 
ORDERS. The Firm Planned Prod. Order window appears. Locate our 
two production orders for the Front Hub, item 1150. Notice that one 
order is for a quantity of 200 and one is for a quantity of 25. This 
mirrors the demand quantities coming from the sales orders. Either in 
the previous step, the Planning Worksheet, or here, the planner could 
elect to combine these into one order if that would make the best 
production decision. Select the order for 200. 

7. Now we have a Firm Planned Production Order for 200 of our 1150 
Front Hubs with a due date that will support our sales order demand. 
Microsoft Navision has a number of production order types used for 
various purposes. To proceed, we want to Release this production 
order. Click the FUNCTIONS→CHANGE STATUS.  
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8. Be sure that the Released button is selected and click Yes. The form 
returns a message telling us that the order has been released and 
giving us its new order number. This order is now ready to proceed 
through the factory or manufacturing process. Click OK and close 
the Firm Planned Order window. 

9. On the Manufacturing menu, click EXECUTION→RELEASED PROD. 
ORDERS.  

10. Locate our production order for the Front Hub, item 1150.  

 

 
 

11. Click on LINE→COMPONENTS. In this window we see the components, 
from the Production Bill of Material that are allocated for this 
production order. You may ask why the Expected quantities are 210 
and not the 200 for the parent item. This is the result of some of the 
setup factors for these component items, such as safety stock, order 
quantities and orders multiples. Close the window. 

12. Click on LINE→ROUTING. In this window we see the routing operation 
steps that have been brought over from the routing, for this 
production order. Take note of the run times that have been 
calculated for the various steps. Close this window. 

13. Now, click on FUNCTIONS→RESERVE. From this window we can link 
this production order to the sales order that was the source of its 
original demand. In some environments this is a handy feature to 
track the progress of work that is being performed to fulfill specific 
sales orders. This can be very valuable to customer service 
representatives. 

14. Click on FUNCTIONS→AUTO RESERVE. Now click on 
LINE→RESERVATION ENTRIES. Notice that our production order is now 
reserved for the original sales order. This can also be seen when the 
sales order is reviewed. Close all the windows including the 
Released Production Order. 



 

 

Microsoft Navision Introduction 

Page 146 

Scenario 3 − Pull Component Parts or Raw Materials 
1. On the Manufacturing menu, CLICK EXECUTION→CONSUMPTION 

JOURNALS. The Consumption Journal window appears. 

 The Consumption Journal is where you report to the system that you 
have pulled the required component parts from inventory in order to 
make the 200 Front Hubs called for on this Released Production 
Order. It is also the activity that moves the costs of the component 
items from inventory into the production order. You pull material 
from inventory. Identify the items and quantities that are being 
pulled for this order. Microsoft Navision has a number of options 
that allow you to have the components automatically relived from 
inventory upon notice that the production activity has begun, or 
when you report to the system that pieces have been completed. 

2. Click on FUNCTIONS→CALCULATE CONSUMPTION. On the Production 
Order tab, enter the order number for our 200 of the Front Hub. 
Click OK. 

 

 
 

3. The form has been populated with the two component items required 
to make the Front Hubs (from the Production Bill of Material), and 
the correct quantities have been filled in based on the 200 of the 
parent item that have been ordered. You are ready to pull these items 
from stock and start work. 

4. Click on POSTING→POST. Click Yes to the posting question and OK 
to the message. The items have been pulled and their costs are now 
part of the production order. Now it is time to apply some labor and 
complete the pieces. Close the form. 
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Scenario 4 − Post Labor and Completed Items 
Our production order is out on the floor with the required parts to put it together. 
Our people are following the operation steps from the routing and finished items 
are being completed. As this is happening, we want to report back to the system 
about our progress and at the same time, have the system collect the labor costs 
of our work, so that when the job is completed we can determine how much it 
actually cost to produce the product.  
 

1. On the Manufacturing menu, click EXECUTION→OUTPUT JOURNALS. 
The Output Journal window appears. 

 In this one form, you report time spent at each operation, and pieces 
completed. Ideally, you would report pieces completed at each 
operation, but in some cases, this may not be of value. However, it is 
the reporting of pieces at the last operation, that tells the system that 
these pieces have been completed, and could now be used to satisfy 
sales order demand, or demand from higher level assemblies.  

2. Click into the Prod. Order No. field. Enter the production order 
number. You can use the AssistButton in that field if you have 
forgotten the order number. 

3. Click on FUNCTIONS→EXPLODE ROUTING. The form fills in with all the 
operation steps that came from the routing. Post labor time and 
pieces completed against these steps. 

 

 
 

4. To simplify the exercise we will only make one entry with this form. 
In reality you would come back to this form multiple times to post 
and keep a specific order up to date. On the operation line for 
operation 50, Hub Assembly, tab over to the Run Time field and 
enter 100 minutes. Now tab to the Finished field and check that box 
for each operation step. Notice that the Quantity Output field for 
each operation has already been filled in with our 200 pieces.  
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5. Click on POSTING→POST. Click Yes to the question and OK to the 
message. We have just reported 100 minutes of labor and 200 pieces 
completed for this work order. Close the Output Journal.  

Scenario 4 - The Results 
1. On the Manufacturing menu, click EXECUTION→RELEASED PROD. 

ORDERS. The Released Prod. Orders window appears. 

2. Be certain that you are looking at your production order for 200 of 
1150 Front Hub. Click in the Source No. field where you see 1150 
and click the AssistButton. In the Item List, click ON ITEM→ITEMS BY 
LOCATION towards the top of the displayed options list.  

 Notice that we now have 200 hubs in our Green location. They are 
ready to ship. 

3. Escape back to the Released Production Order. Click on 
ORDER→ENTRIES→ITEM LEDGER ENTRIES. Notice the three material 
transactions that we have completed. We pulled or reduced inventory 
of the two component items and put to stock or increased inventory 
of our parent item the hub. Close this window. 

4. Click on ORDER→STATISTICS. The Production Order Statistics 
window appears: 

 

 
 

 Here you can review all the cost information concerning this 
production order. After you have had a chance to look at this 
information, you can close this window, and the Production Order 
window. 
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Test Your Skills − Production BOM 
Scenario: It is now time to create a Production Bill of Material for the wooden 
table that your company manufactures. Remember that your "Table, Complete" is 
the end item or parent part number. Except for service or repair parts, sales orders 
will normally be for the Table, Complete. 

All Skill Levels 
Your tasks are as follows: 
 

• Create a Production Bill of Material for the Table, Complete item. It 
will be made up of two component items, the Table Top and the 
Table Leg. 

• Be certain that the bill of material correctly reflects the items 
required to make the table and be sure that everything is in place so 
that the system will see your new bill. 
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Quick Interaction: Lessons Learned 
Take a moment to write down three Key Points you have learned from this 
chapter: 
 
1. 

 

 

 

 

 
 
2. 

 

 

 

 

 
 
3. 
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CHAPTER 7: OTHER FUNCTIONAL AREAS 
 

• Overview 
• Marketing  
• Resource Planning 
• Service Management  
• Human Resources  
• Business Notification 
• eCommerce 

 

Overview 
In this section, you obtain an overview of marketing, jobs, resources, service 
management, human resources, business notification, and eCommerce. More 
detailed information on these features in the program will be discussed in later 
courses. 
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Marketing 
Marketing is a powerful sales tools developed for companies with sales and 
marketing teams. This tool is also integrated with Microsoft® Outlook®. 
 
The Marketing application area gives the user complete and accurate information 
to improve the quality of every business interaction with a Contact. 

Contact Management 
With Contact Management, you can maintain an overview of your contacts and 
record your contact information for all your business relations. For each contact 
you can specify the individual contact people you have at the contact company. 
Duplicate check automatically alerts you if you enter contact information that 
already exists. You can categorize your contacts based on your own profiling 
criteria. Contact Management allows you to personalize your approach to your 
contacts. 
 
You use the contact card to record information about your contacts. Microsoft® 
Business Solutions−Navision® is integrated with Microsoft TAPI (Telephony 
Application Programming Interface). By using TAPI compliant telecom devices, 
you can call a contact simply by clicking a button on the Communication tab on 
the contact card (the small telephone icon next to the telephone or mobile phone 
number).  
 
Contacts are tightly integrated with the Sales application area. This means that, 
for example, you can issue quotes to prospects or create sales documents for 
specific contact persons. To view the contact card, on the Sales & Marketing 
menu, click MARKETING→CONTACTS. The Contact Card window appears: 
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Contact Search 
The Contact Search feature allows you to find a contact in the database even if 
you cannot remember the exact details of the contact. You can misspell a search 
string and find the contact you are looking for. This feature is available not only 
from the Sales & Marketing menu (under Marketing) but also from wizards, the 
contact list and the contact card.  
 
To limit the search, you can search across different fields (for example, Name, 
Address, Telephone No. and E-Mail Address) and tables (Contact, Interaction 
Log Entry, To-do, Opportunity, Rlshp. Mgt. Comment Line), or you can search 
across all tables. 

Task Management 
With Task Management you can organize your campaign, marketing and sales 
tasks. You can create to-do lists for yourself. To-dos can be linked to contacts 
and/or campaigns. You can assign tasks, composed of several to-dos, to other 
users or teams of users recorded in the program. Activities can be composed from 
several to-dos. 
 
The No. of To-dos window allows you to view existing to-dos in a number of 
ways. For example you can choose to view the number of to-dos or the contact 
number involved, grouped by campaign, salesperson, team, or contact. To open 
the window, on the Sales & Marketing menu, click MARKETING→TO-DOS. 

Contact Classification 
Contact Classification classifies your customers based on criteria specified by 
you, for example, to group contacts in terms of revenue. This feature provides 
crucial information for campaign planning, for targeting your contacts more 
specifically and for streamlining your sales and marketing messages. 
 
A contact rating system is provided to let you set up specifically tailored ratings 
reflecting, for example, the importance or loyalty of your customers, vendors and 
partners. You can have the ratings displayed on the contact card for quick 
reference and update. 

Campaign Management 
Campaign Management allows you to organize campaigns based on market 
segments you create yourself. You can segment your contacts based on specific 
criteria, such as, sales, contact profiles and interactions. 
 
You can reuse existing segments, for example, specify whether or not these 
segments are to be updated every time new information on the contact is entered, 
or "freeze" the group for follow-up activities, such as direct mailing.  
 
You can mail merge the identified segment with a Microsoft® Word document or 
send any other file type to the contacts in your segment. You can send copies of 
the same document to people of different nationalities each in their native 
language. 
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Information about a campaign is entered on the campaign card. To open the 
Campaign Card window, on the Sales & Marketing menu, click 
MARKETING→CAMPAIGNS. 

Document Management & Interaction Log 
You can log the interactions that you have with your contacts, such as a 
telephone call, a meeting or a letter. If an interaction contains a document, you 
can save it under the relevant contact, and Document Management helps you 
keep track of the document in question. 
 
Microsoft Navision documents that you send to your contact, such as sales orders 
or quotes, can be logged and retrieved to be used at a later stage. You get an 
accurate and up-to-date account of all your interactions with the contact. 

Opportunity Management 
With Opportunity Management you can keep track of sales opportunities. 
Salespeople have an overview of what is in the pipeline and can plan ahead 
accordingly. 
 
Opportunity Management helps you divide your sales process into different 
stages. You can view existing opportunities in the Opportunities window. The 
Opportunities window allows you to view existing opportunities in a number of 
ways. For example you can choose to view the number of opportunities or the 
value of the opportunities (calculated in a variety of ways), grouped by 
campaign, salesperson, or contact.  
 
On the Sales & Marketing menu, click SALES→OPPORTUNITIES. The Opportunities 
window appears: 
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Outlook Client Integration 
Most Sales & Marketing users build relationships with their contacts using 
calendar and task management tools, and much of the external communication 
takes place through Microsoft® Outlook®. Therefore integration between 
Microsoft Navision and Outlook is vital to the CRM user's performance. 
 
With the Outlook Client Integration feature you can schedule meetings in 
Outlook and see the to-dos in Microsoft Navision before the meeting, and when 
the meeting has taken place, you can log it in the Interaction Log Entries window 
as an interaction. The scheduling capabilities in Outlook allow you to plan and 
execute to-dos you have been assigned, and in Microsoft Navision you can create 
activities for customers and contact persons. 
 
Whenever information (for example, a to-do or a contact) is entered in Microsoft 
Navision, this information is automatically updated in Outlook. There is no need 
to update the same information twice in two different applications. 

E-Mail Logging for Microsoft Exchange 
This feature integrates Microsoft Navision with the Microsoft Outlook e-mail 
service. All your e-mail correspondence, both inbound and outbound, can be 
logged automatically or manually in Microsoft Navision and can therefore be 
shared with your colleagues to ensure that they have instant access to the latest 
communications with business contacts. 
 
This solution is server-based and requires Microsoft Exchange Server. Making 
the solution server-based ensures that e-mails are kept in their natural 
environment instead of lowering performance by storing the e-mails on the 
application server. The integration with Outlook further allows you to use the 
built-in features in Outlook. For example, you can set up rules in Outlook that 
direct certain types of e-mail to specific folders for subsequent, automatic 
logging in Microsoft Navision. 

Resource Planning 
The Jobs & Resources functionality within Microsoft Navision is contained 
within the Resource Planning application area. For this section, all paths to 
access functionality will begin in the Resource Planning menu unless otherwise 
stated. 

Jobs 
You use the Jobs application area for detailed planning and management of the 
costing for any long-term job or project activity. You can also use it for many 
types of services and consultancy tasks. 
 
Successful Job management requires an up-to-date overview, detailed planning 
and the ability to carry out follow-up analysis using objective data. 
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This application area contains all the features that are used with a company's job 
and project management. For example, Job cards, job budgets, job journals, as 
well as reports and registers related to resources. 

Job Budgets 
You use the Job Budget window to set up a budget for a job. You can set up a 
budget for each job. The budget is used to plan the resources you allocate to a 
job. 
 
The budget can be either very general with few entries or it can contain more 
entries that are divided into activity levels. On the Resource Planning menu, click 
JOBS→BUDGETS to view the job budgets. 
 

 
 

Job Journals 
You can use the job journals to: 
 

• Post job usage of resources, items and general ledger resources. 
• Apply job ledger and item ledger entries. 
• Assign entries to phases, tasks, and steps. 
• Reconcile resources. 

 
On the Resource Planning menu, click JOBS→JOB JOURNALS to view the job 
journals. 

Job Sales 
Integration with the Sales & Marketing application area allows you to perform 
job sales. All job sales must be posted on a Sales Invoice. 
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Resources 
With the Resources application area, you define resources, which can either be 
personnel or machines. You may link the individual resources to resource groups. 
 
This functionality contains all the features that are used with a company's 
resource management: Individual resources, resource groups, capacity planning, 
resource journals, as well as reports and registers related to resources. 
 
Resources functionality is a powerful tool for optimal management of personnel 
and/or machines. 

Resource Cards 
You set up new resources on resource cards.  
 
To view the resource cards, on the Resource Planning menu, click Resources. 
The Resource Card window appears:  
 

 
 

Resource Groups 
You can work with resources as individual entities or as groups. Any number of 
resources can be assigned to a resource group. 

Resource Capacity 
You may need to increase the capacity of resources (for example, technicians) 
regularly over a period. 
 
A resource's capacity indicates how much of the resource is available in a 
specified period. 
 
You can assign or modify capacities to your individual resources or to resource 
groups. For example, for employees you might want to enter the available man-
hours. For machines, you could enter the production capacity for a time frame. It 
is possible to enter capacity by day, week, month, quarter, year, or accounting 
period. You can record resource capacities in the Resource Capacity window. To 
view it, on the Resource Planning menu, click Resource Capacity. 
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Allocating Resources to Jobs 
You can allocate a resource or a resource group's capacity to one or several jobs. 
You can do this either from the Resources application area or the Jobs 
application area. 
 
You use the Resource Allocated per Job window to view and change the amounts 
of measuring units for resources allocated to the various jobs in different time 
periods. To view the window, go to the Resource Capacity window and click 
PLANNING→RESOURCE ALLOCATED PER JOB. 

Resource Availability 
The Resource Availability window shows a scrollable summary of resource 
capacities. The window is divided into lines showing the entire capacity, the 
quantity allocated to jobs on order, the capacity assigned to jobs on quote, the 
availability after order and the remaining capacity after all jobs on quote or order. 
To open the window from the resource card, click PLANNING→RESOURCE 
AVAILABILITY. 

Resource and Job Integration 
The Resources application area and the Jobs application area are integrated, so 
you can allocate the capacity of a resource or a resource group to one or several 
jobs. 

Resource Journals 
The Resource Journals feature enables you to keep track of your use of resources 
and their profitability. 
 
You can post usage and sales of your resources in the resource journal, and you 
can generate statistics from this information for internal management purposes. 
To see a Resource journal, click Resource Journals. 

Resource Statistics 
You can see all of the transactions recorded in job journals, resource journals or 
(with some limitations) sales documents in the Resource Statistics window. To 
open the window from the resource card, click the RESOURCE→STATISTICS. 

Service Management 
Service Management makes it profitable for you to deliver superior customer 
service. It helps you take customer satisfaction one step further and exceed your 
customers' expectations. You can: 
 

• Quickly and easily access customer service history. 
• Anticipate customer needs. 
• Maintain real-time records, such as the date, time and technician 

assigned to each customer order. 
 
In this section, all references to accessing functional areas will begin in the 
Service main menu unless otherwise stated. 
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Service Order Management 
You can register after-sales issues including service requests, services due, 
service orders, and repair requests. Service requests can be initiated (by 
customers or automatically), according to the terms stipulated in a service 
contract.  
 
Critical data in service order handling can be entered from a call-center or repair 
shop. You can register ad hoc or one-off service orders. You can access complete 
service order history, service order quotes and loaner management through the 
Service Order Log. You create a service order in the Service Order window.  
 
To open the window, on the Service menu, click ORDER PROCESSING→ORDERS. 
The Service Order window appears: 
 

 

Service Price Management 
Having a well thought-out service price strategy is one of the means companies 
use to gain an overview and control of the costs involved in providing service, 
and to eventually increase the profitability of their service operations. The service 
price management feature in Service Management gives companies an effective 
tool to support their service price strategy, whether it is simple or complex. 
  
Service price management allows the setup of service price groups to take into 
consideration the service item (or service item group) as well as the type of fault 
the service task involves. Service price groups can be set up for a limited period 
of time, and/or for a specific customer or currency. Price calculation structures 
can be used as templates to assign a price to a service task. For example, this 
makes it possible to assign specific items included in the service price as well as 
the type of work included. And to ensure that the right prices are applied, it is 
possible to assign fixed, minimum, or maximum prices, depending on 
agreements with customers. Service price group statistics allow you to keep track 
of the profitability of each service price group.  
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Service Item Management 
With Service Item Management you can create a database for all your service 
items and parts, including contract information, component management, 
reference to the Bill of Materials, and warranty information. 
 
You can access the Service Level Agreement for information on, for example, 
response times. 
 
You can register all items and spare parts with serial numbers as well as any 
replacement equipment technicians may use, and then link them to the Service 
Item Log. You can track all spare parts and equipment. You can access key 
business indicators on service items in the Trendscape Analysis feature. 
 
You keep track of service item information on the service item card.  
 
To open the window, on the Service menu, click ORDER PROCESSING→SERVICE 
ITEMS. The Service Items window appears. 

Service Contract Management 
With service contracts you can set up an agreement with the customer concerning 
the service level to be delivered. You can access information on contract history, 
contract renewal, and contract templates in Contract Management. 
  
Service contracts give you the option to record details on service levels, response 
times, and discount levels as well as the service history of each contract, 
including used service items and parts and man-hours. 
 
With Contract Management you can enable flexible invoicing, contract 
profitability measurement, and contract quotes. You set up service contracts in 
the Service Contract window.  
 
To open the window, on the Service menu, click ORDER CONTRACT 
MANAGEMENT→CONTRACTS. The Service Contracts window appears. 

Planning and Dispatching 
You can assign personnel to work orders with Planning and Dispatching. It also 
allows you to log details such as work order status. Service personnel and field 
technicians can be filtered according to availability and skills. You can gain an 
overview of service task prioritization, service loads, and task escalations. 
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Job Scheduling 
With Job Scheduling, you can automate service-oriented tasks, for example, 
generate preventative service orders, service contract renewals or service contract 
invoicing. You can also set up Job Scheduler to perform automatic checks on 
whether there are any batches to be processed on a specific date. 
 
You set up job scheduling in the Job Scheduler Setup window. To open the 
window, on the Administration menu, click APPLICATION SETUP→JOB 
SCHEDULER→JOB SCHEDULER SETUP. The Job Scheduler Setup window appears. 

Human Resources 
Human Resources is a fully integrated application area that enables you to 
register and update personnel information about employees effectively. This 
application area includes all the features that are used in the human resources 
department of a company: Employee cards, absence registration, and reports 
related to employees. 
 
This makes personnel management more effective through the optimal use of 
employee data. 
 
In this section, all paths to functional areas will begin in the Human Resources 
main menu unless otherwise stated. 

Employees 
Use the employee card to register all employee information. To view the 
window, click Employees: 
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Absence Registration 
Absence codes help you keep track of the absences of employees and the cause 
of the absences. To open the Absence Registration window, click Absence 
Registration. 

Grounds for Termination 
Use the Grounds for Termination window to set up reasons that employees might 
leave the company. To open the window, click SETUP→GROUNDS FOR 
TERMINATION. 

Employment Contracts 
Use employment contract codes to set up the types of contracts the company has 
entered into with its employees. To open the Employment Contracts window, 
click SETUP→EMPLOYMENT CONTRACTS. 

Qualification 
Enter qualification codes to specify various employee qualifications. To open the 
Employee Qualifications window click SETUP→QUALIFICATIONS. 

Relatives 
Enter codes for relatives to register the precise relationship of an employee's 
relatives or close contacts to each employee. To open the Employee Relatives 
window from the employee card, click EMPLOYEE→RELATIVE.  

Miscellaneous Articles 
You can set up codes and descriptions for the benefits your employees receive 
and articles owned by the company that are in the possession of individuals. You 
do this in the Misc. Article Information window. To open the window from the 
employee card, click EMPLOYEE→MISC. ARTICLE INFORMATION. 
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Confidential Information 
You use confidential information codes to register confidential aspects of an 
individual's employment, such as salaries, stock option plans, pensions, and so 
on. You record confidential information about an employee in the Confidential 
Information window.  
 
To open the window from the employee card, click EMPLOYEE→CONFIDENTIAL 
INFORMATION. The Confidential Information window appears: 
 

 
 

Business Notification 
The Business Notification solution is used to generate and send notifications to 
inform your vendors or colleagues from other departments about certain events. 
For example, you may send a notification when you have placed an order and 
received some of the purchased items, but you are waiting for delivery of the rest 
of the order. Sending a notification will alert your supplier that some of the goods 
have not yet been delivered. By enabling this feature in the Notification Setup 
window, you allow the program to send out six predefined notifications. 

Types of Notifications 
There are two approaches to generating notifications: time-based and field 
change-based. 
 
The Business Notification solution offers five time-based notifications that alert 
the recipient about: 
 

• Upcoming deliveries 
• Items that were not received after the promised receipt date 
• Purchase order confirmations that were not received 
• Delayed production orders 
• Current inventory status 
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To see the list of the available time-based notifications, open the Notifications 
window from the Administration menu, click APPLICATION SETUP→GENERAL→ 
BUSINESS NOTIFICATION SETUP. The Notification Setup window appears. 
 
Now, click SETUP→NOTIFICATION REPORTS. The Notification Reports window 
appears: 
 

 
 
The sixth, field change-based, notification is used for tracking changes in the 
Production BOM status. If you have selected the Send Notifications check box 
in the Notification Setup window, this notification is sent every time the status in 
the corresponding field changes. 

Logging Period 
You can define how long you want to store sent notification entries. You can 
specify this period in the Notification Setup window and use it as a default for all 
time-based notification, or you can assign a logging period to each separate 
batch. 

Batches 
Batches are used for managing a specific set of notifications. You can choose to 
send out up to five predefined time-based notifications for your batch. Field 
change-based notifications will be sent out automatically. 

Sending Notifications 
In order to send notification lines, you must first collect them. Among the lines 
you collect, there may be some notification entries that were sent earlier. Should 
the lines have been sent earlier, there will be a check mark in the Sent field for 
these lines and the most recent time the notification was sent will be posted in the 
Notification Lines window. 
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eCommerce 
The eCommerce functionality in Microsoft Navision is divided into two parts: 
Commerce Portal and Commerce Gateway. 

Commerce Portal 
Commerce Portal is an e-commerce solution that enables Web-based trading, 
self-service and other forms of collaboration between a company and all its 
supply chain partners. Commerce Portal makes it easy for partners − customers, 
vendors and others − to serve themselves directly from their Web portal − 
anytime, anywhere. They can maintain and query data and documents across the 
range of functions found in Microsoft Navision (depending on their particular 
role and the access rights that have been defined). 
 
With Commerce Portal, you connect your customers and vendors to your 
business management system by way of the Internet. You respond to your 
partners' needs with Web access to real-time information and self-service features 
from within your Microsoft Navision solution. Information is always up-to-date 
and accurate, and self-service features are relevant to the user's particular 
business needs. 

Commerce Gateway 
The Commerce Gateway functionality allows you to set up BizTalk partners 
from within Microsoft Navision. After this setup has been complete, it is possible 
to exchange BizTalk documents with your BizTalk partners.  
 
Some of the documents that you can send to your BizTalk partners include: 
 

• Sales Orders 
• Sales Invoices 
• Sales Credit Memos 
• Purchase Orders 

 
In addition to sending the above mentioned documents, it is possible to receive 
documents as well. 
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Test Your Knowledge − Other Functional Areas 
 

1. What is the purpose of Contact Management?  

 

2. What is the purpose of Opportunity Management?  

 

3. How many resources may be in a resource group?  

 

4. In Jobs and Resources, what allows you to post job usage of 
resources; apply entries to Phases, Tasks and Steps; and apply job 
ledger and item ledger entries?  

 

5. What area of Service Management is used to automate service-
oriented tasks?  

 

6. Describe how Service Contract Management can be used.  

 

7. eCommerce is divided into two parts. What are they?  

 

8. In eCommerce, what functionality allows you to set up BizTalk 
partners from within Microsoft Navision?  

 

9. What is Business Notification used for?  

 

10. There are two approaches to generating Business Notifications. What 
are they?  

 

11. List the major functional areas found in Human Resources.  
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Quick Interaction: Lessons Learned 
Take a moment to write down three Key Points you have learned from this 
chapter: 
 
1. 

 

 

 

 

 
 
2. 

 

 

 

 

 
 
3. 
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APPENDIX A: TEST YOUR KNOWLEDGE / SKILLS 
SOLUTIONS 

Test Your Knowledge − Getting Started (CH1) 
1. How many Salesperson/Purchasers are in Microsoft Navision? Eight 

2. Who is the contact at Customer 49525252 − Beef House? Frau 
Karin Fleischer 

3. What is the current balance on Customer 49525252 − Beef House? 
5,941.36 

4. How many open invoices does Customer 49525252 − Beef House 
have? Four 

5. How many Bank Accounts are set up in Cronus International, Ltd.? 
Five 

 
HINT: On the Financial Management menu click CASH MANAGEMENT→BANK 
ACCOUNTS  
 

6. What is the quantity on hand of Item No. 70000? (Hint: On the 
Warehouse menu, click PLANNING & EXECUTION→ITEMS) 4,202 

7. What is the Unit Price of Item No. 70040? 108.20 

8. What is the Last Direct Cost of Item No. 70040? 55.10 

9. Name three ways to insert a Customer: Press F3, on the Menu bar, 
click EDIT→INSERT NEW, on the Toolbar, click the Insert button 

10. When you type the letter "t" in a date field, what happens? The field 
is populated with today's system date. 

11. What Shortcut key do you press to delete a new Customer? F4 

12. When you type the letter "w" in a date field, what happens? The 
field is populated with the specified Work Date. 

13. What are the three types of Dimensions available in Microsoft 
Navision? Global, Shortcut, Budget. 
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14. What would the following filter expression display: 1200|1300? 
Records with 1200 or 1300 will be displayed. If there is a record 
with each number, both will be displayed. 

15. What would the following filter expression display: 1100..2100? 
Records 1100 through 2100 would be displayed.  

16. What Shortcut key do you press to Lookup, Drill-down and display 
the Options menu? F6 

17. What are the three filter types available in Microsoft Navision? Field 
Filter, Table Filter, Flow Filter. 

Test Your Knowledge − Technology (CH2) 
1. Name the seven types of objects in C/SIDE.  Tables, Forms, 

Reports, Dataports, XMLports, Codeunits, MenuSuite 

2. Name the four types of tables in C/SIDE. Normal, System, 
Temporary, Virtual 

3. What is a codeunit? A codeunit is an object type that contains 
functions written in C/AL code. 

4. Explain C/AL. C/AL is a fourth-generation programming 
language (4GL) that is used to create functions; controls how 
individual database objects interact; and includes standard 
functions for reading, writing and modifying table data. 

5. What are the special facilities in Microsoft Navision? Direct access 
from one table to another; easy data entry; information in 
multiple dimensions; automatic calculation of amounts and 
quantities; information on what is included in a calculated 
amount; filtering of information; sorting with one or more keys; 
pictures of items or a company logo on the screen together with 
the associated information; and connections to mail merge, 
spreadsheet applications and presentation graphics programs. 

6. Microsoft Navision can be installed on which database servers? 
Navision Database Server and the Microsoft SQL Server Option 
for Navision based on Microsoft SQL Server. 

7. Explain SIFT. SIFT (Sum-Indexed Flow Technology) is the basis 
of FlowFields. It is a feature in the database that allows you to 
have sums calculated very quickly by maintaining SumIndexes. 

8. Define/describe the following and the relationship between them: a 
record, a field, a table, a company. A field is the smallest logical 
structure used in the C/SIDE database. Fields are assembled into 
a structure called a record. A record is a logical structure 
assembled from an arbitrary number of fields. Records are 
organized in tables.  
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 A table can be thought of as an N by M matrix. Each of the N 
rows describes a record and each of the M columns describes a 
field in the record. An example of a table is the Customer table, 
which contains a record for each customer.  

 Each company in a database contains a number of tables. A 
company is the largest logical structure used in a C/SIDE 
database. A company may be considered to be a subdatabase; its 
primary use is to separate and group large portions of data in a 
database. A company can contain private tables as well as tables 
shared with other companies. 

9. Describe the features of Navision Application Server. Navision 
Application Server is a middle-tier server, which executes 
business logic without user intervention. With Navision 
Application Server, it is possible to communicate with external 
services. Navision Application Server acts as a client towards a 
database server and can act as a server for other services. When 
you start Navision Application Server, it opens a predefined 
database and executes C/AL code in a predefined codeunit. 

10. Describe the multilanguage features in Microsoft Navision. Speak 
Your Employees' Language − Microsoft Navision helps 
employees become more efficient by eliminating language 
barriers among your multilingual workforce. Speak Your 
Customer's Language − With Microsoft Navision, your customer 
service improves because you can do business in the language 
preferred by your customer. 

Test Your Skills − Creating an Item and Vendor (CH3) 
Scenario: As the Purchasing agent for Cronus International, Ltd. you are 
responsible for setting up new items as well as new vendors. A customer has 
requested two items of which one is not currently stocked by your company. You 
need to create a new item as well as a new vendor that will supply this new item. 

Step-by-Step 
 

1. On the Purchase menu, click INVENTORY & COSTING→ITEMS. 

2. Press F3 to insert a new item card. 

3. In the No. field, type 80301. 

4. In the Description field, type USB Mouse. 

5. In the Base Unit of Measure field, click the AssistButton.  
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6. In the Item Units of Measure window, enter the following 
information: 

 
Code PCS 
Qty. per Unit of Measure 1 

 
7. Click OK. 

8. Click the Invoicing tab.  

9. Enter the following information: 

 
Costing Method FIFO 
Unit Cost 11.50 
Last Direct Cost 11.50 
Price/Profit Calculation Profit=Price-Cost 
Unit Price 14.375 
General Product Posting 
Group 

RETAIL 

VAT Product Posting 
Group 

VAT25 

Inventory Posting Group RESALE 
 

10. All other fields on this tab may remain as they are. 

11. Click the Replenishment tab. 

12. Enter the following information: 

 
Purchase System Purchase 

 
13. The Item setup is complete. Close the Item Card window. 

14. On the Purchase menu, click ORDER PROCESSING→VENDORS. 

15. Press F3 to insert a new vendor. 

16. In the No. field, type 40101. 
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17. Enter the following information: 

 
Vendor Name Lewis Home Furniture XYZ, 

LTD. 
Address 89 Radcroft Road 
Postal Code GB-IB7 7VN 
City Gainsborough 
Phone No. 23159799 
Contact Katie Jordan 

 
18. Click the Invoicing tab. 

19. Enter the following information: 

 
General Business Posting 
Group 

NATIONAL 

VAT Business Posting 
Group 

NATIONAL 

Vendor Posting Group DOMESTIC 
 

20. Click the Payments tab. 

21. Enter the following information: 

 
Application Method MANUAL 
Payment Terms Code 1M(8D) 
Payment Method Code CHECK 

 
22. Click the Receiving tab. 

23. Enter the following information: 

 
Location Code BLUE 
Shipment Method Code CIF (Cost, Insurance and Freight) 
  

 
24. The Vendor setup is complete. Close the Vendor Card window. 
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Test Your Skills − Creating a Purchase Order (CH3) 
Scenario: As the Purchasing agent for Cronus International, Ltd., you need to 
create a purchase order to purchase two items. 

Step-by-Step 
 

1. On the Purchase menu, click ORDER PROCESSING→ORDERS.  

2. In the header, press F3 to insert a new Order and ENTER to assign a 
Purchase Order No.  

3. In the Buy-from Vendor No. field, type 40101 and press ENTER. 

4. Click in the lines. 

5. In the Type field, press F6, select Item and press ENTER. 

6. In the No. field, type 80216 and press ENTER.  

 The Description field is automatically populated with the name of 
the item (Ethernet Cable).  

7. In the Quantity field, type 6. 

8. Press DOWN ARROW to go to the next line and then HOME to go to the 
beginning of the line. 

 The Type field should automatically default to Item. If the program 
does not do this, select Item in the Type field. 

9. In the No. field, type 80301 and press ENTER.  

 The Description field is automatically populated with the name of 
the item (USB Mouse).  

10. In the Quantity field, type 12. 

11. Verify that the Direct Unit Cost Excl. VAT field is populated on 
both lines.  

12. Close the Purchase Order window. 
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Test Your Skills − Receiving and Invoicing a Purchase Order 
(CH3) 

Scenario: As the Purchasing agent for Cronus International, Ltd., you are 
responsible for purchasing items. You have created, printed and emailed a 
purchase order to the supplying vendor. Now, the items that are related to the 
purchase order have arrived on the warehouse dock. You can fully Receive and 
Invoice this order. 

Step-by-Step 
 

1. On the Purchase menu, click ORDER PROCESSING→ORDERS.  

2. Locate the Purchase Order created in the previous scenario.  

3. In the Vendor Invoice No. field, type LHF-10021. 

4. In the lines, be sure the Qty to. Receive and Qty. to Invoice for Item 
No. 80216 equals 6 and Item No. 80301 equals 12. 

5. Click POSTING→POST.  

6. Select Receive and Invoice. 

7. A message will appear asking if you want to post the Order. Click 
Yes. 

8. Click OK. 

9. Close the Purchase Order window. 

Test Your Skills − Record Automobile Maintenance Expense 
(CH3) 

Scenario: In Cronus International, Ltd. you are the accounts payable clerk, 
responsible for posting and paying expenses. You have received a bill from 
Mortimor Car Company for routine automobile maintenance services. You need 
to record this expense for payment. 

Step-by-Step 
 

1. On the Purchase menu, click ORDER PROCESSING→INVOICES.  

2. In the header, press F3 and then press ENTER. 

3. In the Buy-from Vendor No. field, type 44127914 and then press 
ENTER. 

4. In the Posting Date field, type 01/14/04. 

5. In the Vendor Invoice No. field, type LP-45002. 

6. Go to the lines. 
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7. In the Type field, press F6, select G/L Account and press ENTER. 

8. In the No. field, type 8530 and press ENTER.  

 The Description field will be populated with the name of the 
account (Repairs and Maintenance). 

9. In the Quantity field, type 1.  

10. In the Direct Unit Cost Excl. VAT field, type 132.94. 

11. Click POSTING→POST.  

12. A message will appear asking if you want to post the Order. Click 
Yes. 

13. Click OK. 

14. Close the Purchase Invoice window. 

Test Your Skills − Pay the Automobile Maintenance Expense 
(CH3) 

Scenario: In Cronus International, Ltd. you are the accounts payable clerk, 
responsible for paying expenses. You have posted the invoice from Mortimor Car 
Company for routine automobile maintenance services and you now need to pay 
the invoice. You will print and post the check. 

Step-by-Step 
 

1. Click TOOLS→WORK DATE. The Work Date window appears. 

2. Type 01/31/04 and press ENTER or click OK. 

3. On the Financial Management menu, click PAYABLES→PAYMENT 
JOURNALS.  

4. In the Batch Name field, if BANK is not indicated, press F6, select 
BANK and press ENTER. 

5. Click PAYMENTS→SUGGEST VENDOR PAYMENTS.  

6. On the Vendor tab, in the No. field, type 44127914. 

7. Click on Options.  

8. In the Last Payment Date, type 01/31/04. 

9. In the Bal. Account Type field, click the AssistButton and click 
Bank Account. 

10. In the Bal. Account No. field, click the AssistButton, click WWB-
OPERATING and click OK. 

11. In the Bank Payment Type field, click the AssistButton and click 
Computer Check.  
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12. Click OK. 

13. Click PAYMENTS→PRINT CHECK. The Check request form window 
appears. 

14. Do not change the filters set on the Gen. Journal Line tab. 

15. Click Options. 

16. In the Bank Account field, click on the AssistButton, click WWB-
OPERATING and click OK. 

17. Press Enter. The Last Check No. field will automatically be 
populated from the Last Check No. field on the Bank Account card. 

18. Select the One Check per Vendor per Document No. check box.  

19. Click Print. 

20. In the Check − Print dialog window, select the Print to File check 
box. 

21. In the Print to File window, type Test Check and click OK. 

 A second line now appears in the Payment Journal. This is the bank 
balancing line. 

22. Click POSTING→POST (F11).  

23. A message appears asking if you want to post the journal lines. Click 
Yes. 

24. Click OK or press ENTER. 

25. Close the Payment Journal window. 

Test Your Skills − Adjust the Automobile Maintenance 
Expense (CH3) 

Scenario: In Cronus International, Ltd. you are the Accounting Manager who is 
responsible for G/L adjustments. The Mortimor Car Company bill had a gasoline 
charge on it and you need to reallocate as follows: 
 

• Repairs and Maintenance (8530) = 115.00 
• Gasoline and Motor Oil (8510) = 17.94 

 

Step-by-Step 
 

1. Click TOOLS→WORK DATE. The Work Date window appears.  

2. Type 01/31/04 and press ENTER or click OK. 

3. On the Financial Management menu, click GENERAL 
LEDGER→GENERAL JOURNALS.  
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4. In the Batch Name field, press F6 to open General Journal Batches 
window.  

5. Choose GENERAL and press ENTER twice. 

6. Leave the Document Type field empty. 

7. In the Account Type field, press F6 and click G/L Account. 

8. In the Account No. field, press F6 and find the G/L account number 
for Repairs and Maintenance: 8530. Click OK and press ENTER. 

9. In the Description field, type Correction to Document No. 108029. 

10. In the Amount field, type -17.94 in order to make a credit entry to 
the Repairs and Maintenance account. 

11. In the Bal. Account Type field, retain G/L Account as the selection. 

12. In the Bal. Account No. field, type 8510, and press ENTER. 

13. Clear the Bal. Gen. Posting Type, Bal. Gen. Bus. Posting Group, 
and Bal. Gen. Prod. Posting Group fields.  

14. Click POSTING→POST (F11). 

15. A message appears asking if you want to post the journal lines. Click 
Yes. 

16. Press ENTER or click OK. 

17. Close the General Journal window. 

Test Your Skills − Create a Sales Order (CH4) 
Scenario: In Cronus International, Ltd. you are the clerk responsible for filling 
new orders. You have received another order from Beef House Outlet for 10 
bicycle tires and you now need to create the order. You will post the order. 

Step-by-Step 
 

1. Click TOOLS→WORK DATE. The Work Date window appears.  

2. Type 01/31/04 and press ENTER or click OK. 

3. On the Sales & Marketing menu, click ORDER PROCESSING→ORDERS. 

4. In the header, press F3 and ENTER to create a new record. 

5. In the Sell-to Customer No. field, lookup to the Customer list and 
select Beef House Outlet. Press ENTER. 

6. Go to the lines. 

7. In the Type field, press F6, choose Item and press ENTER. 

8. In the No. field, type 1160 and press ENTER. 
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9. Leave the Location Code field blank. 

10. In the Quantity field, type 10. 

11. In the Unit Price field, type 41. 

12. Verify that the Qty. to Ship and Qty. to Invoice fields both display 
10.  

13. Click POSTING→POST (F11).  

14. Select Ship and Invoice. 

15. Close the Sales Order window. 

16. On the Navigation Pane, click INVENTORY & PRICING→ITEMS. 

17. In the No. field either press F5 or use the List button in the Toolbar 
to see the Item List window. 

18. Find the item 1160 (Tire) and click OK. 

19. Press ENTER or TAB to exit the field. 

20. View the Item Ledger Entries window for this item by either 
pressing CTRL + F5 or clicking selecting ITEM→ENTRIES→LEDGER 
ENTRIES.  

21. Close the Item Ledger Entries and Item Card windows. 

22. On the Navigation Pane, click SALES→CUSTOMERS.  

23. In the No. field, press F5 or use the List button in the Toolbar to see 
the Customer List window. 

24. Select Beef House Outlet and click OK. 

25. Press ENTER or TAB to exit the field. 

26. View the Customer Ledger Entries window for this item by either 
pressing CTRL + F5 or clicking CUSTOMER→LEDGER ENTRIES. The 

27. Close the Customer Ledger Entries and Customer Card windows. 

Test Your Skills − Post a Cash Receipt (CH4) 
Scenario: In Cronus International, Ltd. you are the clerk responsible for posting 
received payments. You have received another payment from Beef House Outlet 
for the remaining balance on an invoice and you now need to post the payment. 

Step-by-Step 
 

1. Click TOOLS→WORK DATE. The Work Date window appears.  

2. Type 02/25/04 and press ENTER or click OK. 
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3. On the Financial Management menu, click RECEIVABLES→CASH 
RECEIPT JOURNALS. 

4. Make sure that the Batch Name field reads BANK. If it does not, 
lookup to the General Journal Batches window and select it. 

5. In the Posting Date field, type w for the Work Date (2/25/04). 

6. In the Document Type field, choose Payment. 

7. Click VIEW→SHOW COLUMN. Select the External Document No. 
field.  

8. In the External Document No. field, type 44703. 

9. In the Account Type field, choose Customer. 

10. In the Account No. window, lookup to the Customer List and find 
the record for Beef House Outlet. Select the record and click OK. 

11. In the Applies-to Doc. Type field, choose Invoice. 

12. In the Applies-to Doc. No. field, lookup (F6) to the Apply Customer 
Entries window. 

13. Select the invoice with a Remaining Amount of 410.00 and click 
OK. 

14. Click POSTING→POST (F11).  

15. A message appears asking if you want to post the journal lines. Click 
Yes. 

16. Click OK. 

17. Close the Cash Receipt Journal window. 

Test Your Knowledge − Finance − Reporting (CH5) 
1. What are the various ways to prepare analyses of G/L Accounts? 

You can do simple calculations in the Chart of Accounts by using 
Field Filters and/or FlowFilters; you can use the standard 
reports in the program; you can create more complex statements 
and calculations using Account Schedules to communicate the 
information; and you can also use Analyses by Dimensions based 
on an Analysis View. 

2. Where are Standard Reports located in Microsoft Navision? 
Standard Reports can be found under the Reports menu item in 
each application area. 
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3. What purpose do Account Schedules serve?  Account schedules are 
intended for calculations that cannot be done directly in the 
chart of accounts. You use account schedules to analyze figures 
in G/L accounts or to compare G/L entries with G/L budget 
entries. Account schedules can be used to make both simple and 
complex customized financial statements and management 
reports.  

4. How can dimension information be reproduced in Excel? Account 
Schedules, using the Analysis View; and Analysis by Dimensions 
can be exported to Excel. 

5. What is Business Analytics? Why would a company want to use it? 
Business Analytics is a decision support and analysis tool that 
provides users with a range of visibility (detailed to aggregated) 
into different aspects of their business. It allows users to quickly 
get to the information they are looking for at the desired level of 
detail.  

Test Your Skills − Create New Items for Production (CH6) 
Scenario: Your company manufactures wooden tables. Create some new Items 
using the following information: 
 
Field Item 1 Item 2 Item 3 
Item No. TYS001 TYS002 TYS003 
Description Table, Complete Table Top Table Leg 
Base Unit of Measure PCS PCS PCS 
Item Category Code MISC MISC MISC 
Costing Method Standard Standard Standard 
Standard Cost 400.00 200 50 
Unit Price 550.00 <blank> <blank> 
Replenishment System Prod. Order Purchase Purchase 
Reordering Price Lot-for-Lot Lot-for-Lot Lot-for-Lot 
Include Inventory Yes Yes Yes 

 

Step-by-Step 
 

1. On the Manufacturing menu, click PRODUCT DESIGN→ITEMS. 

2. Press F3 to insert a new Item. 

3. In the No. field, type TYS001. 

4. In the Description field, type Table, Complete. 

5. In the Base Unit of Measure field, click the AssistButton. 
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6. In the Code field, click the AssistButton. Click on the PCS line and 
click OK twice. 

7. In the Item Category Code field, click the AssistButton, click on 
MISC and click OK or press ENTER.  

8. Click the Invoicing tab. 

9. In the Costing Method field, click the AssistButton and click 
Standard.  

10. In the Standard Cost field, type 500. 

11. In the Unit Price field, type 500. 

12. Click the Replenishment tab.  

13. In the Replenishment System field, click the AssistButton and 
click Prod.Order. 

14. Click the Planning tab.  

15. In the Reordering Policy field, click the AssistButton and click 
Lot-for-Lot. 

16. Select the Include Inventory check box.  

17. Repeat the above steps for Item 2 and Item 3, based on the 
information provided.  

Test Your Skills − Production BOM (CH6) 
Scenario: It is now time to create a Production Bill of Material for the wooden 
table that your company manufactures. Remember that your "Table, Complete" is 
the end item or parent part number. Except for service or repair parts, sales orders 
will normally be for the Table, Complete. 

Step-by-Step 
 

1. On the Manufacturing menu, click PRODUCT DESIGN→PRODUCTION 
BOM. 

2. Press F3 to insert a new Production BOM. 

3. In the No. field, type TYS001. 

4. In the Description field, type Table, Complete. 

5. In the Unit of Measure Code field, click the AssistButton and click 
PCS. 

6. In the Status field, leave New. 

7. Click in the lines section. 

8. In the Type field, leave Item. 
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9. In the No. field, type TYS002. 

10. In the Quantity per field, type 1. 

11. Press ARROW DOWN to go to the next available line. 

12. In the Type field, leave Item. 

13. In the No. field, type TYS003. 

14. In the Quantity per field, type 4. 

15. In the header, in the Status field, click the AssistButton and click 
Certified. 

16. On the Manufacturing menu, click PRODUCT DESIGN→ITEMS.  

17. Locate Item No. TYS001 − Table, Complete. 

18. Click the Replenishment tab. 

19. In the Production BOM No. field, type TYS001. 

20. Press ENTER or TAB. 

Test Your Knowledge − Other Functional Areas (CH7) 
1. What is the purpose of Contact Management? With Contact 

Management, you can maintain an overview of your contacts 
and record your contact information for all your business 
relations. For each contact you can specify the individual contact 
people you have at the contact company. You can categorize 
your contacts based on your own profiling criteria.  

2. What is the purpose of Opportunity Management? Opportunity 
Management assists in keeping track of sales opportunities. 
Salespeople have an overview of what is in the pipeline and can 
plan ahead accordingly. Opportunity Management helps you 
divide your sales process into different stages. 

3. How many resources may be in a resource group? An unlimited 
number of resources can be in a resource group. 

4. In Jobs and Resources, what allows you to post job usage of 
resources; apply entries to Phases, Tasks and Steps; and apply job 
ledger and item ledger entries? Job Journals 

5. What area of Service Management is used to automate service-
oriented tasks? Job Scheduling 

6. Describe how Service Contract Management can be used. Service 
Contracts allow you to setup a service agreement with your 
customers. You can gain access to contract history and contract 
renewal quickly using Service Contracts. Service Contracts also 
enable flexible invoicing, contract profitability management and 
contract quotes. 
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7. eCommerce is divided into two parts. What are they? Commerce 
Portal and Commerce Gateway. 

8. In eCommerce, what functionality allows you to set up BizTalk 
partners from within Microsoft Navision? Commerce Gateway 

9. What is Business Notification used for? The Business Notification 
solution is used to generate and send notifications to inform your 
vendors or colleagues from other departments about certain 
events. 

10. There are two approaches to generating Business Notifications. What 
are they? Time-based and field change-based. 

11. List the major functional areas found in Human Resources. 
Employees, Absence Registration and Reporting. 
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APPENDIX B: TERMINOLOGY LIST 
The section contains an alphabetical list of some of the common terms used in 
Microsoft® Business Solutions−Navision® and within this manual. 
 
Active − Used to describe the window or button that is being used or is selected. 
Only one window or one button can be active at a time. When a window is 
active, the color of the title bar changes to assist you in determining which 
window is active. When a button is active, the name changes color. 
 
Application Area − One of the main functional areas of the program in which a 
user selects to work, e.g. General Ledger, Inventory, etc. 
 
Application Window − The window in the program on which the rest of the 
work in the program is based. In Navision, it is the empty area where all 
windows are opened, and where the program, company and database names 
appear, as well as the menu bar and Toolbar. 
 
Arrow Keys − A group of keys on the keyboard used to move up, down, to the 
right and to the left; these keys can be used instead of the mouse to move through 
the program. 
 
AssistButton − One of four buttons that are accessed using the F6 function key; 
Drill-down, Look Up, Options  and Ellipsis.  
 
Backup − A file you create which contains a copy of your data. 
 
Batch job − A routine that processes selected entries according to general or 
specific guidelines. Examples include Close Income Statement. 
 
BLOB − An acronym for Binary Large Object, used to store bitmaps such as a 
logo. 
 
Boolean − A data type that is used to indicate one of two values: TRUE or 
FALSE; a typical use may be in a Check Box field.  
 
Browse − Move within a window or from window to window on the screen, one 
way to browse would be to use the recorder buttons. 
 
Button − Buttons are found in almost all of the windows and dialog boxes in the 
program. They may be Ordinary buttons such as OK, Yes and No. They may be 
Function buttons which initiate a function, batch job or report. In addition, there 
are Menu buttons which have a downward-pointing triangle on them and they are 
found on the majority of windows. When clicked, they display a menu from 
which you can, for example, select a function, open a different window or open a 
submenu. 
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Card Windows − A data view which shows information about one customer, 
vendor, item, etc. Card Windows generally have a series of tabs at the top. See 
Tabular Window. 
 
Check Boxes − Boolean fields that are used to indicate a function is turned on 
when checked and not turned on if left blank. 
 
Clear − To clear something means to delete it; it may be used for a field or a 
complete line. 
 
Close − Used to exit a window or the program; accessed by pressing ESC, 
clicking FILE→CLOSE or by clicking the X button in the upper right hand corner of 
a window. 
 
C/OCX − An interface used to expand the C/Side development environment. 
This may include OLE or OCX controls. 
 
C/ODBC − A tool used to export accounting information from into other 
programs that then are used to perform graphical analysis and word processing 
functions; Open Database Connectivity. 
 
Codeunit − A function that performs a process, such as posting or creating 
orders. One of seven Object types in Navision. 
 
Command Button − Buttons which initiate a function, batch job or report. 
 
C/SIDE − The Navision development environment. 
 
Database − Where all the information in is stored; it includes customizations for 
your company. 
 
Dataport − A method of importing or exporting information in and/or out of 
Navision. One of seven Object types in Navision. 
 
Debugger − A tool used to diagnose where an error message or error is occurring 
in Navision. Accessed under TOOLS→DEBUGGER. 
 
Designer − The interface used to modify or design additional forms, reports, 
tables, dataports, XMLports, codeunits, and menusuites for Navision. You must 
purchase special permissions to be able to use designer. 
 
Dialog Box − Windows that display to obtain more information on an action that 
you want to start.  
 
Dimension − Data that you can add to an entry so that Navision can group 
entries with similar characteristics and easily retrieve these groups for analysis 
purposes.  



 

 

Appendix B: Terminology List 

Page 187 

Documents − A report that prints one transaction at a time. Documents are 
normally sent outside your company to Vendors, Customers or Tax Reporting 
Authorities. 
 
Drill Down − One of four types of AssistButtons. The downward arrow indicates 
the value in the field is calculated from another table; clicking on the arrow 
allows you to view that table. 
 
Ellipsis Button − One of the four types of AssistButtons. Ellipsis Buttons are 
used to view system-filtered options. 
 
Field − Used to enter or display information; consists of a field name, definition 
and field contents. 
 
Field Filter − A filter that is set on a single field in a table, limiting the amount 
of information displayed or printed. 
 
Filters − A tool that allows the user to limit the scope of information presented 
online or in printed format; the three filters are Field, Table and Flow. 
 
Flow Filter − A filter which limits the amount of information presented based on 
a value that posted with the entries. Flow Filters are set on fields that end with 
the word Filter.  
 
Focus − Where the cursor is placed in Navision, also see Insertion Point. 
 
Form − Displays information on the screen and gives access for editing, deleting 
and adding data in either a card or tabular form. One of seven Object types in 
Navision. 
 
Function Keys − Each of the function keys has a shortcut assigned to it and 
using the combination of the CONTROL or SHIFT key with a Function key 
provides additional shortcuts. The availability of the various shortcuts is screen 
dependent, this may be reviewed by accessing Help, Overview of F Keys 
(ALT+F1). 
 
Granule − A basic building block of Navision allowing firms to purchase only 
the functionality they need. 
 
HTML − An acronym for hypertext markup language, a format widely used on 
the web. 
 
Inline Editing − Used to change the contents of selected fields in posted entries; 
accessed by clicking F2 twice.  
 
Insertion Point − The spot where text is entered when it is typed. Normally 
appears as a blinking vertical line in a window or a dialog box. Also called the 
cursor because the blinking vertical line is one form the cursor can take. 
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Invoice − An original entry document in Purchases and Sales allowing 
information to be recorded and posted for purposes of recording amounts due 
to/from Vendors and Customers. Invoices differ from Orders in that Receiving 
and/or Shipping are not done from an Invoice. 
 
Key − A field or combination of fields in a table that may be used to sort the 
table. 
 
Ledger Entries − Posted activity linked to a table. 
 
License − A file containing a record of the Navision granules purchased by your 
company; may be viewed by selecting TOOLS→LICENSE INFORMATION.  
 
List − A data view which has multiple records per window, displaying 
information about several customers, vendors, items, etc. at one time; another 
way of describing a Tabular Window. The List button is accessed from a Card 
view by selecting the List button from the Toolbar. See also Tabular Window. 
 
Look Up − One of four types of AssistButtons. The upward arrow indicates this 
is a way to view another table; once viewed, data may be retrieved and inserted 
into the field you accessed the table from. 
 
Master Item − The primary table in a granule, around which that granule 
functions. For instance, Customers are the Master Item in Sales; Vendors in 
Purchases; and Contacts in Marketing. 
 
Menu Bar − Located just below the Title Bar; this standard Windows feature 
contains pull-down menus to select functions such as creating new companies, 
design tools, and help. 
 
Menu Button − Have a downward-pointing triangle on them and they are found 
on the majority of windows. When clicked, they display a menu from which you 
can, for example, select a function, open a different window or open a submenu. 
 
MenuSuite − The MenuSuite object contains the menus that are displayed in the 
Navigation Pane and in the Navigation Pane Designer. Each menu contains 
content for a specific departmental area, for example, Finance or Manufacturing. 
One of seven Object types in Navision. 
 
Navigate − A function that allows the user to view a summary of the number and 
type of entries related to the document. When you select the entry you want in 
the table and click Navigate, you will see a list of the records - grouped according 
to table - that have the same document number and the same posting date as the 
entry you selected. 
 
Navigation Pane − When you open Navision, the Navigation Pane will appear 
on the left side of the Application Window. The Navigation Pane lists options 
that allow you to choose the application area, such as Financial Management and 
Sales & Marketing. 
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Object Designer − The interface used to modify or design additional forms, 
reports, tables, dataports and codeunits. 
 
Objects − The building blocks of Navision. There are seven types of objects: 
Forms, Tables, Reports, Dataports, Codeunits, XMLports, and the MenuSuite.  
 
ODBC − An acronym for Open Database Connectivity. ODBC enables Navision 
to be linked and data copied to Excel, Crystal Reports, etc. 
 
Option Button − A circular field which serves to select only one option from 
those listed. Clicking in this field indicates the desired choice. 
 
Option List − One of four types of AssistButtons. The Option List is a short, 
predefined list from which the user selects the desired choice.  
 
Order − An original entry document in Purchases and Sales allowing 
information to be recorded and posted for purposes of recording amounts due 
to/from Vendors and Customers. Orders differ from Invoices in that Receiving 
and/or Shipping are done from an Order. 
 
Passwords − Necessary when security has been setup; used in combination with 
the User Id to log into Navision. Data entry in Navision is case sensitive in the 
Password field. 
 
Primary Key − A field in a table that is used to identify the record in the table 
and is therefore required to have a unique value. 
 
Pull-Down Menu − A listing of options available from a menu button or menu 
item. 
 
Purchase Invoice − Used to record vendor bills that do not have inventory items 
on them, vouchers would be recorded here. 
 
Record − One line of a table, for example a single Customer in a listing. A 
record contains multiple fields and a table contains multiple records. 
 
Record Indicator − Appears to the left of the record you are focused on in a List 
or Tabular Window. 
 
Recorder Buttons − A series of buttons on the Tool Bar that are used to move 
through a list of records.  
 
Reports − A printout of information from the database; reports are generally 
used internally by management. One of seven Object types in Navision. 
 
Restore − A process whereby you create a database and populate it with the 
information held in your backup file.  
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Request Form − The form that is displayed prior to printing or previewing a 
report that allows the user to set filters and select options prior to printing. 
 
Shortcut Key − A keystroke or keystroke combination that moves to another 
screen or function within Navision. 
 
Sort − The ability to change the order in which records are displayed or printed. 
 
SQL − Structured Query Language. 
 
Status Bar − Located at bottom of the application window; it shows the name 
and contents of the active field, work date, user ID, and whether a filter 
(FILTER), insert (INS), or overwrite (OVR) mode is on. 
 
System Date − The date of your computer. 
 
Table − A table consists of a group of related records, each record is made up of 
fields and each field holds one piece of information; one example of a table is the 
entire listing of Vendor records. One of seven Object types in Navision.  
 
Table Filter − This option enables you to set multiple Field Filters on a table, 
limiting the amount of information displayed or printed.  
 
Tabular Window − A data view that has multiple records per window, 
displaying information about several customers, vendors, items, etc. at one time. 
See also Card Window and List. 
 
Text Box − A small box in a dialog box or window; it is used for entering 
information necessary for the execution of a command. 
 
Title Bar − Located at the top of the screen; displays the name of the company 
you are currently working in and the name of program (Navision). 
 
Toggle Mark (CTRL+F1) − A function that allows you select certain records 
for viewing, posting, etc. When selected, a diamond appears in front of the 
Record Indicator of the record you are on. If you move off of the record, the 
diamond remains. You may limit your view by selecting VIEW→MARKED ONLY. 
 
Toolbar − Located just below the Menu Bar; contains a row of iconic buttons to 
give quick access to frequently used functions such as editing, filtering and 
locating data.  
 
TrendScape Window − A form in Navision that allows the user to view a 
summary of data by a time period, such as by day, week, month, quarter or year 
or Accounting Period.  
 
Work Date − The date displayed in the Status Bar; may be set by accessing 
TOOLS→WORK DATE. If you do not change the Work Date, it will default to be 
your system date. 
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XMLports − The XMLport object is conceptually related to a dataport; you also 
use XMLports to import and export data, but in XML format. XMLports make 
the process of exchanging data in XML between systems more simple and 
streamlined. One of seven Object types in Navision. 
 
Zoom (CTRL+F8) − Allows you to view fields and the values for those fields 
which are not included in the current screen display.  
 
ZUP File − A file in which a user's specific screen modifications are stored, the 
file is named FIN.ZUP. 
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