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Preface 

PREFACE 
Welcome 

Training is a vital component of retaining the value of your Microsoft® Business 
Solutions investment. Our quality training created by industry experts keeps you 
up-to-date on your solution and helps you develop the skills necessary to 
maximize the value of your solution. Whether you choose Online Training, 
Classroom Training, or Training Materials, there is a type of training to meet 
your needs and learning style. Choose the training that best suits you so you can 
stay ahead of the competition. 

Online Training 
Online Training delivers convenient, in-depth training to you in the comfort of 
your own home or office. Online training provides immediate access to training 
24 hours a day. It is perfect for the customer who does not have the time or 
budget to travel. Our newest online training options, eCourses, combine the 
efficiency of online training with the in-depth product coverage of classroom 
training, and provide at least two weeks to complete each course. 

Classroom Training 
Classroom Training provides serious, in-depth learning through in-class 
interaction. From demonstrations to presentations to classroom activities, you 
gain hands-on experience with instruction from our certified staff of experts. 
Regularly scheduled throughout North America, you can be sure to find a class 
convenient for you. 

Training Materials 
Training Materials enable you to learn at your own pace, on your own time, with 
information-packed training manuals. Our wide variety of training manuals 
feature an abundance of tips, tricks, and insights you can refer to again and again. 
 
Microsoft Business Solutions Courseware: These detailed training materials 
are designed by experienced trainers. These manuals include basic through 
advanced topics as well as training objectives, exercises, interactions, and 
quizzes.  
 
Look for a complete list of manuals available for purchase on the Microsoft 
Business Solutions website: www.microsoft.com/BusinessSolutions. 
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Microsoft Business Solutions Courseware Contents 
Test Your Knowledge 
Within the Microsoft Business Solutions Training Courseware you may find Test 
Your Knowledge review questions to reinforce learning concepts. Review 
questions are located at the end of the chapter and the answers to these questions 
can be found in Appendix A, which is located at the end of the manual. 

Exercises 
Within the Microsoft Business Solutions Training Courseware you find a variety 
of exercises. The exercises in this course are based on the demonstration Web 
portal installed with Commerce Portal and the demonstration data provided by 
Microsoft Business Solutions. 

Quick Interaction: Lessons Learned 
At the end of each chapter within the Microsoft Business Solutions Training 
Courseware there is a Quick Interaction: Lessons Learned page. This interaction 
is designed to provide the student with an opportunity to reflect on the material 
they have just been exposed to. By outlining three key points from the chapter, 
the student can maximize knowledge retention, and provide themselves with an 
excellent resource for review.  
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Student Objectives 
What do you hope to learn by participating in this course? 
 
List three main objectives below. 
 
1. 

 

 

 

 

 
2. 

 

 

 

 

 
3. 
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Chapter 1: Introduction  

CHAPTER 1: INTRODUCTION 
 

• Overview 
• Commerce Portal Course Prerequisites 
• Overview of Commerce Portal  
• Key Features of Commerce Portal 

 

Overview 
This chapter provides basic background information about Microsoft® Business 
Solutions−Navision® Commerce Portal. 
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Commerce Portal Course Prerequisites 
Before using this course, you must install Microsoft Navision, Commerce Portal 
and a number of Microsoft products. These products provide the functionality 
needed to practice using Commerce Portal. 

Microsoft Products 
All Microsoft products must be installed and configured before you can use 
Commerce Portal. For instructions on how to install and configure these 
products, see the manual Installation & System Management: E-Commerce 
Solutions. 
 
The following Microsoft products must be installed: 
 

• Microsoft® Windows® 2000 Server, Service Pack 3 
(Check to make sure that you have installed the components for 
Microsoft Message Queuing Services.) 

• Microsoft® Internet Information Server 5.00 (included with 
Windows 2000 Server) 

• Microsoft® SQL Server® 2000, Service Pack 3 + Analysis Services, 
Service Pack 3 

• Microsoft® Internet Explorer 5.5, Service Pack 1 
• Microsoft® XML 3.0, Service Pack 2 
• Microsoft® Commerce Server 2000, Service Pack 2 
• Microsoft® Business Solutions−Navision® Database Server 4.0  
• Microsoft® Business Solutions−Navision® Client 4.0 
• Microsoft® Business Solutions−Navision® Application Server 4.0 
• Commerce Portal Web Integration Components 4.0 

 
NOTE: You must install non-localized versions of all the Microsoft products. 

 

Microsoft Navision 
You must install and configure a Navision server, a Navision client and a 
Navision Application Server before you can begin using this course. For 
instructions, see the manuals "Installation & System Management: Microsoft 
Business Solutions−Navision Database Server" and "Installation & System 
Management: Microsoft Business Solutions−Navision Application Server."
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Commerce Portal 
You need to install Commerce Portal. For instructions, see the manual 
"Installation & System Management: E-Commerce Solutions." 
 
All the necessary ASP files that are the basis of the demonstration Web portal in 
Commerce Portal are installed automatically when you install Commerce Portal. 

Overview of Commerce Portal 
The following picture illustrates how Microsoft Navision and the installed 
Microsoft products are linked together. 
 

 
 

Clients 
There are two sets of clients involved in using Commerce Portal: 
 

• Microsoft Navision clients that are connected to your company's 
local area network and are used by you and your colleagues. 

• Web browsers that are connected to the Internet and are used by the 
users of your Web portal. 

 
Microsoft Navision clients do not have to be dedicated specifically to the 
Commerce Portal. These clients can act as normal Microsoft Navision clients 
because all information requested or created through the Internet on your Web 
portal is processed like any other information in Microsoft Navision. 
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Web browser clients can be of any type and can be started from any platform. 
The design of your homepage determines the requirements for Web browsers, for 
example, whether or not Web browsers have to support frames. 

Communication 
All communication between Microsoft Navision, Microsoft Commerce Server, 
and Microsoft SQL Server is done using Microsoft Message Queue Server.  

Services 
All data is maintained in Microsoft Navision. Data used in the Web portal is 
synchronized with Microsoft SQL Server. After the first synchronization is 
carried out, the SQL Server is synchronized every time you update information in 
Microsoft Navision that is relevant for the Commerce Portal. For example, 
changing the name of an item automatically creates a message that updates the 
item name in the SQL Server database. 
 
When a user who is signed in on your Web portal requests information about a 
specific item, the static data − such as item number and item name − is retrieved 
from the SQL Server database. In comparison, the variable data − such as item 
price and item availability − is retrieved from the Microsoft Navision database. 
 
When a user who is not signed in browses your Web portal and requests 
information, or when a connection with the Microsoft Navision database cannot 
be made, only information available on the SQL Server will be retrieved and 
shown to your Web portal user. A connection cannot be made if Navision 
Database Server or Navision Application Server is not running.  
 
You can read more about how to synchronize the Microsoft Navision database 
and the SQL Server database later in the course.  
 
Microsoft Internet Information Server and Microsoft Commerce Server provide 
functionality that allows end users using Web browsers to access your Web 
portal and request and create information in Microsoft Navision. These requests 
are then passed on as messages, through the Message Queue Server to the SQL 
Server database and the Microsoft Navision database, which processes and 
replies to the messages. The Web portal users then receive an answer to their 
request, or a notification confirming the receipt of the information. 
 
A line of third-party payment solutions is available for Microsoft Commerce 
Server as plug-ins. These plug-ins provide a high level of security and make 
Commerce Portal very flexible. You do not have to choose one or two specific 
payment solutions − just install the payment solutions as needed. 
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Key Features of Commerce Portal  
This section describes some Commerce Portal features. Each of these features 
will be described more thoroughly in the following chapters. This chapter 
provides only a brief introduction to each feature to give you an enhanced 
overview of Commerce Portal. The following are key features of Commerce 
Portal:  
 

• Data is maintained only in Microsoft Navision. 
• You can create multiple websites. 
• You can define the permissions for your Web portal users based on 

roles. 
• You can set up automatic e-mail notifications to Web portal users 

and colleagues in connection with specific events in the process of 
handling a sales or purchase order.  

• You can set up specific language-dependent text and descriptions, to 
be used on your Web portal. 

• You can increase the efficiency of your purchasing activity by listing 
items you want to order on your Web portal and inviting your 
vendors to participate in a reverse auction. 

• Web pages are maintained from within Microsoft Navision. 
• Commerce Portal has full integration with the rest of the Navision 

Application. 
• Commerce Portal supports the picture formats GIF and JPG.  

 

Maintaining Data 
To work with Commerce Portal, Microsoft Navision users do not have to 
familiarize themselves with a new user interface. From Microsoft Navision, they 
can update the Web portal user and item information, handle sales quotes, sales 
orders, reverse auctions, and other similar activities. 
 
However, customer information on the Customer card and Contact card can also 
be maintained from the Web portal. For example, while you are visiting your 
customers. 
 
All data relevant to the Commerce Portal is synchronized with (copied to) the 
SQL Server database so that the data is actually stored in both the Microsoft 
Navision database and the SQL Server database. The program automatically 
synchronizes the SQL Server database and, subsequently, the Web pages on your 
Web portal with the Microsoft Navision database. 
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Multiple Websites 
With Commerce Portal, you can create multiple websites. For example, you can 
create a new website while the old one is still online. In addition, you can set up 
the templates for copying basic information to the different types of users on the 
website. You can also define which notification processes are to be used for the 
website. 

Roles and Permissions 
Commerce Portal allows you to create Web portal users, give them roles, and 
modify the rights of these users and roles from within Microsoft Navision. This 
means that several types of Web portal users can do business activities with your 
company or browse in your Web portal. Different roles have different 
permissions to perform different activities, such as business, maintenance, or 
administration activities.  

E-Mail Notification 
In Commerce Portal, you can set up various notifications. These notifications are 
used, for example, in the following circumstances: 
 

• To notify the users of your Web portal of specific events or of the 
status of their orders and offers, and of their new password and/or 
user ID. 

• To notify yourself or your colleagues of information entered by users 
of your Web portal. 

 
During processing of information entered by a Web portal user, you might want 
to send information or status reports to that user. This is done by setting up 
notifications for each step that the different information types can go through: for 
example, confirmation of a sales quote; shipping of a sales order; confirmation of 
an offer made on a reverse auction; or the creation of a Commerce Portal user ID 
and password. For each notification, you can write one or more texts that will 
automatically be sent to the customer via e-mail. For example, whenever a sales 
order is shipped, the Web portal user automatically receives an e-mail saying so. 
 
The same functionality is used to inform your colleagues of the creation of new 
Web portal users, new sales quotes, or new offers on reverse auctions. One of 
your colleagues or a group of your colleagues will then receive an e-mail, for 
example containing information about the new Web portal user, new sales quote, 
or new offer on the reverse auction. 

Multilanguage 
You can set up specific language-dependent text and descriptions to be used on 
your Web portal when the Web portal user's language is other than the standard 
language of your Microsoft Navision installation. Commerce Portal 
automatically uses the text and descriptions defined for the chosen language in 
the Multilanguage table and in the Item Translation table. 
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Reverse Auction 
You can ease your purchasing process by creating a reverse auction. A reverse 
auction is when you put a demand for purchasing products to one or more 
vendors on the Web portal. The participating vendors can then respond to your 
auction by placing an offer on the Web portal; stating delivery time, quantity, and 
price. 

Maintaining Web Pages 
When your Web portal is up and running you might want to make adjustments or 
changes. For example, you may want to change the welcoming text that greets 
the Web portal users when they open the first page of your Web portal. This is 
easily done from within Microsoft Navision. You do not have to change the text 
in the HTML code, nor do you need the assistance of an ASP programmer. You 
simply change the text as you would change the text in any other application area 
of Microsoft Navision. You can also change the pictures on your Web pages 
within Microsoft Navision. 

Integration 
Commerce Portal is fully integrated with the rest of the Microsoft Navision 
application areas. 
 
This means that if, for example, a new customer places an order through your 
Web portal their customer information will automatically be inserted in the 
Customer table in the Microsoft Navision database. When you set up your 
website, you define templates for each of your different types of Web portal 
users. The information on the templates will be copied to the new user. The 
templates can contain basic information that you want all new users created 
through your Web portal to have, as well as the permissions you want to grant 
them. 
 
If an existing Web portal user places an order through your Web portal, they 
receive all discounts that they are entitled to. In fact, everything will work just as 
if the order was entered manually in the Sales Quote window in Microsoft 
Navision. You can even grant trusted customers permission to create sales orders. 
Or, you can choose to reject or accept the sales quotes manually. 
 
By using their user ID and password, each Web portal user can sign in to your 
Web portal and view their previously entered information. For example, they can 
view orders, credit memos, offers on reverse auctions, and financial statements. 
Depending on how you have set up your Web portal, users can also reorder items 
on the basis of previous orders. It is also possible for Web portal users to monitor 
the status of their current orders or offers.  
 
There is no separate table for the items you sell through your Web portal. All 
maintenance and updating is done using the Item card in the Inventory 
application area of Microsoft Navision. So, whenever you update your prices, or 
the name or the availability of an item is changed, it will have an immediate 
effect on your Web portal. 
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An order placed on your Web portal is no different than one created from within 
Microsoft Navision; there is full integration with the general ledger through 
posting.  
 
A sales order placed by a Web portal user is posted like any other sales order in 
Microsoft Navision, and will therefore result in the same general ledger entries, 
customer ledger entries, item ledger entries, and so on. 
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Test Your Knowledge − Introduction to Commerce Portal 
 

1. Before you can begin this course you must install _______________, 
_________________, and a number of _______________________. 

 
 
 

2. Name the two sets of clients involved in using Commerce Portal and 
describe their functions. 

 
 
 

3. Briefly describe some of the synchronization features between 
Microsoft Navision and Commerce Portal. 

 
 
 

4. Name a few of the key features of Commerce Portal. 

 
 
 

5. Do users need to learn a new interface in order to use Commerce 
Portal? Please explain how data can be maintained in Microsoft 
Navision and Commerce Portal. 

 
 
 

6. Explain when an email notification might be used. 

 
 
 

7. Briefly describe some of the integration between Microsoft Navision 
and Commerce Portal. 
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Quick Interaction: Lessons Learned 
Take a moment to write down three Key Points you have learned from this 
chapter: 
 
1. 

 

 

 

 

 
 
2. 

 

 

 

 

 
 
3. 
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CHAPTER 2: SETTING UP COMMERCE PORTAL 
 

• Overview 
• Setting up Commerce Portal 
• Setting up Navision Application Server  
• Setting up a Website  
• Setting up Web portal Roles and Permissions  
• Setting up Notification Processes  
• Setting up Web Templates 

 

Overview 
After you have completed the installation of the required Microsoft® Business 
Solutions−Navision® products and Microsoft Navision servers and clients, there 
are a number of parameters in the Microsoft Navision Commerce Portal 
application area that you have choose. This chapter describes how to set up 
Microsoft Navision Commerce Portal. 
 

NOTE: Be sure that one instance of Navision Application Server is installed prior to 
beginning this chapter. 
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Setting up Commerce Portal 
Before starting to use Commerce Portal, you must enter certain basic setup 
information that will apply to all of your websites. You also have to set up a 
website, roles, notification processes, Web Templates, synchronization, requests, 
and the Navision Application Server. These topics will be described in the 
following sections.  
 
The following diagram illustrates the framework on which Commerce Portal is 
built. 
 

 
 
Setting up Commerce Portal includes: 
 

• Information about your country, local currency, and decimal symbol. 
• Information about where to store pictures on the Web server as well 

as information used to communicate with the SQL Server. 
• Information about the number series in Commerce Portal. 
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The Commerce Portal Setup Window 
Follow this procedure to enter information in the Commerce Portal Setup 
window: 
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→COMMERCE PORTAL SETUP. The Commerce Portal Setup 
window appears. 

 Microsoft Navision does not use a currency code to specify the local 
currency (LCY). The local country and language are not set up and 
are represented by blank fields. In order to give your Web portal 
users the choice of your local currency and language, you must 
specify these in the relevant fields on the General tab. 

2. On the General tab, in the Currency Code field, enter the LCY 
code from the General Ledger Setup window. When a user signs in 
to your Web portal using their user ID and password, the currency 
code on the customer or Vendor card determines which currency is 
used. If the Currency Code field on the customer or Vendor card is 
blank, the code that you specify here is used. 

3. In the Currency Description field, enter a description of your local 
currency. The Web portal user selects, from a list, the currency that 
they would like prices to be displayed and invoiced in. This list is 
based on the Currencies window in Microsoft Navision, but because 
the local currency is not defined there, the description you enter here 
will be used as the LCY. 

 The same principle applies to the next fields. Because your country 
and language is not defined in the Country table and Language table 
in Microsoft Navision, the description you enter here defines your 
default country and language. This information appears on the list 
from which the Web portal user must select their country and 
language. 

4. In the Decimal Symbol field, enter the decimal symbol you have 
selected in your Windows regional settings. The content of this field 
defines the decimal symbol of the data synchronized to the SQL 
Server. 

5. Click the Communication tab. 

6. In the Picture Target Folder field, enter the path and name of the 
folder on the Web server where you want Microsoft Navision to save 
your pictures. 

 Commerce Portal uses this path to save pictures on the Web server 
converted to GIF or JPEG format. The pictures displayed on your 
Web portal are not actually saved in the SQL database. Due to 
performance considerations, Microsoft Navision saves the pictures 
like any other file, in the file system on the Web server. 
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 The first part of the path, also referred to as the virtual root, 
corresponds to the Web publishing home directory defined during 
installation and configuration of the Microsoft Internet Information 
Server. Attached to this path is the path of the subdirectory in the 
virtual root, where the pictures are saved. 

 Pictures for use on your Web portal can be maintained in Commerce 
Portal. 

7. In the Data Source field, specify the SQL Server Instance name. If 
you are running your Web portal on the same server as your SQL 
Server the name must be localhost.  

8. In the Initial Catalog field, enter the name of catalog that is used on 
your Web portal.  

9. In the SQL User ID field, enter the SQL user ID that the 
synchronization service must use to connect to the SQL Server.  

10. In the SQL Password field, enter the password of the SQL user ID. 

11. Click the Numbering tab. 

12. In the Picture Nos., Contact Nos., and the Reverse Auction Nos. 
fields, enter a number series. This is done in the same way, as you 
would define any other number series in Microsoft Navision. 

Exercise − Changing the Password for SQL Server Logon 
In this exercise, you change the security settings to match the SQL Server 
settings. 
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→COMMERCE PORTAL SETUP. The Commerce Portal Setup 
window appears. 

2. Click the Communication tab. 

3. In the SQL Password field, enter a new password for the SQL User 
ID.  

4. Restart Navision Commerce Portal Synchronization service. 

The password you entered must be the same as the password registered on the 
SQL Server. Otherwise, you experience a lot of error messages in the Error 
message queue (Microsoft Message Queuing). 
 
For this training session, the SQL Server probably does not have a password for 
the sa account so you should clear the password settings that you just made. You 
should never use the sa account in real life, instead create your own SQL 
database account with Commerce Portal database rights. 
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Setting up Navision Application Server 
For your Web portal to communicate with Microsoft Navision the following 
communication components must be defined in Microsoft Navision: 
 

• Navision Application Server 
• Synchronization 
• Request 

 

Setting up the Navision Application Server 
In Commerce Portal, the Navision Application Server is used to handle the 
communication between Microsoft Navision and the Web portal. You can set up 
one or more application servers to handle the communication. In the Application 
Server Card window you define which part of the communication the application 
server handles. 
 
If you only have a limited number of messages sent between Microsoft Navision 
and your Web portal every day, one application server can handle all the 
communication. You must define setup codes for synchronization, requests, and 
mail, all on one application server. 
 
But if you have a high load of communication, you can ensure a high 
performance by installing more than one application server; for example, by 
dedicating one application server to handle only the requests from the Web 
portal. 
 
In the Application Server Card window, you can also define if you want the 
communication to be logged. In the Log Requests field, insert a check mark so 
that the program will log the messages that are defined in the Message Log Setup 
List window. If you insert a check mark in the Log Synchronization field, all 
synchronization of data from Microsoft Navision to the SQL database will be 
logged. 
 
You can read more about installing the Navision Application Server in the 
"Microsoft Business Solutions−Navision Installation & Configuration" manual. 

Setting up Synchronization 
On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→SYNCHRONIZATION. The Synchronization Setup Card window appears. 
 
In the Synchronization Setup Card window, define message queues to handle the 
synchronization from Microsoft Navision to your Web portal, as well as the label 
registry key and how often the program will check whether to synchronize data 
to the SQL database. 
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Setting up Requests 
On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→REQUEST. The Request Setup Card window appears. 
 
In the Request Setup Card window, define how you want the requests and the 
replies to your Web portal handled by the message queues. You must define an 
incoming queue to take care of the requests from your Web portal, and define an 
outgoing queue to take care of the replies sent from Microsoft Navision to your 
Web portal. You must also define a label registry key for where to find labels and 
queue names and you must enter the length of time that replies can remain in the 
queue before they are deleted. 

Setting up Mail 
In the Mail Setup Card window, define how you want your out-going e-mails to 
be handled. You can define the time interval at which the program will check 
whether any e-mails are waiting to be processed and whether the queue is open to 
send e-mails or not. You can set up the mail queue to prioritize the mails 
according to the priority on the Contact Card.  

Setting up the Log 
On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→MESSAGE LOG. The Message Log Setup List window appears. 
 
The Message Log Setup List window contains all the message types that can be 
sent between Microsoft Navision and your Web portal. You can define which 
messages you want to be logged and in which direction. A check mark in the Log 
Requests field in the Application Server Card window activates the logging.  

Exercise − Enabling Logging of Synchronization 
Messages 
In this exercise, you enable the logging of messages sent to the Commerce 
Server. To verify that the synchronization messages are sent correctly to the SQL 
Server, you can enable the logging.  
 

1. Open the Application Server Card window. 

2. Click the Actions tab. 

3. In the Log Synchronization field, select the option. 

 After you have enabled the logging of Synchronization messages, 
you need to restart the Navision Application Server service in order 
to see the messages. 

4. To see the Synchronization messages, on the Administration menu, 
click IT ADMINISTRATION→COMMERCE PORTAL→COMMUNICATION→ 
MESSAGE LOG. The Message Log window appears. 
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Setting up a Website 
After you have set up the general information for Commerce Portal, you are 
ready to set up any number of websites, each of which can have a different 
layout, sell different items, or target different user groups. 
 
This diagram shows how the websites you create comprise your Web portal. 
 

 
 
To set up your website, you must create a website card containing the following 
information: 
 

• The address of your homepage. 
• The path to the ASP files on the Web server. 
• A quote expiration calculation formula. 
• The profiles of template users. 
• Notification codes and processes. 
• Number series for users and orders created through your Web portal. 

 

Exercises 
In these exercises, you create a new website. However, in order to allow your 
Web portal users to enter your Web portal while you are working on the new one, 
you must have your old website running. 
 
The layout of the new website will be identical to the old one, so in order to 
avoid retyping all the information, use the batch job request window to create 
your new website. 
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Creating a Website 
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→WEB SITES. The Web Site Card window appears. 

2. On the Edit menu, Insert New (or press F3) to insert a new website. 

3. On the General tab, in the Code field, enter an identifier, for 
example, New Home.  

4. To use the Copy Web Site batch job, click FUNCTIONS→COPY WEB 
SITE. The Copy Web Site batch job request window appears. 

5. In the Copy-from Web Site Code field, click the AssistButton to 
view a list of websites. The Web Site List window appears. 

6. Click the website that you want to make a copy of, for example, 
Home, and then click OK. 

7. In the Include Web Site Setup, Include Web Templates, and 
Include Web Pages fields, select the options. 

8. Click OK to start the batch job. 

9. When the batch job is complete, close the Copy Web Site batch job 
request window. 

10. Verify that all information has been copied from the Home website 
to your new website. 

Setting up Web Portal Roles and Permissions 
Commerce Portal allows you to create Web portal users, give them roles and 
modify the rights of these users and roles from within Microsoft Navision. 
 
In order to create Web portal users, you must give them an identity within 
Microsoft Navision that allows them to log on to your Web portal. When the user 
has logged on to your Web portal, they are able to perform tasks according to the 
permissions that they have been allocated. 

Permissions 
Each permission grants the Web user authorization to perform a task or a part of 
a task on your Web portal. All permissions are based on Microsoft Navision 
information and/or some functionality that will help the user perform a task. The 
permissions are predefined in Commerce Portal and can be assigned to the Web 
portal user as a part of a role. 
 

NOTE: You can add new permissions to the Permissions table. However, it is not 
enough to just do this. You must also have a programmer create a new function in the 
related codeunit and/or a new Web page that can handle the new permission. 
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Web Portal Roles 
Before you welcome your users in your Web portal, you must define which tasks 
your Web portal user must be able to perform, and afterward, create the roles 
according to this definition.  
 
A role is a collection of permissions that you can combine in any way that meets 
your needs. 
 
You can choose to set up a few general roles, each containing all the permissions 
for one user type, or you can set up a role for each task or part of a task that the 
users will perform and then customize each user's rights and possibilities. 

Exercise − Scenario 
You have decided that you will give some of your partners access to information 
about your inventory. In this exercise you create a new partner role and add the 
additional permissions to it. 

Creating a New Web portal Role 
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→WEB PORTAL ROLES. The Web portal Roles window will 
appear. 

2. On the Edit menu, Insert New (or press F3) to insert a new Web 
portal role. 

3. In the Code field, enter an identifier, for example prtnr2. 

4. In the Description field, enter Partner 2. 

5. Click the existing partner role named PRTNR. 

6. Click ROLE→PERMISSIONS. The Web portal Role Permissions 
window for PRTNR appears. 

7. Select all the permissions assigned to the PRTNR role and copy 
(CTRL+C) them. 

8. Escape back to the Web portal Roles window. 

9. Click your new role (PRTNR2) and click ROLE→PERMISSIONS.  

10. Paste (CTRL+V) the copied permissions into this role. 

11. Insert (F3) a new line.  

12. In the Code field, click the AssistButton. The Web portal 
Permissions List window appears.  

13. Locate and select the permission number 10058, Availability 
Numeric.  

14. Click OK to add the permission to the role. 
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Setting up Notification Processes 
When you create a website, you can choose a set of notification processes and 
codes to be used when certain events occur on your Web portal or in Microsoft 
Navision. These notifications can be divided into two groups: 
 

• Internal notifications − To notify you or your colleagues 
• External notifications − To notify your Web portal users 

 
A notification code identifies a number of text lines that can be sent by e-mail to 
your Web portal users or your colleagues. Basically, notification codes are a set 
of e-mail templates. 

Internal Notifications 
Internal notifications relate to you or your colleagues. The notifications are single 
notification codes, which are selected from the Web Site window. 
 
Microsoft Navision can send internal notifications: 
 

• To notify a colleague that a new customer has been created in 
Microsoft Navision through your Web portal. The notification code 
in the New-Customer Notif. field is used. 

• To notify a colleague that a new quote has been accepted in 
Microsoft Navision through your Web portal. The notification code 
in the New-Quote Notif. field is used. 

• To notify a colleague that a response to a reverse auction has been 
created in Microsoft Navision through your Web portal. The 
notification code in the Rev. Auct. Response Notif. field is used. 

 

External Notifications 
External notifications relate to your Web portal user. The notification codes are 
grouped in notification processes and can be selected from the Notification 
Process Code window. 
 
The notification processes can be defined on the Contact card, the vendor or 
Customer card, or on the Web Site card. 
 
If a notification process is specified on the Contact card of a Web portal user, 
then the user will be notified according to this. If you leave the Notification 
Process Code field on the Contact card blank, the user will be notified according 
to the Notification Process Code on the Vendor or Customer card. If you also 
leave the Notification Process Code fields on these cards blank, the user will be 
notified according to the Notif. Process Code field on the Web Site card. 
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Sales and Notifications 
Microsoft Navision can send the following external notifications connected to 
sales: 
 

• A notification to notify a Web portal user that you have received 
their order from your Web portal. At this point, the user's order is 
actually a quote in Microsoft Navision with the status Accepted by 
Customer. The notification code in the Quote-Received Notif. field 
is used. 

• A notification to confirm an order. This message is sent to your Web 
portal user when you make the quote into an order. The notification 
code in the Quote-Confirmed Notif. field is used. 

• A notification to notify a customer that you have rejected their quote. 
The notification code in the Quote-Rejected Notif. field is used. 

• A notification to notify a customer that you have shipped their order. 
The notification code in the Order-Shipped Notif. field is used. 

 
The following diagram shows the stages of a sales quote's life cycle and the 
notifications associated with each stage: 
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A notification process can be assigned to all your Web portal users. For more 
information see the section called "Assigning a Notification Process to a 
Customer" in Chapter 4, "Setting up Items and Customers"; and the section 
called "Assigning a Notification Process to a Vendor" in Chapter 5, "Working 
with Reverse Auction." 

Reverse Auctions and Notifications 
Associated with reverse auctions, Microsoft Navision can send the following 
external notifications: 
 

• To invite a vendor to participate in a reverse auction. The 
notification code in the Rev. Auct. Notif. field is used. 

• To notify a vendor that you have received their offer from your Web 
portal. The notification code in the Rev. Auct. Update Notif. field is 
used.  

• To notify a vendor that you have received their decline of the 
invitation to participate in the reverse auction. The notification code 
in the Rev. Auct. Decline Notif. field is used. 

• To notify a vendor that you have accepted their offer. The 
notification code in the Rev. Auct. Won Notif. field is used. 

• To notify a vendor that you have rejected their offer. The notification 
code in the Rev. Auct. Lost Notif. field is used. 

 

Passwords and Notifications 
Microsoft Navision can send an external notification to notify a Web portal user 
that you have created a password for them or a new user ID. The notification 
code in the Password-Created Notif. field is used. 
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Notification Symbols 
You can have the program automatically insert text from Microsoft Navision in 
the notification text. Do this by using specific symbols that the program replaces 
with values when you send the e-mail; for example, %08, %10, and so on, as 
shown in the screen shot below. 
 

 
 

Exercises 
In the following exercises, you create a new notification code and set up an 
alternative text for that notification code. 

Creating New Notification Codes  
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→NOTIFICATION CODES. The Notification Codes window 
appears. 

2. On the Edit menu, Insert New (or press F3) to insert a new 
notification code. 

3. For this example, in the Code field enter Training and in the 
Description field, enter CP Training. 

4. Choose the notification code you have just created. Click 
NOTIFICATION→TEXTS. The Notification Text window appears. 
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5. In the Language Code field, enter ENU. 

6. In the Subject field, enter the subject of the notification text and then 
fill in the text lines. For this example, enter Commerce Portal 
Exercise. 

7. In the Text section, enter the following: 

 
Line Text 
1 Hello! 
2 <blank> 
3 This notification code is a part of a solution to an exercise 
4 in the Commerce Portal Training Material. 

 

Creating Alternative Texts 
 

1. Click in the header of the Notification Text window and press F3 to 
insert a new notification text card. 

2. In the Language Code field, click the AssistButton, and then select 
a language code from the Languages window. Click OK. 

3. In the Subject field, enter your alternative subject and then fill in the 
text lines for the body of your e-mail message. 

4. In the header of the Notification Text window, select any of the 
fields, for example, the Starting Date field. Press F3 to insert a 
second notification text card. 

5. In the Starting Date and Ending Date fields, enter dates. 

6. In the Subject field, enter your alternative subject line text and then 
fill in some text lines for the body of your second e-mail message. 

7. Click TEXT→LIST (or press F5) to verify that all notification texts have 
been created. The Notification Text List window appears. 

 

Notification Processes 
Once you have created your notification codes, you can group them together in 
notification processes. You can then assign a notification process to one or 
maybe a group of your Web portal users. To read more about this, see the section 
called "Assigning a Notification Process to a Customer" in Chapter 4, "Setting up 
Items and Customers." 
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Creating Notification Processes 
To set up a notification process, follow this procedure: 
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→NOTIFICATION PROCESSES. The Notification Processes 
window appears. 

2. On the Edit menu, Insert New (or press F3) to insert a new 
notification processes card. 

3. For this example, in the Code field, enter New NP and in the 
Description field, enter New Notification Process. 

4. Leave the Salutation field set to Formal. 

5. Complete the remaining fields using the following information: 

 
Tab Field Value 
Sales   
 New Consumer Notif.  NEW-CONS 
 Quote-Received Notif. S-RECEIVE 
 Quote-Confirmed Notif. S-CONFIRM 
 Quote-Rejected Notif. S-REJECT 
 Order-Shipped Notif. S-SHIP 
Contact   
 Password-Created Notif. C-PASSWORD 
Revc. Auct.   
 Rev. Auct. Update Notif. RA-UPD 
 Rev. Auct. Decline Notif. RA-DECL 
 Rev. Auct. Won Notif. RA-WON 
 Rev. Auct. Lost Notif.  RA-LOST 
 Rev. Auct. Invitation Notif. RA-NEW 
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Setting up Web Templates 
A Web Template in Commerce Portal is similar to a template in a word 
processing application. It is a document that contains formatting and sometimes 
generic text or other content, however, most of the content remains to be filled in 
on the individual Web page. To read more about Web pages, see Chapter 3, 
"Setting up Web Pages." 
 
A website can contain any number of Web Templates. The following diagram 
shows how Web Templates make up a website: 
 

 
 
A Web Template can be used as a pattern for creating many Web pages. Each 
Web Template is based on an ASP page located on the Web server. The 
properties you choose to edit in Microsoft Navision appear on the Web Template. 
The fixed properties of a template can only be edited directly on the ASP page or 
the cascading style sheet. By using Web Templates, you can create new Web 
pages without having to do additional programming. 
 
You can fill in the value of each property you chose to edit with information 
from Microsoft Navision, and you can maintain your website from within 
Commerce Portal. For example, the values of these properties could be a 
hyperlink to another Web page for a link property, a picture for a picture 
property, or text for a text property. 
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Web Templates 
The Web Templates window gives you an overview of the templates you have 
defined for a website.  
 
To view the templates, on the Administration menu, click APPLICATION 
SETUP→COMMERCE PORTAL→WEB TEMPLATES. The Web Templates window 
appears. 
 

 
 
Each template is identified by a number in the Template No. field and a brief 
description in the Description field. The Web Templates can have a number of 
subproperties. The properties and subproperties form a hierarchy within the Web 
Template. This hierarchy can be seen in the Web Templates window. The lines 
written in bold text are root property collections. The indented lines, which are 
written in standard text beneath a root property collection, are its subproperties. 
 
Each of your websites has a separate set of Web Templates. To see a list of 
websites, in the Web Site field, click the AssistButton. The Web Site List 
window appears.  
 
Click OK to close the window. 
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Template Properties 
To see the template properties, click TEMPLATE→PROPERTIES. The Properties 
Template window appears: 
 

 
 
When you create a template, a number of template property lines will be created 
automatically. Each line corresponds to a property defined in the ASP file. 

Automatic Numbering 
Sometimes, when you make a Web Template, you cannot foresee how many 
properties (for example, lines of text) each Web page that is based on that 
particular template will need. An automatic numbering property appears once on 
a template, but you can duplicate it as many times as you want on the Web page. 
You can then enter a different value for each of the duplicated properties. 
 
For example, a single text property only represents one line of text (250 
characters). To define a paragraph with a flexible number of lines, it is necessary 
to use a text property with automatic numbering. 
 
In the Properties Template window, the program fills in the Code field with the 
name of the property in the ASP file. You cannot change the name of a property. 
The program also fills in the Description field, but you can change this. 

Template Property Types and Values 
Every property has a type and a value. In the Properties Template window, the 
contents of the Type field defines what kind of data the property can contain, for 
example, text or a number. The Value field contains the data itself, that is, the 
actual text or number. 
 
If you fill in the Value field on a template property line, the program enters it as 
the default value on all Web pages you create with the template. However, you 
can edit the value on each individual Web page. 
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The following table describes the seven property types: 
 

Type Value 
Text The Value field can contain text that will appear on the 

Web page. It can contain up to 250 characters. 
Date The Value field can contain a date that will appear on the 

Web page. 
Time The Value field can contain a time that will appear on the 

Web page. 
Number The Value field can contain a number that will appear on 

the Web page. 
Picture The Value field can contain the identification code of a 

picture. The code represents a link to a picture in the 
Picture List window. The picture will appear on the Web 
page. 

Link The Value field can contain the identification number of 
another page on the website. The link to the page referred 
to in this field will appear on the Web page. 

Subproperties The property has subproperties. That is, the property line 
represents an entire property collection. 
 
The contents of the Value field indicates whether or not 
the property's subproperties have been assigned a value. If 
the Value field contains Yes, the Value field on the 
subproperties has been filled in. If the Value field contains 
No, the Value field on the subproperties is blank. 

 
You cannot add a new template property line. If the ASP file has been updated 
with new properties, you have to create the Web Template again, and the 
properties of the ASP file will be imported. 

Creating Web Templates Requirements 
You MUST have an ASP programmer set up ASP pages to determine the 
structure and layout of your website. When you have completed the setup of your 
Commerce Portal and your website, you are ready to create Web Templates by 
running the Create Web Template batch job. 

Exercises 
In these exercises, you create a new template in your website. You will be using 
an existing ASP file to base the template on, so you actually create a copy of one 
of the other templates. 
 

NOTE: Before starting this exercise, you must have an ASP programmer create the 
ASP file addresses.asp. This file defines the names and types of the properties that will 
be imported into Navision and is used in step 5 of the exercise. 
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Creating Web Templates 
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→WEB TEMPLATES. The Web Templates window appears. 

2. Click FUNCTIONS→CREATE WEB TEMPLATE. The Create Web Template 
batch job request window appears. 

3. In the Template No. field, enter a unique template number, for 
example, T-EXERCISE. 

4. In the Description field, enter a brief description, for example, 
Training Material Exercise. 

5. In the ASP File Name field, enter addresses.asp. This is the file 
name of the ASP file you want to base your template on.  

6. Click OK to start the batch job. 

Verifying that the New Template has been Created 
 

1. To verify that the template was successfully created, in the Web 
Templates window, find and select the T-EXERCISE template.  

2. To view the properties of the template, click TEMPLATE→PROPERTIES. 
The Properties Template window appears. 

 
You can also view the properties in the addresses.asp file that you entered in step 
5. The PAGEPROPERTIES section at the bottom of the ASP file defines the 
names and types of the properties that will be imported into Microsoft Navision. 
If the name of the property is followed by .#, it means that the property will have 
subproperties. 
 
In the case of the addresses.asp file, four properties will be imported, three of the 
type Text and one of the type Link. It should appear as follows: 
 
<--PAGEPROPERTIES 
ORDERLIST.TEXT 
SHIPTOLIST.TEXT 
NEWADDRESS.TEXT 
LINK.LINK 
PAGEPROPERTIES--> 
 
When the name is followed by .#, the Description properties can consist of 
multiple lines of text, like for example, in reorder.asp file and the order.asp file. 
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Test Your Knowledge − Setting up Microsoft Navision 
Commerce Portal 

1. What are the two types of Notifications?  

 

 

2. What does setting up Commerce Portal include? 

 

 

3. What do you need in order to create new Web Templates? 

 

 

4. Before using Commerce Portal, what will you need to enter and set 
up? 

 

 

5. When setting up your website, what information must the website 
card contain? 

 

 

6. Briefly explain Web Templates. 

 

 

7. What are the four areas that the Commerce Portal framework is built 
upon? 

 

 

8. What are the seven property types found on the Properties Template? 
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9. What is the Navision Application Server used for with Commerce 
Portal? 

 

 

10. Define Permissions and Web portal Roles. 
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Quick Interaction: Lessons Learned 
Take a moment to write down three Key Points you have learned from this 
chapter: 
 
1. 

 

 

 

 

 
 
2. 

 

 

 

 

 
 
3. 
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CHAPTER 3: SETTING UP WEB PAGES 
 

• Overview 
• Creating Web Pages 
• Testing Hyperlinks 
• Adding Pictures to your Web Portal 

 

Overview 
This chapter describes how to set up Web pages in Microsoft® Business 
Solutions−Navision® Commerce Portal and how to verify that all links are valid. 
This chapter also describes how to add pictures to your Web pages. 
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Creating Web Pages 
Once you have set up Web Templates for use in each of your websites, you are 
ready to create the actual Web page. Each of your Web pages is based on a Web 
Template. This also means that you can create a number of Web pages based on 
the same Web Template. These Web pages will make up your Web portal. 
 
The following diagram illustrates the relationship between the different elements 
of the Web portal. 
 

 
 

Web Pages 
Each of your websites has its own set of Web pages and Web Templates. Each 
Web page has a set of properties defined by the Web Template. Therefore, you 
cannot add additional properties to a Web page. 
 
When you create a Web page, a number of property lines will be created. Each 
line corresponds to a property line defined in the Web Template on which your 
Web page is based. 
 
After the Web page has been created, you need to fill in or adjust the values of 
the properties. Note that when you create the Web page, the property lines are 
simply copied from the Web Template that you base your Web page on. You can 
create any number of Web pages based on one Web Template; therefore, you 
might want to customize the values of the properties on each Web page.  
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Exercise − Creating New Web Pages 
In these exercises, you create a new Web page on your website. You will be 
using an existing Web Template, so you will create a new Web page that is 
similar to one of your other Web pages. You will then fill in additional 
information to specify the Web page properties to complete the Web page. 
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→WEB SITE→WEB PAGES. The Web Pages window appears: 

 

 
 

2. Click FUNCTIONS→CREATE WEB PAGE. The Create Web Page batch job 
request window will appear. 

3. In the Page No. field, enter a unique Web page number, for example, 
EXERCISE.  

4. In the Description field, enter a short description, for example, 
Training Course Exercise.  

5. In the Template No. field, click the AssistButton to view a list of 
Web Templates. The Web Template List window appears. 

6. In the Description field, find Sales Invoices. This will be the Web 
Template to base your new Web page on. Click OK.  

7. Click OK. 
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Exercise − Completing Web Pages 
The new page now appears in the Web Pages window.  
 

1. Click the Web page you have just created. 

2. To see the properties of the Web page, click PAGE→PROPERTIES. The 
Properties Page window appears: 

 

 
 

 The property lines from the template have been copied to the Web 
page. You can edit the contents of the Value field on each property 
line. One of the Web page property lines has subproperties and there 
is a No in the Value field. This means that you have to enter the 
values for the subproperties in order to complete the Web page. 

3. On the line with subproperties, click the Value field and then click 
the AssistButton in the field. A new property collection appears in 
the Properties Page window. 

4. In the Value field of the first line enter Training Course Exercise. 
You can use as many lines as you need to enter your text. Close the 
window. 

 The subproperties that contained No in the Value field now have Yes 
in the Value field. This means that you have assigned the property's 
subproperties a value. 

5. In the Properties Page window, directly in the Value field, fill in the 
other values of the properties using the following information: 

 
Description Type Value 
Btn_dates Text Search 
Date Text Document Date 
Dateformat Text (dd/mm/yyyy) 

Description2 Text 
Please select an invoice from the 
following list... 
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Description Type Value 
Link to Invoice Details Link INVOICEDETAIL 
Enddate Text End Date: 
Heading Text Sales Invoice Information 
Invalid Number Text Not a valid number. 
Matches to show Number 5 
Next Text Next %1 
No Text Document No. 

No Invoices Text 
You currently have no sales invoices 
registered on the system. 

Noofrecs Text No of records per page 
Previous Text Previous %1 
Results Text result(s) found. 
Startdate Text Start Date 

 
Once you have filled in values for the properties on the page, the page is 
complete. 

Exercise − Scenario  
You have decided to start running a news page on your Web portal in order to 
keep your customers informed about the latest news and events in your company. 
In these exercises, you create a new Web page where you can publish your 
company's news and events. You then add a menu item to the top menu to allow 
your customers to open your new page. 

Adding New Lines to Web Templates 
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→WEB TEMPLATES. The Web Templates window appears. 

2. Select the template number T-GLOBALTEXTPAGES, and then 
click TEMPLATE→PROPERTIES. The Properties Template window 
appears: 
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3. Click F3 to add a line for the description.  

4. In the Code field, enter a code for the template line, for example, 
descriptionnews.  

5. In the Type field, enter Subproperties. 

6. In the Value field, click the AssistButton. The Properties Template 
window for Descriptionnews appears. 

7. Select the Auto Number option. 

8. In the Code field, enter #. 

9. In the Description field, enter a short description, for example, 
Textline. 

10. Escape back to the Globaltextpages Properties Template window. 

11. Press F3 to add another new line, this time for the heading.  

12. In the Code field, enter a code for the template line, for example, 
headingnews. In the Type field enter Text. 

13. Close the Globaltextpages Properties Template window. 

Adding Extra Lines to Web Pages 
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→WEB SITE→WEB PAGES. The Web Pages window appears. 

2. Locate the GLOBALTEXTPAGES Web Page and click 
PAGES→PROPERTIES.  

3. Click the line you created for the description, in this case 
Descriptionnews. 

4. In the Value field, click the AssistButton. The Properties Page 
window appears. 

5. Enter the following text, noting that there will be three separate lines 
of text: 

 
Description Type Value 
Textline Text <H3>News&Events </H3><br> 

Textline Text 
CRONUS International Ltd. Commerce Portal is 
operational. 

Textline Text 
We are pleased to welcome new as well as 
existing customers. 

 
NOTE: Any valid HTML tag can be used to format text that will be displayed on a 
Web page on your storefront. The <P> tag in the Value field of the first Web page 
property line is an HTML tag that sets a line break. 
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Adding Menu Items on Your Web Portal Home Page 
You are now ready to add a menu item to the menu on your Web portal. 
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→WEB SITE→WEB PAGES. The Web Pages window appears. 

2. In the Page No. field, find GLOBALMENU. Select the property 
with the description Menu. 

3. Click PAGE→PROPERTIES. The Properties Page window appears. 

4. Click F3 to add a new line.  

5. In the Description field, enter News.  

6. In the Value field, click the AssistButton. The Properties Page 
window appears. 

7. On the first line, for Link, in the Value field, click the AssistButton. 
The Web Page List window appears. 

8. In the Page No. field, locate the GLOBALTEXTPAGES. This is the 
Web page your customer will see when they click the link. 

9. In the Value field of the second property line (Text), enter 'News and 
Events.' This will be the name of the link on your Web portal. Press 
ENTER. 

10. Close all open windows. 

Reloading Web Pages 
After you have added the new lines to the Web pages, you must reload the Web 
pages to the SQL Server. 
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→WEB SITES. The Web Site Card window appears. 

2. Click FUNCTIONS→RELOAD PAGE PROPERTIES. The program will now 
reload all changes made to the page properties. 

Adding Extra Lines to Web Pages 
For the changes you have made to take affect on your Web portal, you must edit 
the ASP page GlobalTextPages. The ASP page can be located in the folder 
indicated in the ASP File Folder field on the Web Site Card window. 
 
In the GlobalTextPages ASP page there are two Select Case statements. You 
must enter one new Case statement for the header and one for the content. The 
value in the Case statement must match the value you entered in the 
GLOBALMENU Web Page in Commerce Portal (in this case, NEWS AND 
EVENTS). 

Page 45 



 

 

Microsoft Navision Commerce Portal 

You must also enter the name of the properties in the page properties list in the 
ASP file (HEADINGNEWS and DESCRIPTIONNEWS). The screen below 
highlights the necessary changes: 
 

 
 
To verify that the new page has been added to your Web portal and that the Web 
pages refer to each other correctly, open your Web portal and browse to the Web 
page. 
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Testing Hyperlinks 
When you have finished creating all of your Web pages for your website, there 
will be a structure among the Web pages. The Web pages will refer to each other, 
using hyperlinks. The pictures on your Web pages are also referred to through 
links. 
 
There are two types of hyperlinks in Commerce Portal: 
 

• A link from one Web page to another. 
• A link to a picture. 

 
Before you allow customers into your Web portal, you can test that all hyperlinks 
refer to a Web page or a picture; that is, that the hyperlink is not broken. 
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→WEB SITE→WEB PAGES. The Web Pages window appears. 

2. In the Site field, click the AssistButton to select a website from the 
Web Site List window, and then click OK. 

3. Click WEB SITE→HYPERLINKS. The Hyperlinks window appears: 

 

 
 

4. The Hyperlinks window displays all of the properties for the website 
that have the type Link or Picture. 

5. The Page No. field contains the number of the Web page, and the 
Description field contains the description from the Web page 
property line. 

6. The Type field contains the type of the hyperlink: a link or picture. 
The Value field contains the actual link. 
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7. Click the hyperlinks you want to test. 

 
HINT: To select hyperlinks that are not sequential, press CTRL and then click each 
line. 

 
8. To start testing the selected hyperlinks, click FUNCTIONS→CHECK 

HYPERLINKS. A dialog box appears asking if you want to check 
selected hyperlinks. Click Yes. 

 When the program has completed the test, a window appears that 
tells you how many hyperlinks were tested and how many broken 
hyperlinks were found. 

9. Click OK. 

10. On the View menu, click Marked Only to view the broken 
hyperlinks that were found during the test. 

Exercise − Scenario 
In these exercises you test all hyperlinks on a website. You then delete one of the 
links and run the test again, and finally you reestablish the link. 

Testing all Hyperlinks  
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→WEB SITE→WEB PAGES. The Web Pages window appears. 

2. In the Site field, click the AssistButton to select a website from the 
Web Site List window, and then click OK. 

3. Click WEB SITE→HYPERLINKS. The Hyperlinks window appears. 

4. On the Edit menu, click Select All (or press CTRL+A) to select all 
hyperlinks.  

5. To start testing the selected hyperlinks, click FUNCTIONS→CHECK 
HYPERLINKS. A dialog box appears asking if you want to check 
selected hyperlinks. Click Yes. 

 When the program has completed the test, a window appears that 
tells you how many hyperlinks were tested and how many broken 
hyperlinks were found. 

6. Click OK. 

Changing Hyperlinks 
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→WEB SITE→WEB PAGES. The Web Pages window appears. 

2. In the Page No. field, find DEFAULT. 
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3. Click PAGE→PROPERTIES. The Properties Page window appears. 

4. On the property line for Local Menu, in the Value field, click the 
AssistButton. The Web Page List window appears. 

5. In the Page No. field, find the EXERCISE web page you created 
earlier and click OK.  

 The Local Menu property now has a hyperlink to the EXERCISE 
web page. 

6. Escape back to the Web Pages window. 

Deleting and Testing Hyperlinks 
 

1. Verify that your line indicator is on the DEFAULT Web page. 

2. Press F4 to delete the DEFAULT Web page. A message appears 
asking if you want to delete the Page Property Collection. Click Yes. 

 Test the hyperlinks again.  

3. On the Web Pages window, click WEB SITE→HYPERLINKS. The 
Hyperlinks window appears. 

4. On the Edit menu, click Select All (or press CTRL+A) to select all 
hyperlinks defined on your website. 

5. Click FUNCTIONS→CHECK HYPERLINKS. A dialog box appears asking if 
you want to check selected hyperlinks. Click Yes. 

6. When the program has completed the test, a window appears 
indicating how many hyperlinks were tested and how many broken 
hyperlinks were found. 

7. Click OK.  

8. To view the broken hyperlinks, on the View menu, click Marked 
Only. 

9. Do not close the Hyperlinks window. 

Reestablishing Hyperlinks 
 

1. In the Value field of the hyperlink, click the AssistButton. The Web 
Page List window appears.  

2. In the Page No. field, locate the LOCALMENU Web page.  

3. Click OK. 

4. Now you are ready to test the hyperlinks again.  

5. Click FUNCTIONS→CHECK HYPERLINKS. A dialog box appears asking if 
you want to check selected hyperlinks. Click Yes. 
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6. When the program has completed the test, a message should appear 
indicating how many hyperlinks were tested and that none were 
found broken. 

 The broken hyperlink has been reestablished.  

7. Click OK to finish. 

Adding Pictures to Your Web Portal 
You may want to include pictures on your Web portal. If you have digitized 
pictures that you would like to use, you can import them into Commerce Portal. 
For example, if you have pictures of your items, or if you have menu graphics 
like buttons, bars, or other decorative graphics, you can import them into 
Commerce Portal. 
 
You can import the pictures you want to include on your Web portal to the 
Picture Card. Pictures are then synchronized to the Web Server automatically. 
The format of the picture files must be either JPEG or GIF. If you have pictures 
inserted on your Item card that you want to use on your Web portal, you can save 
the pictures in either GIF or JPEG format and import it to the Picture card.  

Handling Pictures 
You can import, export, and remove pictures in the same way as you would 
handle pictures of your employees or items in Microsoft Navision. 
 
The Picture Card is accessed on the Administration menu, by clicking 
APPLICATION SETUP→COMMERCE PORTAL→WEB SITE→PICTURES. The Picture Card 
window appears: 
 

 
 
To see a list of pictures, on the Picture Card window, click PICTURE→LIST. The 
Picture List window appears. 
 
To import a picture, click PICTURE→IMPORT. A dialog box appears in which you 
select the file name to import. 
 
To remove a picture, click PICTURE→REMOVE. A dialog box appears in which you 
confirm the removal of the picture. 
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To view a picture, click PICTURE→VIEW. The picture is shown in an external 
viewer. 

Exercise − Scenario  
In this exercise you Import a new picture for use on your Web portal.  
 

TIP: If you do not already have a picture, you can export one of the other pictures in 
Commerce Portal to use for this scenario. 

 

Creating Pictures 
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→WEB SITE→PICTURES. The Picture Card window appears. 

2. On the Edit menu, click Insert New (or press F3) to create a new 
picture. 

3. Press ENTER to have the program fill in the No. field automatically. 
Alternatively, you can enter a unique value manually. 

4. In the Description field, enter a short description, for example, 
Training Course Exercise.  

5. Click PICTURE→IMPORT. A dialog box appears in which you can 
select a picture by its file name.  

6. Locate the file and click Select Image. 

7. To view the picture, click PICTURE→VIEW. The picture is shown in an 
external viewer. 

8. Escape back to the Picture Card. 

 The Last Date Modified field shows the date of the last 
modification on each picture card. The program maintains the field, 
and you cannot change the date manually. 

The picture is now imported. You can display the picture on your Web portal. 
You can include the picture on a Web page that has a property with the type 
Picture by entering the picture number in the Value field on the property line. 
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Test Your Knowledge − Setting up Web Pages 
True False  
 �  � 1. After a Web page has been created, you need to fill in or 

adjust the values of the properties.
 
 �  � 2. There are three types of hyperlinks in Commerce Portal. 
 
 �  � 3. Pictures can be imported into Commerce Portal if they are 

either GIF or JPEG format. 
 
 �  � 4. You can create multiple Web Pages based on the same Web 

Template. 
 
 �  � 5. The Type field of the Hyperlink contains the actual link. 
 
 �  � 6. Each of your Web Pages is based on a Web Template. 
 
 �  � 7. Web Pages refer to each other using Page References.  
 
 �  � 8. Each Web Page has a set of properties defined by the Web 

Template. Therefore, you can add additional properties to a 
Web page. 
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Quick Interaction: Lessons Learned 
Take a moment to write down three Key Points you have learned from this 
chapter: 
 
1. 

 

 

 

 

 
2. 

 

 

 

 

 
3. 
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CHAPTER 4: SETTING UP ITEMS AND CUSTOMERS 
 

• Overview 
• Grouping Items on Your Web portal 
• Customers and Commerce Portal 

 

Overview 
This chapter describes the final steps you must take before you can welcome 
users onto your Web portal. 
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Grouping Items on Your Web portal 
Your Web portal contains an electronic product catalog to display the items that 
you plan to sell. When you design your catalog, you may want to display your 
items in groups. You can group your items in many different ways. For example, 
items can be grouped by item type or by association, such as paint and brushes.  
 
Your inventory might already be grouped. For example, you may use different 
number series for different groups of items.  
 
To group your items on your Web portal you must use the Class field on the item 
card. 

Commerce Server Catalog 
The catalogs that display your items on the Web portal are created and 
maintained in Microsoft Commerce Server Catalog Management.  
 
For example, in the demonstration Web portal the items are classified by 
furniture type. They are grouped as chairs, desks, whiteboards, and so on. Chairs 
have been further divided into guest chairs and swivel chairs.  
 
You can read more about Catalogs in the Microsoft documentation of Commerce 
Server. 

Exercise − Scenario 
You have decided to start selling spare parts for the furniture on your storefront. 
In these exercises, you create a new class called Spare Parts. You then group the 
relevant items using this new class. In order to allow your customers to buy spare 
parts from your storefront, you must create the necessary category. 

Creating New Classes 
 

1. On the Warehouse menu, click PLANNING & EXECUTION→SETUP 
INVENTORY→CLASSES. The Classes window appears. 

2. On the Edit menu, click Insert New (or press F3), to create a new 
class.  

3. In the Code field, enter Spare Part. 

4. In the Description field, enter Spare Parts. 

5. Close the Classes window. 

Assigning Items to a Class 
 

1. On the Warehouse menu, click PLANNING & EXECUTION→ITEMS. The 
Item Card window appears. 

2. In the No. field, find 70000.  
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3. Click the E-Commerce tab. 

4. In the Class field, click the AssistButton, click the line for SPARE 
PART and click OK. Alternatively, you can enter Spare in the Class 
field and press ENTER. 

5. Press PAGE DOWN and repeat steps 4-5 for Items 70001−70060. 

Adding a New Class to the Catalog 
Classes are added to the Catalogs on the Microsoft Commerce Server in the 
Business Desk. 
 

1. On your desktop, click the Commerce Portal Business Desk button.  

 If an icon does not exist or the Business Desk does not open, in the 
browser you need to enter the computer name where Commerce 
Portal is installed and "CommercePortalbizdesk." It should look like 
this: computername/CommercePortalbizdesk.  

 You may be asked to enter a User Name and Password. 

2. Under the Business Desk Home pane, click CATALOGS→CATALOG 
EDITOR. The Catalogs pane appears. 

3. Click Cronus Catalog. On the menu bar, click Open Catalog. The 
Catalog Content window appears. 

3. Click NEW→NAVISION ITEM. Click OK to enter your new class as a 
category. The Catalog Editor window appears. 

4. Under Category Properties, in the Name, Display name, and 
Description fields, enter Spare Parts.  

5. In the Searchable field, select the option to include the category in 
your index. 

Synchronizing to Your Web portal 
To synchronize your Item table to the SQL Server database, follow this 
procedure: 
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→PERIODIC ACTIVITIES→SYNCHRONIZATION. The Synchronized 
Tables List window appears. 

2. Click the line containing Item, table 27.  

3. Click FUNCTIONS→FORCE SYNCHRONIZATION. A dialog box appears 
asking if you want to force synchronization of the Item table. Click 
Yes. 

4. Open the Catalog Content window in the Microsoft Commerce 
Server: 
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 On the Microsoft Commerce Server, open the Business Desk. Click 
CATALOGS→CATALOG EDITOR. Click Cronus Catalog. On the menu 
bar, click Open Catalog. The Catalog Content window appears. 

5. Expand the Categories section and under Categories, click Spare 
Parts. 

 In the Products in category: Spare Part section, the list of items 
(70000-70060) now appears. 

To verify that the menu item has been added to your Web portal, open your Web 
portal and browse the Web pages. If your Web portal is already open, just refresh 
the Web page. 

Customers and Commerce Portal  
Both new and existing Web portal users can place orders on your Web portal. 
 
If you want your existing customers to use the same account on your Web portal 
as in Navision − using the same information such as addresses, payment terms, 
and so on − you have to enable them to use Commerce Portal. New users can 
sign up on your Web portal. 
 
To enable customers to shop on your Web portal, you must complete the 
following tasks: 
 

• Assign person contacts to customers (company contact).  
• Assign roles to customers (person contacts). 
• Assign notification process codes to customers (person contacts). 
• Assign Commerce Portal user IDs and passwords to customers 

(person contacts). 
• Assign priorities to your customers (person contacts). 

 
The following sections describe these tasks in more detail. 

Assigning Contact Cards to Customers 
All information about Web portal users is maintained on related Contact cards. If 
a customer is already registered in your database, you can manually grant them 
the necessary permissions and create a Commerce Portal login ID and password 
for them by creating a Contact Person card. If a new Web portal user signs up in 
your Web portal, Navision automatically creates a new Customer card, a Contact 
Company card, and Contact Person card. 

Assigning a Role to Customers 
Before you welcome your customers to your Web portal, you must define which 
tasks your customers are allowed to perform on your Web portal, and afterwards 
you must grant permissions to each customer by assigning a role according to 
this definition. 
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In Commerce Portal, you can define different roles. This means that several types 
of Web portal users can do business activities with your company or browse in 
your Web portal. Different roles have different permissions to perform different 
activities, such as business, maintenance, or administration activities. 
 
You can choose to assign the same role to all your customers or you can define 
different roles and assign these to customers according to the permissions you 
want to grant them. The roles are assigned to the Contact Person card. 

Assigning a Notification Process to a Customer 
In Commerce Portal, you can notify your customers of the status of their orders. 
But instead of doing this manually by phone or fax, you can have Navision do 
this automatically by e-mail. This is done using notification processes. 
 
External notifications relate to your Web portal user. The notification codes are 
grouped in notification processes and can be selected from the Notification 
Process List window. 
 
The notification processes for a customer can be defined per contact on the 
Contact Person card, per customer on the Customer card, or per website on the 
Web Site card. 
 
If a notification process is specified on the Contact card of the Web portal user, 
the user will be notified according to this. If you leave the Notification Process 
Code field on the Contact Person card blank, the user will be notified according 
to the notification process code on the Customer card. If you also leave the 
Notification Process Code field on the Customer card blank, the user will be 
notified according to the Notification Process Code field on the Web Site card. 
 
The customer and the contacts related to the customer can receive e-mail 
notifications, for example, when the following events in Navision occur: 
 

• When a sales quote is accepted. 
• When a sales quote is confirmed, that is, made into a sales order. 
• When a sales quote is rejected. 
• When a sales order is shipped. 
• When a Web portal user ID and password are created. 

 

Assigning Web portal User IDs and Passwords to 
Customers 
Customers need to sign in to your Web portal with their user ID and password in 
order to be correctly identified when they place an order and to ensure that they 
receive all discounts that they are entitled to. 
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New customers must register on your Web portal with a login ID and a password 
of their own choice. The customer then uses this Web portal user ID and 
password to sign in to your Web portal, where they are allowed to perform the 
tasks you have granted them permission for. 
 
But some of your existing customers may also want to place orders through your 
Web portal. In order to use the information on the Customer card with existing 
customers, you have to create a Web portal user ID and password for them. 
 

NOTE: The login ID must be unique. If you enter a login ID that already exists, a 
dialog box telling you this will appear. 

 
When you create a Web portal user ID and password for a new Web portal user, 
Navision automatically generates the password and the user will receive an e-
mail notification. The notification code in the Password-Created Notif. field, 
defined on the Contact tab of the notification process card for this customer, 
determines the content of the e-mail.  
 
To read about notification processes, see the section called "Setting up 
Notification Processes" in Chapter 2, "Setting up Microsoft Navision Commerce 
Portal." 

Deleting a Web portal User's Login ID 
You can also disable your Web portal users, which means that the user will no 
longer be able to sign in to your Web portal. Do this by using the Remove from 
Web portal function. The program then deletes all the information that was used 
for the user to have access to the Web portal. This includes roles and notification 
process codes. 
 

NOTE: It is not possible to delete a login ID if there are any sales documents 
containing the login ID that are not posted. 

 

Assigning Queue Priorities to Your Customers 
When you create a new Customer card, the program automatically assigns the 
value Medium Priority to the customer and the related contact persons. However, 
you can assign different priorities to your customers and contact persons. When 
many customers are browsing your Web portal, and there are a large number of 
Web portal requests that need to be processed, the requests from your customers 
with the highest priority will be processed first.  

Exercises 
In the following exercises, you create a new Contact Person card for a customer. 
You will also generate a new login, password, and assign roles to the contact to 
give your customer access to your Web portal. 
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Creating a New Contact Person 
 

1. On the Sales & Marketing menu, click SALES→CONTACTS. The 
Contact window appears. 

2. Press F3 and ENTER to create a new Contact card. 

3. Complete the following fields with this information: 

 
Tab Field Value 
General   
 Type Person 
 Company No. John Haddock Insurance Co. 
 Name Kendall Keil 
Communication   

 E-mail 
<your email address> to view the 
email.  

Commerce Portal   
 Login ID kkeil 

 
Notification 
Process Code Basic 

 
4. Click CONTACT→COMMERCE PORTAL ROLES. The Web portal User 

Roles window appears. 

5. In the Web portal Role Code field, click the AssistButton to view a 
list of the Web portal roles. The Web portal Roles window appears. 

6. In the Code field, find PRTNR. Click on the line and click OK. 

7. Commit the code to the field. 

8. Escape back to the Contact Card window for Kendall Keil. 

9. To create a password for this contact, click FUNCTIONS→COMMERCE 
PORTAL→CREATE PASSWORD. A dialog window asks if you want to 
create a new password and send to the user. Click Yes.  

10. A dialog box appears telling you that an email message containing a 
new Password will be sent to the user. Click OK. 

11. On the Commerce Portal tab, the Password option is now selected.  

 While in the Contact header, if you Zoom (CTRL+F8) and find the 
Password field, you see that an encrypted password has been added 
to this Contact Card table. 

12. Open the email to see your password. 

Page 61 



 

 

Microsoft Navision Commerce Portal 

Manually Sending Emails with Passwords  
If you do not have access to Microsoft® Outlook® within the class, but you have 
Outlook Express or Outlook installed and configured on your machine, you can 
manually send the email.  
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→PERIODIC ACTIVITIES→COMMERCE PORTAL STATUS. The 
Commerce Portal Status window appears. 

2. Click the Communication tab. 

3. In the No. of Queued E-mail Msgs field, click the AssistButton. 

4. Locate your email address from the list. 

5. Click FUNCTIONS→RESEND MANUALLY. A Microsoft Office Outlook 
security dialog box appears. Select the Allow Access for option and 
click Yes. 

6. Outlook then opens with the email notification to be sent to you. 

7. Make note of the Login and Password within the body of the email. 

8. Close the email without clicking Send. 

Logging On to Your Web portal 
 

1. Open your Internet browser and enter the address of your Web 
portal, the website will appear in your browser. 

2. Log on to your Web portal as the new contact person you have 
created in the previous exercise, using the password you received in 
the e-mail. 
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Test Your Knowledge − Setting up Items and Customers 
1. In the Catalog Editor, you select the __________________________ 

option to include the category in your index. 

 

2. You use the ____________________ field on the Item Card to group 
your items on your Web portal. 

 

3. The function used to synchronize the Item table to SQL Server 
database is called ________________________________________. 

 

4. The requests from your customers with the ____________________ 
_____________________ will be processed first. 

 

5. Your Web portal contains a/an ______________________________ 
_______________________________________ to sell the item that 
you plan to sell. 

 

6. You can disable your Web portal users by using the _____________ 
_______________________________ function. 

 

7. The __________________________________ assists in letting your 
customers know the status of their orders automatically by e-mail. 

 

8. The catalogs that display your items on the Web portal are created 
and maintained in ________________________________________ 
_______________________________________________________. 
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Quick Interaction: Lessons Learned 
Take a moment to write down three Key Points you have learned from this 
chapter: 
 
1. 

 

 

 

 

 
 
2. 

 

 

 

 

 
 
3. 
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CHAPTER 5: WORKING WITH REVERSE AUCTION 
 

• Overview 
• Vendors and Commerce Portal 
• Reverse Auction 

 

Overview 
This chapter describes how you can ease your purchasing process by requesting 
offers on different items from your vendors through the Web portal. 
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Vendors and Commerce Portal 
You can give your vendors access to some of your internal information, located 
in Microsoft® Business Solutions−Navision®, by giving them access to your Web 
portal. 
 
If you want your vendors to use the same account on your Web portal as in 
Microsoft Navision − using the same information like addresses, payment terms, 
and so on − you just have to enable them to use Commerce Portal. 
 
To enable vendors to access information and to respond to reverse auctions on 
your Web portal, you must complete the following tasks: 
 

• Assign Contact Person cards to vendors (company contacts). 
• Assign roles to vendors (person contacts). 
• Assign notification process codes to vendors (person contacts). 
• Assign Commerce Portal login ID and passwords to one or more 

contact persons related to the vendors (person contacts). 
• Assign priorities to your vendors (person contacts). 

 
The following sections describe these tasks in more detail. 

Assigning a Contact Person Card to Vendors 
All information about Web portal users is maintained on related Contact Person 
cards. If a vendor is already registered in your database, you can manually grant 
them the necessary permissions and create a Commerce Portal login ID and 
password for them by creating a Contact Person card. 

Assigning a Role to a Vendor 
Before you welcome your vendors to your Web portal, you must define which 
tasks each of your vendors is allowed to perform on your Web portal. Then you 
must assign one or more roles to your vendor according to these tasks. You can 
choose to assign the same role to all your vendors or you can define different 
roles and assign these to vendors according to the permissions you want to grant 
them. The roles are assigned to the Contact Person card. 

Assigning a Notification Process to a Vendor 
In Commerce Portal, you can notify your vendors of different events connected 
to your reverse auctions. But instead of doing this manually by telephone or fax, 
you can have Microsoft Navision do this automatically by e-mail. This is done 
using notification processes. 
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A notification process can be assigned to each of your vendors and/or the contact 
persons related to the vendor. If the Notification Process Code field on the 
Vendor card is filled in, the vendor will receive e-mail notifications, for example, 
when the following events in Microsoft Navision occur: 
 

• When a reverse auction is created. 
• When an auction is closed. 
• When an offer is accepted. 
• When an offer is rejected. 
• When a Web portal login ID and password is created. 

 
The notification process code is used to send e-mail notifications to the vendor 
when a new reverse auction is created and the vendor is invited to participate, or 
when an offer is accepted or rejected.  
 
The notification processes can be defined on the Contact Person card, the Vendor 
card, or on the Web Site card. 
 
If a notification process is specified on the Contact Person card of the vendor, the 
vendor will be notified according to this. If you leave the Notif. Process Code 
field on the Contact card blank, the vendor will be notified according to the 
notification process code on the Vendor card. If you also leave the Notification 
Process Code field on the Vendor card blank, the vendor will be notified 
according to the Notif. Process Code field on the Web Site card. 

Assigning a Web portal Login ID and Passwords to 
Vendors 
Vendors need to sign in to your Web portal with their login ID and password in 
order to be correctly identified to view personal information or place an offer on 
a reverse auction. 
 
A login ID and password for vendors must be created from within Microsoft 
Navision or by a contact that is granted administrator permission and that is 
related to the current vendor. The login ID must be entered on the Contact card, 
and you can create the password by running the create password batch job. 
 

NOTE: The login ID must be unique. If you enter a login ID that all ready exists, a 
dialog box telling you this will appear. 

 
When Microsoft Navision creates a Web portal login ID and password for a 
vendor, the vendor will receive an e-mail notification. The notification code in 
the Password-Created Notif. field in the notification process code defined on 
the Communication tab of the Web Site card determines the content of the e-
mail. 
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This Web portal login ID and password is then used by the vendor to sign into 
your Web portal, which allows the vendor to place offers on reverse auctions, 
maintain information on items, enter delivery dates, and enter drop shipments. 
 
To read about notification processes, see the section called "Setting up 
Notification Processes" in Chapter 2, "Setting up Microsoft Navision Commerce 
Portal." 

Deleting a Web portal Login ID 
You can also disable your Web portal vendors, which means that the vendor will 
no longer be able to sign in to your Web portal.  
 

NOTE: It is not possible to delete a login ID if there is any reverse auction documents 
containing the login ID that are not posted. 

 

Assigning Queue Priorities to Your Vendors 
When you create a new Vendor card, the program automatically assigns the value 
Medium Priority to the vendor. However, you can assign different priorities to 
your vendors. When many Web portal users are browsing your Web portal and 
there are a large number of Web portal requests that need to be processed, the 
requests from your vendors with the highest priority will be processed first.  

Exercises 
In the following exercises, you create a new Contact Person card for a vendor. 
You also generate a new login and password. You assign roles to the contact to 
give your vendor contact person access to your Web portal.  

Creating a New Contact 
 

1. On the Sales & Marketing menu, click SALES→CONTACTS. The 
Contact window appears. 

2. Press F3 and ENTER to create a new Contact card. 

3. Complete the following fields with this information: 

 
Tab Field Value 
General   
 Type Person 
 Company No. The Cannon Group PLC 
 Name Mason Bendixen 
Communication   

 E-mail 
<your email address> to view the 
email. 
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Tab Field Value 
Commerce Portal   
 Login ID mbendixen 

 
Notification 
Process Code Basic 

 
4. Click CONTACT→COMMERCE PORTAL ROLES. The Web portal User 

Roles window appears. 

5. In the Web portal Role Code field, click the AssistButton to view a 
list of the Web portal roles. The Web portal Roles window appears. 

6. In the Code field, find VEND, click the line and then click OK. 

7. Commit the code to the field. 

8. Escape back to the Contact Card window for Mason Bendixen. 

9. To create a password for this contact, click FUNCTIONS→COMMERCE 
PORTAL→CREATE PASSWORD. A dialog window asks if you want to 
create a new password and send to the user. Click Yes.  

10. A dialog box appears telling you that an email message containing a 
new Password will be sent to the user. Click OK. 

11. On the Commerce Portal tab, the Password option is now selected.  

 While in the Contact header, if you Zoom (CTRL+F8) and find the 
Password field, you see that an encrypted password has been added 
to this Contact Card table. 

12. Open the email to see your password. 

Manually Sending Emails with Passwords  
If you do not have access to Microsoft® Outlook® within the class, but you have 
Outlook Express or Outlook installed and configured on the machine, you can 
manually send the email.  
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→PERIODIC ACTIVITIES→COMMERCE PORTAL STATUS. The 
Commerce Portal Status window appears. 

2. Click the Communication tab. 

3. In the No. of Queued E-mail Msgs field, click the AssistButton. 

4. Locate your email address from the list. 

5. Click FUNCTIONS→RESEND MANUALLY. A Microsoft Office Outlook 
security dialog box appears. Select the Allow Access for option and 
click Yes. 
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6. Outlook then opens with the email notification to be sent to you. 

7. Make note of the Login and Password within the body of the email. 

8. Close the email without clicking Send. 

Reverse Auction 
A reverse auction is when you put a demand for purchasing products to one or 
more vendors on the Web portal. The participating vendors can then respond to 
your auction by placing an offer on the Web portal, stating delivery time and 
quantity. Finally, you choose which of the vendors you want to buy from.  
 
Completing a reverse auction includes the following tasks: 
 

• Setting up vendors as participants 
• Creating a reverse auction 
• Choosing participants 
• Handling the responses 
• Selecting a winner 
• Participants 

 
When a vendor has agreed to participate in your future reverse auctions, you 
must enable the vendor to be a participant. On the Vendor card, you can include 
the vendor in the group that can be invited to participate in a reverse auction. 
Before you invite a vendor to participate in a reverse auction, make sure that a 
Web portal user login ID and a password has been sent to the vendor. 

Creating a Reverse Auction 
Each reverse auction document in Microsoft Navision lists one item that is up for 
auction. The document consists of a header and some lines, similar to other 
documents in Microsoft Navision. The header contains relevant information 
about the item and the requirements of the reverse auction. The lines contain 
information about the participants and their responses to the reverse auction. 
Each reverse auction should have a unique identification number, so that both 
customer and vendor can make sure that they are referring to the same auction. 

Public Reverse Auction 
It is up to you whether the auction should be public or not. A public reverse 
auction results in an open reverse auction, where participating vendors are able to 
follow the auction progress. All vendor bids are made public for the rest of the 
participating vendors to view and react to. However, not all information about a 
vendor is made public to the other vendors. The vendors name or other 
information about the vendor is not displayed on the Web portal. 
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Choosing Participants 
When you have filled in the header of the reverse auction document, you can 
choose the vendors you want to invite to participate. You can choose the 
participants one by one from the lines, or you can use the Suggest Reverse 
Auction Lines batch job to fill in the lines. Only vendors with a check mark in 
the Reverse Auction Participant field on the Vendor card and who have a Web 
portal login ID and password can participate. When you have filled in the reverse 
auction, you must release it so that it can be shown on your Web portal. 

Handling the Responds 
After you have released the reverse auction to the Web portal, you are able to 
receive responses from vendors. The responses will automatically be copied to 
the lines on the reverse auction. The lines contain information about the 
participants and their responses to the reverse auction. 

Closing the Reverse Auction 
When the closing date of the reverse auction has passed or you have decided to 
close the reverse auction, you can run the Close Reverse Auction for Offers batch 
job. This batch job changes the status of the reverse auction to Closed for Offers 
before you select the winner of the auction. 

Selecting a Vendor 
When the closing date has passed or you have closed the reverse auction by using 
the Close Reverse Auction for Offers batch job, you must choose a winner of the 
auction by running the Select Vendor batch job. If you have set up the relevant 
reverse auction notifications, the vendors will receive notifications of the result 
of the reverse auction. 

Exercises 
In the following exercises, you create a reverse auction, choose participants for it, 
and then release it to your Web portal. Then you log on to your Web portal (as a 
vendor) to place an offer on the reverse auction. Finally, you close the reverse 
auction, select a vendor, and make an order from the reverse auction. 
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Creating a Reverse Auction  
 

1. On the Purchase menu, click ORDER PROCESSING→REVERSE 
AUCTIONS. The Reverse Auctions window appears: 

 

 
 

2. Press F3 and ENTER to create a new reverse auction.  

3. In the Item No. field enter 70000. 

4. In the Quantity field, enter 100. 

5. In the Web Site Code field, enter the name of your website. In this 
example, enter home. 

6. In the Closing Time field, enter 12.  

7. Click FUNCTIONS→SUGGEST REVERSE AUCTION LINES.  

 The program creates a reverse auction line for all vendors assigned to 
the item listed for auction. That is, only the vendors who have a 
check mark in the Reverse Auction Participants field on the 
Vendor card will be included in the list of participants. 

8. To release the reverse auction to your Web portal, click 
FUNCTIONS→RELEASE. The Release Reverse Auctions batch job 
window appears. 

9. Click OK. 

 The Status field on the Reverse Auction header and lines now 
display Released. 

10. Make note of the Reverse Auction No. 
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Making a New Bid on a Reverse Auction 
 

1. Start the Internet browser and enter the address of your Web portal, 
the website appears in you browser. 

2. Log on to your Web portal as Mason Bendixen. 

3. From the menu, click Reverse Auctions. The Reverse Auctions list 
appears. 

4. Click the line for the Reverse Auction number noted in step 10 of the 
previous exercise.  

5. Place an offer for the reverse auction with the following data:  

 
Field Value 
Item Number 70000 
Quantity 101 

Expected Receipt Date 
Enter a date a few days after the Offerdeadline 
date. 

Currency British Pound 
Unit Price 20 

 
6. To submit the order, click Update. You have now placed an offer for 

the reverse auction.  

7. Go back to Microsoft Navision and on the Purchase menu, click 
ORDER PROCESSING→REVERSE AUCTIONS. The Reverse Auctions 
window appears. 

8. Find the reverse auction you have placed an offer on and check the 
data. Notice that on the line for the vendor associated with your 
vendor Contact Card (Vendor 10000), the Quantity, Amount 
(LCY), and Delivery Date fields are updated with the values you 
entered in step 5. Also notice that the Status field for this line has 
been changed to Updated. 

9. Do not close the Reverse Auction window. 

Closing the Reverse Auction 
 

1. On the Reverse Auction window from the previous exercise, click 
FUNCTIONS→CLOSE REVERSE AUCTION FOR OFFERS. The Close for 
Offers batch job window appears. 

2. Click OK to continue.  

3. In the header, the status of the Reverse Auction has now changed to 
Closed for Offers. 

4. Do not close the Reverse Auctions window. 
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Selecting a Vendor and Making a Purchase Order 
 

1. On the Reverse Auction window from the previous exercise, click 
the line for Vendor 10000. 

2. Click FUNCTIONS→SELECT VENDOR. The line of the selected vendor is 
now bold. 

3. Click FUNCTIONS→CREATE ORDER. The Create Order batch job 
window will appear. 

4. Click OK to accept the creation of the order. 

5. On the Shipping tab, you can see the order number that has been 
created. Make note of this Order No. 

6. To see the order you have just created, on the Purchase menu, click 
ORDER PROCESSING→ORDERS. The Purchase Order window appears. 

7. Locate the Order No. noted in step 5 above. 
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Test Your Knowledge − Working with Reverse Auction 
1. All information about Web portal users is maintained on related 

__________________________________________________ cards. 

 

2. The ____________________________________________________ 
field must be checked on the ____________________ card in order 
to eligible for a reverse auction, in addition to a Web portal login ID 
and password. 

 

3. A reverse auction is ______________________________________ 
_______________________________________________________. 

 

4. The winner of the auction is selected by running the _____________ 
______________________________ function. 

 

5. A/an _________________ reverse auction results in an open reverse 
auction, where participating vendors are able to follow the auction 
progress. 
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Quick Interaction: Lessons Learned 
Take a moment to write down three Key Points you have learned from this 
chapter: 
 
1. 

 

 

 

 

 
 
2. 

 

 

 

 

 
 
3. 
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CHAPTER 6: COMMERCE PORTAL ARCHITECTURE 
AND ADMINISTRATION 

 
• Overview 
• System Architecture 
• Request/Response  
• Synchronization  
• E-mail  
• Troubleshooting Synchronization  
• Monitoring the Status of Commerce Portal 

 

Overview 
This chapter provides you with an overview of the architecture used for 
Microsoft® Business Solutions−Navision® Commerce Portal. An understanding 
of the architecture allows you to troubleshoot Commerce Portal issues. 
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System Architecture 
The following diagram provides an overview of the system architecture of 
Commerce Portal. Commerce Portal is based on a four-tier model consisting of a 
Web front, a communication layer, a Navision Application layer and a Microsoft 
Navision backend. In Commerce Portal, all data is maintained from within 
Microsoft Navision but stored in both the Microsoft Navision database and in the 
SQL Server database. Synchronization between the two is done through 
messages sent through Microsoft Message Queuing (MSMQ). Navision 
Application Server is used to handle communication between Microsoft Navision 
and the Web portal. 
 

 
 

Data Interchange between the Web Front and the Backend 
The communication between the Web front and the backend includes several 
stages of data interchange: 
 

• A request is sent from the Web front to the Job message queue. 
• Navision Application Server receives the job request messages from 

the CPHandler. 
• Microsoft Navision sends back the reply message to the Web front 

through the Reply message queue. 
• The Web front receives the reply message. 

 
Each of these stages is described in detail in the following sections. 
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Sending a Request from the Web Front to the Job Message 
Queue 
 

1. Using ASP code, the program creates an XML document using 
Microsoft® XML Core Services (MSXML) with the globally unique 
identifier (GUID) number left blank.  

2. The website ASP code calls the MSMQ (job queue) send method 
which returns a GUID. The ASP code now starts to listen to the 
MSMQ (reply queue) looking for message with the previously stored 
GUID. 

3. When the correct message is found, the ASP code receives it and 
starts processing the XML document in the message. 

 

 
 

Receiving the Job Request Messages from the CPHandler  
 

1. The CP Handler "cQueueHandler" method exposes the 
"MessageReceived" event. This event exists in Microsoft Navision 
as a trigger which is fired as soon as a message is ready to be 
processed.  

2. The XML document is extracted by the Queue Handler. 

3. Codeunit 6221 (Request Handler) extracts the process type and login 
ID (to determine the queue priority). It creates a log entry in the 
"Message Log Header" table. Then it calls Codeunit 6217 (XML 
Document Receive).  
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4. Codeunit 6226 (XML Document Decode) receives the message and 
checks whether the GUID number of the XML document is blank. If 
it is blank, the process is stopped and an error message is sent back 
to the Web front. 

Sending and Receiving the Reply Message 
 

1. Depending on the process type, one of the management codeunits 
processes the XML document.  

2. Codeunit 6225 (XML Document Encode), creates the reply XML 
document. The previously extracted GUID is added as an element. 

3. The reply XML document is sent back to the Queue Handler by 
Codeunit 6221 (Request Handler). The Queue Handler sends it to the 
MSMQ (reply queue). 

Synchronization 
Data that is relevant for Commerce Portal is stored in both the Microsoft 
Navision database and in the SQL Server database. 
 
In Commerce Portal, all data is maintained in Microsoft Navision. This includes 
item names, descriptions, prices, translations, and availability. The program also 
maintains information about your Web portal users, the text on your Web pages, 
and to some extent the design of your Web portal. 
 
The synchronization between the two databases is done through messages sent 
using MSMQ.  
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Automated Synchronization 
The following diagram shows how the records in Microsoft Navision are 
synchronized with the SQL Server database. Synchronization is triggered by the 
Microsoft Navision C/SIDE triggers OnInsert, OnModify, OnRename and 
OnDelete. The following diagram shows this process using Table 8 (Language) 
as an example. 
 

 
 
You can use this as guidance when customizing the synchronization processes, 
for example, when adding new fields or tables.  
 
The last stage in the synchronization process is that the program places the data 
in the SynchMgt. Message Queue table (6224) and Navision Application Server 
collects the data from this table and submits it to MSMQ (the sync queue). 

Force Synchronization 
When you first install Commerce Portal, you have to force synchronization to 
initialize the SQL Server. Similarly, when you add fields or tables to the 
synchronization, you need to force the synchronization to initialize again. 
 
To synchronize your SQL Server database with the Microsoft Navision database 
(force synchronization), follow this procedure: 
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→PERIODIC ACTIVITIES→SYNCHRONIZATION. The Synchronized 
Tables List window appears. 

2. Click the lines containing the tables you want to synchronize.  

3. Click FUNCTIONS→FORCE SYNCHRONIZATION. A dialog box appears 
asking if you want to force synchronization of the Item table. Click 
Yes. 
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A window with a status bar appears on the screen until the synchronization has 
completed. Depending on your configuration and hardware, this process can take 
several hours. 
 

NOTE: The synchronization procedure creates XML messages. The Navision 
Application Server and the Microsoft Navision Commerce Portal synchronization 
service handles the synchronization of the SQL Server database with the Microsoft 
Navision database. The synchronization is done through MSMQ using a Windows NT 
service (Microsoft Navision Commerce Portal Synchronization), which is included in 
the Commerce Portal installation. 

 

Troubleshooting Synchronization 
In the following exercises, you troubleshoot the synchronization of data from the 
SynchMgt. Message Queue table (6224) in Microsoft Navision to the SQL 
Server. This is done by disabling components one at a time to see how far the 
data can go with that component disabled. This shows you the key places to start 
your troubleshooting. If no data is entered in the SynchMgt. Message Queue 
table (6224), you must troubleshoot within Microsoft Navision.  
 
For an overview of how records are synchronized to the SQL Server, see the 
diagram in the previous section, "Automated Synchronization." 

Overview 
Data is stored in the SynchMgt. Message Queue table (6224) when you run the 
Force Synchronization batch job or when you modify data in a table that contains 
synchronization data. The data is only deleted from the SynchMgt. Message 
Queue table if a MSMQ message is created in the Synch. message queue 
requiring this deletion. From the Synch message queue the message can only go 
to SQL Server or the Error message queue. 
 
The data is collected by Navision Application Server and stored in a MSMQ 
message. The CPHandler places the message in the Synch. message queue. 
 
The Commerce Portal synchronization service retrieves the messages from 
MSMQ. If Commerce Portal synchronization can process the message, it is sent 
to SQL Server. Otherwise, the message is sent to the Error message queue 
attached to the error message describing the error. 
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The components used in synchronization are highlighted in the diagram below. 
 

 
 
For more information about error handling, see the Common Error document in 
the "Channel Readiness Kit for E-Commerce." 

Exercise − Troubleshooting Navision Application Server 
To do this exercise, you need to complete the following five tasks:  
 

• Stop the Navision Application Server. 
• Synchronize the Currency table. 
• Verify the data. 
• Restart the Navision Application Server. 
• Verify that the data has been removed. 

 
Each of these tasks is described in detail in the following sections.  

Stopping the Navision Application Server 
 

1. On your Desktop, right-click My Computer and click Manage. 

2. Expand Services and Applications and click Services. 

3. Right-click Navision Application Server Computername-
CLASSIC and click Stop. 
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Synchronizing the Currency Table  
 

1. In Microsoft Navision, on the Administration menu, click 
APPLICATION SETUP→COMMERCE PORTAL→PERIODIC 
ACTIVITIES→SYNCHRONIZATION. The Synchronized Tables List 
window appears. 

2. Click the line containing Currency (table 4).  

3. Click FUNCTIONS→FORCE SYNCHRONIZATION. A dialog box appears 
asking if you want to force synchronization of the Item table. Click 
Yes. 

Verifying the Data in SynchMgt. Message Queue Table  
 

1. On the Tools menu, click Object Designer and then click Table.  

2. In the Name field, find the SynchMgt. Message Queue table (6224). 

3. Click Run. The SynchMgt. Message Queue − Table window 
appears. 

 Verify that the currency data you want synchronized appears. 

Restarting the Navision Application Server  
 

1. On your Desktop, right-click My Computer and click Manage. 

2. Expand Services and Applications and click Services. 

3. Right-click Navision Application Server Computername-
CLASSIC and click Start. 

Verifying the Removal of Data in the SynchMgt. Message 
Queue Table  
 

1. In Microsoft Navision, on the Tools menu, click Object Designer 
and then click Table.  

2. In the Name field, find the SynchMgt. Message Queue table (6224). 

3. Click Run. The SynchMgt. Message Queue − Table window 
appears. 

 Verify that the currency data has been removed. 

 
NOTE: The Navision Application Server checks the table every 10 seconds, as 
controlled by the CPTimer. Therefore you may need to refresh the table a few times 
before you can verify that the data has been removed. 
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Synch. Message Queue Properties  
The CPHandler.dll retrieves the messages from the Navision Application Server 
and places them in the private Synch. message queue. The security properties for 
the Synch. message queue must grant full control to everyone. If the properties 
are not set correctly, the CPHandler cannot access the message queue and the 
data remains in the SynchMgt. Message Queue table (6224). 

Exercise − Synch. Message Queue Administration 
In this exercise, you change the security settings of the Synch. message queue to 
ensure that the data stays in the SynchMgt. Message Queue table (6224). It is 
very important to choose the settings as described in the following procedure. If 
you select Deny to all settings you will not be able to change the settings back 
and you will have to reinstall MSMQ. 
 
To do this exercise, you need to complete the following five tasks: 
 

• Change the Synch. message queue's security settings.  
• Synchronize the Currency table. 
• Verify the data. 
• Reset the security settings for the Synch. message queue. 
• Verify that the data has been removed. 

 

Changing the Security Settings for the Synch. Message queue 
 

1. On your Desktop, right-click My Computer and click Manage. 

2. Expand Services and Applications, click Message Queuing and 
then click Private Queues. The list of Private Queues appears. 

3. Right-click the Synch. Message Queue (possibly labeled synchmq) 
and click Properties. The Properties window appears. 

4. On the Security tab, in the Name field, click Everyone. 

5. In the Permissions field, under Full Control, click Deny. 

6. In the Permission section, verify that the Allow option is selected for 
Get Properties and Get Permissions. This allows you to set the 
settings correctly after this exercise. 

7. Click OK. A message appears asking you to confirm the changes. 
Click Yes. 

Synchronizing the Currency Table  
 

1. In Microsoft Navision, on the Administration menu, click 
APPLICATION SETUP→COMMERCE PORTAL→PERIODIC 
ACTIVITIES→SYNCHRONIZATION. The Synchronized Tables List 
window appears. 
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2. Click the line containing Currency (table 4).  

3. Click FUNCTIONS→FORCE SYNCHRONIZATION. A dialog box appears 
asking if you want to force synchronization of the Item table. Click 
Yes. 

Verifying the Data in the SynchMgt. Message Queue  
 

1. On the Tools menu, click Object Designer and then click Table.  

2. In the Name field, find the SynchMgt. Message Queue table (6224). 

3. Click Run. The SynchMgt. Message Queue − Table window 
appears. 

4. Verify that the currency data you want synchronized appears. 

Resetting the Security Settings for Synch. Message Queue 
 

1. On your Desktop, right-click My Computer and click Manage. 

2. Expand Services and Applications, click Message Queuing and 
then click Private Queues. The list of Private Queues appears. 

3. Right-click synchmq (the Synch. Message Queue) and click 
Properties. The synchmq Properties window appears. 

4. On the Security tab, in the Name field, click Everyone. 

5. In the Permissions field, under Full Control, click Allow. 

Verifying the Removal of Data from the SynchMgt. Message Queue 
Table  
 

1. In Microsoft Navision, on the Tools menu, click Object Designer 
and then click Table.  

2. In the Name field, find the SynchMgt. Message Queue table (6224). 

3. Click Run. The SynchMgt. Message Queue − Table window 
appears. 

4. Verify that the currency data has been removed. 

The message has now been processed by CPHandler and sent to SQL Server 
through the Synch. message queue. 

Navision Commerce Portal Synchronization Service  
The Navision Commerce Portal Synchronization service monitors the Synch. 
message queue and processes all the messages in it. These messages are either 
sent to the Commerce Server or to the Error message queue. 
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Exercise − Commerce Portal Synchronization Service 
Administration 
To do this exercise, you need to complete the following six tasks: 
 

• Stop the Navision Commerce Portal Synchronization service. 
• Verify that the Synch. message queue is empty. 
• Synchronize the Currency table from Commerce Portal. 
• Verify that the Synch. message queue contains messages. 
• Restart the Navision Commerce Portal Synchronization service. 
• Verify that the Synch. message queue is empty. 

 

Stopping the Navision Commerce Portal Synchronization  
 

1. On your Desktop, right-click My Computer and click Manage. 

2. Expand Services and Applications and click Services. 

3. Right-click Navision Commerce Portal Synchronization and click 
Stop. 

Verifying that the Synch. Message Queue is Empty 
 

1. On your Desktop, right-click My Computer and click Manage. 

2. Expand Services and Applications, click Message Queuing and 
then click Private Queues. The list of Private Queues appears. 

3. Resize the window so you can see the Messages column in the right 
pane. 

4. Press F5 to refresh.  

5. Verify that there are no messages in the Synch. message queue. 

Synchronizing the Currency table  
 

1. In Microsoft Navision, on the Administration menu, click 
APPLICATION SETUP→COMMERCE PORTAL→PERIODIC 
ACTIVITIES→SYNCHRONIZATION. The Synchronized Tables List 
window appears. 

2. Click the line containing Currency (table 4).  

3. Click FUNCTIONS→FORCE SYNCHRONIZATION. A dialog box appears 
asking if you want to force synchronization of the Item table. Click 
Yes. 
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Verifying that the Synch. Message Queue Contains Messages 
 

1. On your Desktop, right-click My Computer and click Manage. 

2. Expand Services and Applications, click Message Queuing and 
then click Private Queues. The list of Private Queues appears. 

3. Resize the window so you can see the Messages column in the right 
pane. 

4. Press F5 to refresh.  

5. Verify that there are messages in the Synch. message queue. 

Restarting Navision Commerce Portal Synchronization  
 

1. On your Desktop, right-click My Computer and click Manage. 

2. Expand Services and Applications and click Services. 

3. Right-click Navision Commerce Portal Synchronization and click 
Start. 

Verifying that the Synch. Message Queue Is Empty 
 

1. On your Desktop, right-click My Computer and click Manage. 

2. Expand Services and Applications, click Message Queuing and 
then click Private Queues. The list of Private Queues appears. 

3. Resize the window so you can see the Messages column in the right 
pane. 

4. Press F5 to refresh.  

5. Verify that there are no messages in the Synch. message queue. 

The messages have been picked up by the Navision Commerce Portal 
Synchronization service and sent to SQL Server. 
 

NOTE: You can verify that the messages are sent to SQL Server by deleting the 
COMMERCE_CURRENCY table in the CommercePortal_commerce database in the 
SQL Server Enterprise Manager prior to running the synchronization. The 
synchronization process recreates this table. 
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Error Message Queue  
The messages that, for one reason or another, cannot be processed by Navision 
Commerce Portal synchronization end up in the Error message queue.  

Exercise − Error Message Queue Administration 
In this exercise, you change the Connection String in the Commerce Portal setup 
so that it contains incorrect information. Then you restart the Navision 
Commerce Portal Synchronization service to have the changes take effect. After 
the synchronization process, you see the resulting messages in the Error message 
queue. Then correct the setup and start Navision Commerce Portal 
Synchronization again to see that the messages in the Error message queue are 
still there but a new synchronization has been successful. 
 
To do this exercise, you need to complete the following eight tasks: 
 

• Change the Commerce Portal setup. 
• Restart the Navision Commerce Portal Synchronization service. 
• Synchronize the Currency table. 
• Verify the error messages in the Error message queue. 
• Reset Commerce Portal Setup. 
• Restart the Navision Commerce Portal Synchronization. 
• Synchronize the Currency table. 
• Verify the Error message queue. 

 

Changing Commerce Portal Setup 
 

1. In Microsoft Navision, on the Administration menu, click 
APPLICATION SETUP→COMMERCE PORTAL→COMMERCE PORTAL SETUP. 
The Commerce Portal Setup window appears. 

2. Click the Communication tab.  

3. In the Initial Catalog field, enter the name of a nonexistent catalog, 
for example, Wrong Catalog. 

Restarting the Navision Commerce Portal Synchronization  
 

1. On your Desktop, right-click My Computer and click Manage. 

2. Expand Services and Applications and click Services. 

3. Right-click Navision Commerce Portal Synchronization and click 
Restart. 
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Synchronizing the Currency table  
 

1. In Microsoft Navision, on the Administration menu, click 
APPLICATION SETUP→COMMERCE PORTAL→PERIODIC 
ACTIVITIES→SYNCHRONIZATION. The Synchronized Tables List 
window appears. 

2. Click the line containing Currency (table 4).  

3. Click FUNCTIONS→FORCE SYNCHRONIZATION. A dialog box appears 
asking if you want to force synchronization of the Item table. Click 
Yes. 

Verifying That there Are Error Messages in the Error Message Queue 
 

1. On your Desktop, right-click My Computer and click Manage. 

2. Expand Services and Applications, click Message Queuing and 
then click Private Queues. The list of Private Queues appears. 

3. Resize the window so you can see the Messages column in the right 
pane. 

4. Press F5 to refresh.  

5. Verify that there are messages in the Synch. message queue. 

There are twice as many messages in the Error message queue as in the Synch. 
message queue because the Navision Commerce Portal synchronization creates a 
message containing the error description for each message, and also sends this to 
the Error message queue. 

Resetting Commerce Portal Setup. 
 

1. In Microsoft Navision, on the Administration menu, click 
APPLICATION SETUP→COMMERCE PORTAL→COMMERCE PORTAL SETUP. 
The Commerce Portal Setup window appears. 

2. Click the Communication tab.  

3. In the Initial Catalog field, enter the correct name of the catalog this 
is used on your Web portal, for example, 
CommercePortal_COMMERCE. 

Restarting Navision Commerce Portal Synchronization  
 

1. On your Desktop, right-click My Computer and click Manage. 

2. Expand Services and Applications and click Services. 

3. Right-click Navision Commerce Portal Synchronization and click 
Restart. 
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Synchronizing the Currency Table 
 

1. In Microsoft Navision, on the Administration menu, click 
APPLICATION SETUP→COMMERCE PORTAL→PERIODIC 
ACTIVITIES→SYNCHRONIZATION. The Synchronized Tables List 
window appears. 

2. Click the line containing Currency (table 4).  

3. Click FUNCTIONS→FORCE SYNCHRONIZATION. A dialog box appears 
asking if you want to force synchronization of the Item table. Click 
Yes. 

Verifying That there Are No New Error Messages in the Error 
Message Queue 
 

1. On your Desktop, right-click My Computer and click Manage. 

2. Expand Services and Applications, click Message Queuing and 
then click Private Queues. The list of Private Queues appears. 

3. Resize the window so you can see the Messages column in the right 
pane. 

4. Press F5 to refresh.  

5. Verify that there are no messages in the Synch. message queue. 

The messages have been picked up by the Navision Commerce Portal 
Synchronization service and sent to SQL Server. 

Exercise − Troubleshooting Navision Application Server  
You can use the previous exercise to test whether the Navision Application 
Server is the cause of an unsuccessful synchronization. This is the case if you can 
see the data in the SynchMgt. Message Queue table (6224). 
 
You can then check to see if the Navision Application Server is running before 
you start the following exercise.  
 
If the Navision Application Server is running, you can also check the database 
information in Microsoft Navision to verify that you are using the correct 
connections.  
 

1. In Microsoft Navision, on the File menu, click DATABASE→ 
INFORMATION. The Database Information window appears. 

2. Click the Connection tab and verify that the client is connected to 
the server. 

3. Click the Sessions tab and verify that there are two current sessions, 
one for the Navision Application Server and one for the Client. Both 
of these sessions should be using Windows login. 
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Another cause of trouble with the Navision Application Server can be that the 
CPHandler.dll is not registered properly. This results in a warning event for 
computername-CLASSIC. You can view the event using the Event Viewer in the 
Computer Management window.  
 
This event has the following description: 
 
Trigger 99 in Codeunit 1 does not exist.  
This trigger must be executed to establish connection to 
the Message Bus. 

 
In the following diagram, you can see that Navision Application Server depends 
on the CPHandler.dll in order to initiate the QueueHandler. 
 

 
 
You need to register the CPHandler.dll again. 
 

4. On the Start menu, click Run and enter 
regsvr32"C:\ProgramFiles\Navision\Client\CPHandler.dll".  

5. Restart the computer. 
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Monitoring the Status of Commerce Portal 
When users browse your Web portal, SQL Server and Microsoft Navision create 
and process a number of messages through Microsoft Commerce Server. 
 
To maintain Commerce Portal, you must: 
 

• Monitor the Commerce Portal status. 
• Delete expired or rejected quotes. 
• Handle unprocessable messages. 
• Monitor the message log. 

 

Commerce Portal Status 
The status of Commerce Portal can be divided into two categories: 
 

• Sales related to Commerce Portal 
• Communication between SQL Server and Microsoft Navision 

 
The sales and communication status of Commerce Portal is monitored from the 
Commerce Portal Status window. 
 
On the Sales tab you can monitor the number of sales quotes that have been: 
 

• Accepted by the customer. 
• Expired before the customer request. 
• Rejected by you or one of your colleagues. 

 
On the Communication tab you can monitor: 
 

• Unprocessable e-mail messages. 
• Pictures and records that need to be updated or synchronized with 

SQL Server. 
 
Each field has an AssistButton which lets you view the message queues. 
 
Unprocessable e-mail messages can be deleted or modified, and then processed 
manually in the E-Mail Queue window, or you can modify the e-mail message, 
and then send it again. 
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Deleting Expired or Rejected Quotes 
In time, a number of sales quotes will be created through your Web portal. The 
customer may never accept some of these sales quotes, and therefore they will 
expire. Other sales quotes may be incorrectly filled in, or there may be other 
reasons why you want to reject them. 
 
Therefore, a number of invalid sales quotes will be registered in your Microsoft 
Navision Sales & Marketing, Order Processing area. You can, of course, delete 
the sales quotes manually as you would delete any other sales quote, however the 
Commerce Portal solution provides a batch job that can delete several expired 
and/or rejected sales quotes at once. 

Exercises 
In these exercises, you use the Delete Expired or Rejected Quotes batch job to 
maintain your Commerce Portal. First, enter the required information about 
yourself in the Web portal so that Microsoft Navision can create a new Customer 
card, a contact person card and a sales quote for you. Open your Web portal and 
place an order. Then go back to Microsoft Navision and reject the newly created 
sales quote, and finally, you will delete the rejected sales quote. 

Registering as a New Customer  
Because you have not signed in to your Web portal, you are an unknown 
customer. Therefore you have to register as a new customer on your Web portal. 
 

1. Open your browser. 

2. In the Commerce Portal window, click Register. 

3. Fill in the fields as followed: 

 
Field Value 
Name Dan Jump 
Street Name and 
Number Hollywood Blvd. 102 
Town/City Los Angeles 
Country USA 
Phone No. 555-555-1234 
E-Mail Dan.jump@cronuscorp.net  
Login Name danjump1 
Password djump1 
Confirm Password djump1 

 
4. Click Submit. 
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Placing an Order and Accepting Purchases 
Create an order for the following items: Item No. 1968 GRENOBLE 
Whiteboard, red; and Item No. 1928-W, ST.MORITZ Storage Unit/Drawers. 
 

1. In the Commerce Portal window, in the Login Name field, enter 
danjump1. 

2. In the Password field, enter djump1. 

3. Under Catalog Categories, click Whiteboards. 

4. Click 1968-W: GRENOBLE Whiteboard, red. 

5. Click Add to Shopping Cart. 

6. Click Catalog. 

7. Under Catalog Categories, click Storage Units. 

8. Click 1928-W: ST.MORITZ Storage Unit/Drawers. 

9. Click Add to Shopping Cart. 

10. In the Select items to buy now window, click Continue. 

11. In the Select Address window, click Continue. 

12. In the Order Confirmation window, click Purchase. 

 
NOTE: A credit card may be required at this point. Attempt to enter a fake credit card 
number (5555555555555555) and if you are unable to finish this purchase, close the 
browser. You will not be able to complete the next two exercises but you can still look 
at the forms. 

 

Locating and Rejecting Sales Quotes 
 

1. In Microsoft Navision, on the Sales & Marketing menu, click ORDER 
PROCESSING→QUOTES. Locate the sales quote that has just been 
created.  

2. Click FUNCTIONS→COMMERCE PORTAL→REJECT to reject the quote.  

3. The sales quote has been rejected.  

4. Click the Commerce Portal tab. The CP Status field displays the 
status of this Sales Quote. 
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Deleting Rejected Sales Quotes 
 

1. In Microsoft Navision, on the Administration menu, click 
APPLICATION SETUP→COMMERCE PORTAL→PERIODIC 
ACTIVITIES→COMMERCE PORTAL STATUS. The Commerce Portal Status 
window appears. 

2. Click COMMERCE PORTAL→DELETE EXPIRED OR REJECTED QUOTES. The 
Delete Expd./Rejected Qte. batch job window appears. 

3. Click the Options tab and select the Delete Rejected Quotes option. 

4. Click OK to start the batch job. 

When the batch job has finished, on the Sales & Marketing menu, click ORDER 
PROCESSING→QUOTES to verify that the sales quote has been deleted. 

Unprocessable E-Mails 
The processing of e-mails in Commerce Portal might not succeed for a number of 
reasons. As a result, unprocessable e-mails are logged, and you can then process 
the e-mails manually. 
 
To examine unprocessable e-mail messages, follow this procedure: 
 

1. On the Administration menu, click APPLICATION SETUP→COMMERCE 
PORTAL→PERIODIC ACTIVITIES→COMMERCE PORTAL STATUS. The 
Commerce Portal Status window appears. 

 On the Communication tab, the No. of Unprocessed E-Mail Msgs. 
field contains the number of e-mail messages that have not been 
processed by the application server. 

2. To view a list of unprocessable e-mails, in the No. of Unprocessed 
E-Mail Msgs. field, click the AssistButton. The E-Mail Queue 
window appears: 
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 The E-Mail Queue window displays the e-mails that are not being 
processed by the application server. You have two possibilities to 
resend these e-mails: 

– Click the e-mail you want processed and click 
FUNCTIONS→RESEND MANUALLY. The e-mail will be sent from 
your own account and not from Microsoft Navision. 

– Select the e-mail that you want processed and click FUNCTIONS→ 
REPROCESS. The e-mail will be put back into the message queue 
and the application server will attempt to resend it. 

 
3. Click FUNCTIONS→REPROCESS to manually process any messages. 

Monitoring the Message Log 
If you have set up Commerce Portal to log all incoming and outgoing messages 
to and from the Web portal, you can view these in the Message Log window.  
 

1. To ensure that all communication is logged, on the Administration 
menu, click APPLICATION SETUP→COMMERCE PORTAL→APPLICATION 
SERVER CARD. The Application Server Card window appears. 

2. Click the Actions tab and select the Log Communication option. 

 All synchronization from Microsoft Navision to the SQL server, 
except from the picture synchronization, is logged. The 
synchronization is logged in the Message Log Header and the 
Message Log Lines tables.  

 In addition to the synchronization, the normal communication 
between the Web front and Microsoft Navision is also logged 
according to the set up. 

3. To view the message log, on the Administration menu, click IT 
ADMINISTRATION→COMMERCE PORTAL→COMMUNICATION→MESSAGE 
LOG. The Message Log window appears.  

 The header contains information about the time, subject and 
direction of the messages sent between Microsoft Navision and your 
Web portal. The Message Direction field shows whether the 
message in the log is incoming or outgoing. The lines show the 
content of the XML document that was transferred. 

4. To delete messages, on the Administration menu, click IT 
ADMINISTRATION→DATA DELETION→DELETE MESSAGE LOG ENTRIES. The 
Delete Message Log Entries window appears.  

 If you do not fill in the Filter fields, all entries will be deleted when 
you click OK. 
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Test Your Knowledge − Commerce Portal Architecture & 
Administration 

1. When you first install Commerce Portal, you have to ____________ 
_________________________________to initialize the SQL Server. 

 

2. The messages that cannot be processed by Navision Commerce 
Portal synchronization end up in the _________________________. 

 

3. All synchronization from Navision to the SQL Server, except the 
__________________________________________, will be logged 
in the Message Log. 

 

4. The ____________________________________________________ 
________________________________________ monitors the 
Synch. Message queue and processes all the messages in it. 

 

5. Synchronization between the Microsoft Navision database the SQL 
Server database is done through messages sent through ___________ 
_______________________________________________________. 

 

6. The Navision Application Server receives the job request messages 
from the _____________________________________. 

 

7. The status of Commerce Portal can be divided into two categories: 
_______________________________________________________
______________________________________________________. 

 

8. Synchronization is triggered by the Microsoft Navision C/SIDE 
triggers ________________________________________________. 

 

9. Data is stored in the ______________________________________ 
____________________________________ table when you run the 
Force Synchronization batch job or when you modify data in a table 
that contains synchronization data. 
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10. The ______________________________ retrieves the messages 
from the Navision Application Server and places them in the private 
Synch. Message queue.  

 

11. Commerce Portal is based on a four-tier model consisting of ______ 
_______________________________________________________ 
_______________________________________________________. 

 

12. One cause of trouble with the Navision Application Server may be 
that the CPHandler.dll is not ________________________ properly. 
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Quick Interaction: Lessons Learned 
Take a moment to write down three Key Points you have learned from this 
chapter: 
 
1. 

 

 

 

 

 
 
2. 

 

 

 

 

 
 
3. 
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APPENDIX A: TEST YOUR KNOWLEDGE 
SOLUTIONS 

Test Your Knowledge − Introduction to Commerce Portal 
(CH1) 

1. Before you can begin this course you must install Microsoft® 
Business Solutions−Navision®, Commerce Portal, and a number of 
Microsoft products. 

2. Name the two sets of clients involved in using Commerce Portal and 
describe their functions. 

– Microsoft Navision clients. These are connected to your 
company's local area network and are used by you and your 
colleagues. Microsoft Navision clients do not have to be 
dedicated specifically to the Commerce Portal. These clients can 
act as normal Microsoft Navision clients because all information 
requested or created through the Internet on your Web portal is 
processed like any other information in Microsoft Navision. 

– Web browsers. These are connected to the Internet and are used 
by the users of your Web portal. Web browser clients can be of 
any type and can be started from any platform. The design of 
your home page determines the requirements for Web browsers; 
for example, whether or not Web browsers have to support 
frames. 

 
3. Briefly describe some of the synchronization features between 

Microsoft Navision and Commerce Portal.  

 All data is maintained in Microsoft Navision. Data used in the Web 
portal is synchronized with Microsoft® SQL Server®. After the first 
synchronization is carried out, the SQL Server is synchronized every 
time you update information in Microsoft Navision that is relevant 
for the Commerce Portal. For example, changing the name of an item 
will automatically create a message that updates the item name in the 
SQL Server database. 

 When a user who is signed on your Web portal requests information 
about a specific item, the static data − such as item number and item 
name − is retrieved from the SQL Server database. By comparison, 
the variable data − such as item price and item availability − is 
retrieved from the Microsoft Navision database. 
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4. Name a few of the key features of Commerce Portal. 

– Data is maintained only in Microsoft Navision. 
– You can create multiple websites. 
– You can define the permissions for your Web portal users based 

on roles. 
– You can set up automatic email notifications to Web portal users 

and colleagues to provide them with updates on the handling of 
their sales or purchase order.  

– You can set up specific language-dependent text and 
descriptions, to be used on your Web portal. 

– You can increase the efficiency of your purchasing activity by 
listing items you want to order on your Web portal and inviting 
your vendors to participate in a reverse auction. 

– Web pages are maintained from within Microsoft Navision. 
– Commerce Portal has full integration with the rest of the 

Microsoft Navision Application. 
– Commerce Portal supports GIF and JPG picture formats. 

 
5. Do users need to learn a new interface in order to use Commerce 

Portal? Explain how data can be maintained in Microsoft Navision 
and Commerce Portal. 

 No, Microsoft Navision users do not need to familiarize themselves 
with a new user interface. From within Microsoft Navision, they can 
update the Web portal user and item information, handle sales 
quotes, sales orders, reverse auctions, and similar activities. 

 Customer information on the Customer card and Contact card can be 
maintained from the Web portal as well as from within Microsoft 
Navision. 

 All data relevant to the Commerce Portal is synchronized with 
(copied to) the SQL Server database so that the data is stored in both 
the Microsoft Navision database and the SQL Server database. The 
program automatically synchronizes the SQL Server database and, 
subsequently, the Web pages on the Web portal with the Microsoft 
Navision database. 

 
6. Explain when an email notification might be used. 

– To notify Web portal users of specific events, the status of their 
orders and offers, and their new password and/or user ID. 

– To notify you or your colleagues of information entered by users 
of your Web portal. 
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7. Briefly describe some of the integration between Microsoft Navision 

and Commerce Portal. 

 If a new customer places an order through your Web portal, their 
customer information will automatically be inserted in the Customer 
table in the Microsoft Navision database.  

 If an existing Web portal user places an order through your Web 
portal, they receive all discounts as indicated by their Customer card 
setup.  

 By using their user ID and password, each Web portal user can sign 
on to your Web portal and view their previously entered information.  

 Whenever you update your Item prices or names, or update the 
availability of an item, this data will be immediately updated on your 
Web portal.  

 An order placed on your Web portal is no different than one created 
from within Microsoft Navision.  

Test Your Knowledge − Setting up Microsoft Navision 
Commerce Portal (CH2) 

1. What are the two types of Notifications?  

– Internal notifications − to notify you or your colleagues 
– External notifications − to notify your Web portal users 

 
2. What does setting up Commerce Portal include? 

– Information about your country, local currency, and decimal 
symbol. 

– Information about where to store pictures on the Web server as 
well as information used to communicate with the SQL Server. 

– Information about the Number Series to be used for Commerce 
Portal-initiated entries. 

 
3. What do you need in order to create new Web Templates? 

 You must have an ASP programmer set up ASP pages to determine 
the structure and layout of your website. When you have completed 
the setup of your Commerce Portal and your website, you are ready 
to create Web Templates by running the Create Web Template batch 
job. 
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4. Before using Commerce Portal, what will you need to enter and set 
up? 

 You must enter basic setup information that will apply to all of your 
websites. You also have to set up a website, roles, notification 
processes, Web Templates, synchronization, requests, and the 
Navision Application Server. 

 
5. When setting up your website, what information must the website 

card contain? 

– The address of your homepage. 
– The path to the ASP files on the Web server. 
– A quote expiration calculation formula. 
– The profiles of template users. 
– Notification codes and processes. 
– Number Series for users and orders created through your Web 

portal. 
 

6. Briefly explain Web Templates. 

 A Web Template in Commerce Portal is similar to a template in a 
word processing application. It is a document that contains 
formatting and sometimes generic text or other content. However, 
most of the content will be filled in on the specific Web page.  

 A website can contain any number of Web Templates. A Web 
Template can be used as a pattern for creating many Web pages. 
Each Web Template is based on an ASP page located on the Web 
server. 

 
7. What are the four areas that the Commerce Portal framework is built 

upon? 

 Web portal, Web Sites, Web Templates, and Web Pages 

 
8. What are the seven property types found on the Properties Template? 

 Text, Date, Time, Number, Picture, Link, and Subproperties 

 
9. What is the Navision Application Server used for with Commerce 

Portal? 

 In Commerce Portal, the Navision Application Server is used to 
handle the communication between Navision and the Web portal. 
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10. Define Permissions and Web portal Roles. 

 Each permission grants the Web user authorization to perform a task 
or a part of a task on your Web portal. 

 Web portal Roles are a collection of different permissions that allow 
Web portal users to perform different tasks, such as business, 
maintenance, or administrative activities. 

Test Your Knowledge − Setting up Web Pages (CH3) 
True False  
 ⌧  � 1. After a Web page has been created, you need to fill in or 

adjust the values of the properties.
 
 �  ⌧ 2. There are three two types of hyperlinks in Commerce Portal. 
 
 ⌧  � 3. Pictures can be imported into Commerce Portal if they are 

either GIF or JPEG format. 
 
 ⌧  � 4. You can create multiple Web Pages based on the same Web 

Template. 
 
 �  ⌧ 5. The Type Value field of the Hyperlink contains the actual 

link. 
 
 ⌧  � 6. Each of your Web Pages is based on a Web Template. 
 
 �  ⌧ 7. Web Pages refer to each other using Page References 

hyperlinks.  
 
 �  ⌧ 8. Each Web Page has a set of properties defined by the Web 

Template. Therefore, you can cannot add additional 
properties to a Web page. 
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Test Your Knowledge − Setting up Items and Customers 
(CH4) 

1. In the Catalog Editor, you select the Searchable option to include the 
category in your index. 

 
2. You use the Class field on the Item Card to group your items on your 

Web portal. 

 
3. The function used to synchronize the Item table to SQL Server 

database is called Force Synchronization. 

 
4. The requests from your customers with the highest priority will be 

processed first. 

 
5. Your Web portal contains an electronic product catalog to sell the 

item that you plan to sell. 

 
6. You can disable your Web portal users by using the Remove from 

Web portal function. 

 
7. The notification process assists in letting your customers know the 

status of their orders automatically by e-mail. 

 
8. The catalogs that display your items on the Web portal are created 

and maintained in Microsoft Commerce Server Catalog 
Management. 
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Test Your Knowledge − Working with Reverse Auction (CH5) 
1. All information about Web portal users is maintained on related 

Contact Person cards. 

 
2. The Reverse Auction Participant field must be checked on the 

Vendor card in order to eligible for a reverse auction, in addition to a 
Web portal login ID and password. 

 
3. A reverse auction is when you put a demand for purchasing products 

to one or more vendors on the Web portal

 
4. The winner of the auction is selected by running the Select Vendor 

function. 

5. A public reverse auction results in an open reverse auction, where 
participating vendors are able to follow the auction progress. 

Test Your Knowledge − Commerce Portal Architecture & 
Administration (CH6) 

1. When you first install Commerce Portal, you have to force 
synchronization to initialize the SQL Server. 

 
2. The messages that cannot be processed by Navision Commerce 

Portal synchronization end up in the Error Message Queue. 

 
3. All synchronization from Navision to the SQL Server, except the 

picture synchronization, will be logged in the Message Log. 

 
4. The Navision Commerce Portal Synchronization service monitors 

the Synch. Message queue and processes all the messages in it. 

 
5. Synchronization between the Microsoft Navision database the SQL 

Server database is done through messages sent through Microsoft 
Message Queuing (MSMQ).

 
6. The Navision Application Server receives the job request messages 

from the CPHandler. 

 

Page 107 



 

 

Microsoft Navision Commerce Portal 

7. The status of Commerce Portal can be divided into two categories: 
Sales related to Commerce Portal and Communication between SQL 
Server and Navision.

 
8. Synchronization is triggered by the Microsoft Navision C/SIDE 

triggers OnInsert, OnModify, OnRename and OnDelete. 

 
9. Data is stored in the SynchMgt. Message Queue table when you run 

the Force Synchronization batch job or when you modify data in a 
table that contains synchronization data. 

 
10. The CPHandler.dll retrieves the messages from the Navision 

Application Server and places them in the private Synch. Message 
queue.  

 
11. Commerce Portal is based on a four-tier model consisting of a Web 

front, a communication layer, a Navision Application layer and a 
Microsoft Navision backend.

 
12. One cause of trouble with the Navision Application Server may be 

that the CPHandler.dll is not registered properly. 
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